All of lore.kernel.org
 help / color / mirror / Atom feed
From: Guenter Roeck <linux@roeck-us.net>
To: "Matwey V. Kornilov" <matwey@sai.msu.ru>,
	Jean Delvare <jdelvare@suse.com>,
	Rob Herring <robh+dt@kernel.org>,
	"open list:HARDWARE MONITORING" <linux-hwmon@vger.kernel.org>,
	"open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS" 
	<devicetree@vger.kernel.org>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 1/4] hwmon: lm75: Add lm75 to of_match list
Date: Sat, 6 Feb 2021 08:46:16 -0800	[thread overview]
Message-ID: <164495f0-9b53-2523-f178-bd52bbb40ae6@roeck-us.net> (raw)
In-Reply-To: <20210206095121.20625-2-matwey@sai.msu.ru>

On 2/6/21 1:51 AM, Matwey V. Kornilov wrote:
> Currently, many boards use just 'lm75' as a compatible string.
> 
> Signed-off-by: Matwey V. Kornilov <matwey@sai.msu.ru>
> ---
>  Documentation/devicetree/bindings/hwmon/lm75.yaml | 1 +
>  drivers/hwmon/lm75.c                              | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/hwmon/lm75.yaml b/Documentation/devicetree/bindings/hwmon/lm75.yaml
> index 96eed5cc7841..aec8edd1e0c6 100644
> --- a/Documentation/devicetree/bindings/hwmon/lm75.yaml
> +++ b/Documentation/devicetree/bindings/hwmon/lm75.yaml
> @@ -13,6 +13,7 @@ maintainers:
>  properties:
>    compatible:
>      enum:
> +      - lm75

Please split the .yaml file changes into a single patch, separate
from the code changes. Also please make sure that the subject indicates
that this is a bindings change.

For this change, we'll definitely need feedback from Rob. I am not sure
if such a generic compatible string is permitted or if we need to change
the dts files instead.

On a higher level, while lm75 is an extreme case, I see a few other
violators as well.

drivers/macintosh/windfarm_ad7417_sensor.c:     { .compatible = "ad7417", },
drivers/macintosh/windfarm_max6690_sensor.c:    { .compatible = "max6690", },
arch/arm/boot/dts/socfpga_arria10_socdk.dtsi:           compatible = "ltc2977";
arch/arm/boot/dts/aspeed-bmc-arm-centriq2400-rep.dts:                           compatible = "tmp421";
arch/arm/boot/dts/nuvoton-npcm750-evb.dts:              compatible = "tmp100";
arch/arm/boot/dts/nuvoton-npcm750-evb.dts:              compatible = "tmp100";

so it would be good to know how to handle those in general.

Note that there is also:

Documentation/devicetree/bindings/display/repaper.txt:          compatible = "lm75b";

but maybe that doesn't matter as much since it is not actually
used in dts files.

Thanks,
Guenter

  reply	other threads:[~2021-02-06 16:47 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-30 10:38 [PATCH 1/2] hwmon: lm75: Add NXP LM75A to of_match list Matwey V. Kornilov
2021-01-30 10:38 ` [PATCH 2/2] hwmon: lm75: Add another name for NXP LM75B " Matwey V. Kornilov
2021-01-30 15:41 ` [PATCH 1/2] hwmon: lm75: Add NXP LM75A " Guenter Roeck
     [not found]   ` <CAJs94EbBAK1LAZt4pfbzbUCxJtRo8kTAxdaN=y_gRbuvX0rz8Q@mail.gmail.com>
2021-02-03 19:57     ` Guenter Roeck
2021-02-06  9:51       ` [PATCH v4 0/4] hwmon: lm75: Handle broken device nodes gracefully Matwey V. Kornilov
2021-02-06  9:51         ` [PATCH v4 1/4] hwmon: lm75: Add lm75 to of_match list Matwey V. Kornilov
2021-02-06 16:46           ` Guenter Roeck [this message]
2021-02-10 19:47             ` Rob Herring
2021-02-06  9:51         ` [PATCH v4 2/4] hwmon: lm75: Add nxp,lm75a " Matwey V. Kornilov
2021-02-06 16:48           ` Guenter Roeck
2021-02-06 16:54             ` Guenter Roeck
2021-02-06  9:51         ` [PATCH v4 3/4] hwmon: lm75: Add ti,lm75 " Matwey V. Kornilov
2021-02-06 16:54           ` Guenter Roeck
2021-02-06  9:51         ` [PATCH v4 4/4] hwmon: lm75: Handle broken device nodes gracefully Matwey V. Kornilov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=164495f0-9b53-2523-f178-bd52bbb40ae6@roeck-us.net \
    --to=linux@roeck-us.net \
    --cc=devicetree@vger.kernel.org \
    --cc=jdelvare@suse.com \
    --cc=linux-hwmon@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=matwey@sai.msu.ru \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.