All of lore.kernel.org
 help / color / mirror / Atom feed
From: "NeilBrown" <neilb@suse.de>
To: "Jeff Layton" <jlayton@kernel.org>
Cc: "Christian Brauner" <brauner@kernel.org>,
	"Alexander Viro" <viro@zeniv.linux.org.uk>,
	"Eric Van Hensbergen" <ericvh@kernel.org>,
	"Latchesar Ionkov" <lucho@ionkov.net>,
	"Dominique Martinet" <asmadeus@codewreck.org>,
	"Christian Schoenebeck" <linux_oss@crudebyte.com>,
	"David Howells" <dhowells@redhat.com>,
	"Marc Dionne" <marc.dionne@auristor.com>,
	"Xiubo Li" <xiubli@redhat.com>,
	"Ilya Dryomov" <idryomov@gmail.com>,
	"Alexander Aring" <aahringo@redhat.com>,
	"David Teigland" <teigland@redhat.com>,
	"Miklos Szeredi" <miklos@szeredi.hu>,
	"Andreas Gruenbacher" <agruenba@redhat.com>,
	"Trond Myklebust" <trond.myklebust@hammerspace.com>,
	"Anna Schumaker" <anna@kernel.org>,
	"Chuck Lever" <chuck.lever@oracle.com>,
	"Olga Kornievskaia" <kolga@netapp.com>,
	"Dai Ngo" <Dai.Ngo@oracle.com>, "Tom Talpey" <tom@talpey.com>,
	"Jan Kara" <jack@suse.cz>, "Mark Fasheh" <mark@fasheh.com>,
	"Joel Becker" <jlbec@evilplan.org>,
	"Joseph Qi" <joseph.qi@linux.alibaba.com>,
	"Steve French" <sfrench@samba.org>,
	"Paulo Alcantara" <pc@manguebit.com>,
	"Ronnie Sahlberg" <lsahlber@redhat.com>,
	"Shyam Prasad N" <sprasad@microsoft.com>,
	"Namjae Jeon" <linkinjeon@kernel.org>,
	"Sergey Senozhatsky" <senozhatsky@chromium.org>,
	"Steven Rostedt" <rostedt@goodmis.org>,
	"Masami Hiramatsu" <mhiramat@kernel.org>,
	"Mathieu Desnoyers" <mathieu.desnoyers@efficios.com>,
	linux-kernel@vger.kernel.org, v9fs@lists.linux.dev,
	linux-afs@lists.infradead.org, ceph-devel@vger.kernel.org,
	gfs2@lists.linux.dev, linux-fsdevel@vger.kernel.org,
	linux-nfs@vger.kernel.org, ocfs2-devel@lists.linux.dev,
	linux-cifs@vger.kernel.org, samba-technical@lists.samba.org,
	linux-trace-kernel@vger.kernel.org,
	"Jeff Layton" <jlayton@kernel.org>
Subject: Re: [PATCH 01/20] filelock: split common fields into struct file_lock_core
Date: Wed, 17 Jan 2024 09:07:02 +1100	[thread overview]
Message-ID: <170544282220.23031.10628392788633554158@noble.neil.brown.name> (raw)
In-Reply-To: <20240116-flsplit-v1-1-c9d0f4370a5d@kernel.org>

On Wed, 17 Jan 2024, Jeff Layton wrote:
> In a future patch, we're going to split file leases into their own
> structure. Since a lot of the underlying machinery uses the same fields
> move those into a new file_lock_core, and embed that inside struct
> file_lock.
> 
> Signed-off-by: Jeff Layton <jlayton@kernel.org>
> ---
>  include/linux/filelock.h | 9 +++++++--
>  1 file changed, 7 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/filelock.h b/include/linux/filelock.h
> index 95e868e09e29..7825511c1c11 100644
> --- a/include/linux/filelock.h
> +++ b/include/linux/filelock.h
> @@ -85,8 +85,9 @@ bool opens_in_grace(struct net *);
>   *
>   * Obviously, the last two criteria only matter for POSIX locks.
>   */
> -struct file_lock {
> -	struct file_lock *fl_blocker;	/* The lock, that is blocking us */
> +
> +struct file_lock_core {
> +	struct file_lock *fl_blocker;	/* The lock that is blocking us */
>  	struct list_head fl_list;	/* link into file_lock_context */
>  	struct hlist_node fl_link;	/* node in global lists */
>  	struct list_head fl_blocked_requests;	/* list of requests with
> @@ -102,6 +103,10 @@ struct file_lock {
>  	int fl_link_cpu;		/* what cpu's list is this on? */
>  	wait_queue_head_t fl_wait;
>  	struct file *fl_file;
> +};
> +
> +struct file_lock {
> +	struct file_lock_core fl_core;
>  	loff_t fl_start;
>  	loff_t fl_end;
>  

If I we doing this, I would rename all the fields in file_lock_core to
have an "flc_" prefix, and add some #defines like

 #define fl_list fl_core.flc_list

so there would be no need to squash this with later patches to achieve
bisectability.

The #defines would be removed after the coccinelle scripts etc are
applied.

I would also do the "convert some internal functions" patches *before*
the bulk conversion of fl_foo to fl_code.flc_foo so that those functions
don't get patched twice.

But this is all personal preference.  If you prefer your approach,
please leave it that way.  The only clear benefit of my approach is that
you don't need to squash patches together, and that is probably not a
big deal.

Thanks,
NeilBrown

  reply	other threads:[~2024-01-16 22:07 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-01-16 19:45 [PATCH 00/20] filelock: split struct file_lock into file_lock and file_lease structs Jeff Layton
2024-01-16 19:45 ` [PATCH 01/20] filelock: split common fields into struct file_lock_core Jeff Layton
2024-01-16 22:07   ` NeilBrown [this message]
2024-01-17 12:46     ` Jeff Layton
2024-01-16 19:45 ` [PATCH 02/20] filelock: add coccinelle scripts to move fields to " Jeff Layton
2024-01-16 19:45 ` [PATCH 03/20] filelock: the results of the coccinelle conversion Jeff Layton
2024-01-17 15:10   ` Chuck Lever
2024-01-16 19:46 ` [PATCH 04/20] filelock: fixups after the coccinelle changes Jeff Layton
2024-01-17 15:13   ` Chuck Lever
2024-01-16 19:46 ` [PATCH 05/20] filelock: convert some internal functions to use file_lock_core instead Jeff Layton
2024-01-16 19:46 ` [PATCH 06/20] filelock: convert more internal functions to use file_lock_core Jeff Layton
2024-01-16 19:46 ` [PATCH 07/20] filelock: make posix_same_owner take file_lock_core pointers Jeff Layton
2024-01-16 19:46 ` [PATCH 08/20] filelock: convert posix_owner_key to take file_lock_core arg Jeff Layton
2024-01-16 19:46 ` [PATCH 09/20] filelock: make locks_{insert,delete}_global_locks " Jeff Layton
2024-01-16 19:46 ` [PATCH 10/20] filelock: convert locks_{insert,delete}_global_blocked Jeff Layton
2024-01-16 19:46 ` [PATCH 11/20] filelock: convert the IS_* macros to take file_lock_core Jeff Layton
2024-01-16 22:16   ` NeilBrown
2024-01-17 12:32     ` Jeff Layton
2024-01-16 19:46 ` [PATCH 12/20] filelock: make __locks_delete_block and __locks_wake_up_blocks " Jeff Layton
2024-01-16 22:23   ` NeilBrown
2024-01-17 12:40     ` Jeff Layton
2024-01-16 19:46 ` [PATCH 13/20] filelock: convert __locks_insert_block, conflict and deadlock checks to use file_lock_core Jeff Layton
2024-01-16 22:32   ` NeilBrown
2024-01-17 12:42     ` Jeff Layton
2024-01-16 19:46 ` [PATCH 14/20] filelock: convert fl_blocker to file_lock_core Jeff Layton
2024-01-16 19:46 ` [PATCH 15/20] filelock: clean up locks_delete_block internals Jeff Layton
2024-01-16 19:46 ` [PATCH 16/20] filelock: reorganize locks_delete_block and __locks_insert_block Jeff Layton
2024-01-16 19:46 ` [PATCH 17/20] filelock: make assign_type helper take a file_lock_core pointer Jeff Layton
2024-01-16 19:46 ` [PATCH 18/20] filelock: convert locks_wake_up_blocks to " Jeff Layton
2024-01-16 19:46 ` [PATCH 19/20] filelock: convert locks_insert_lock_ctx and locks_delete_lock_ctx Jeff Layton
2024-01-16 19:46 ` [PATCH 20/20] filelock: split leases out of struct file_lock Jeff Layton
2024-01-16 22:44   ` NeilBrown
2024-01-17 12:45     ` Jeff Layton
2024-01-17 12:48 ` [PATCH 00/20] filelock: split struct file_lock into file_lock and file_lease structs Christian Brauner
2024-01-17 12:59   ` Jeff Layton
2024-01-17 13:25 ` [PATCH 02/20] filelock: add coccinelle scripts to move fields to struct file_lock_core David Howells
2024-01-17 13:40   ` Jeff Layton
2024-01-17 15:12 ` [PATCH 00/20] filelock: split struct file_lock into file_lock and file_lease structs Chuck Lever
2024-01-17 17:32   ` Jeff Layton
2024-01-17 18:59   ` NeilBrown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=170544282220.23031.10628392788633554158@noble.neil.brown.name \
    --to=neilb@suse.de \
    --cc=Dai.Ngo@oracle.com \
    --cc=aahringo@redhat.com \
    --cc=agruenba@redhat.com \
    --cc=anna@kernel.org \
    --cc=asmadeus@codewreck.org \
    --cc=brauner@kernel.org \
    --cc=ceph-devel@vger.kernel.org \
    --cc=chuck.lever@oracle.com \
    --cc=dhowells@redhat.com \
    --cc=ericvh@kernel.org \
    --cc=gfs2@lists.linux.dev \
    --cc=idryomov@gmail.com \
    --cc=jack@suse.cz \
    --cc=jlayton@kernel.org \
    --cc=jlbec@evilplan.org \
    --cc=joseph.qi@linux.alibaba.com \
    --cc=kolga@netapp.com \
    --cc=linkinjeon@kernel.org \
    --cc=linux-afs@lists.infradead.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-trace-kernel@vger.kernel.org \
    --cc=linux_oss@crudebyte.com \
    --cc=lsahlber@redhat.com \
    --cc=lucho@ionkov.net \
    --cc=marc.dionne@auristor.com \
    --cc=mark@fasheh.com \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mhiramat@kernel.org \
    --cc=miklos@szeredi.hu \
    --cc=ocfs2-devel@lists.linux.dev \
    --cc=pc@manguebit.com \
    --cc=rostedt@goodmis.org \
    --cc=samba-technical@lists.samba.org \
    --cc=senozhatsky@chromium.org \
    --cc=sfrench@samba.org \
    --cc=sprasad@microsoft.com \
    --cc=teigland@redhat.com \
    --cc=tom@talpey.com \
    --cc=trond.myklebust@hammerspace.com \
    --cc=v9fs@lists.linux.dev \
    --cc=viro@zeniv.linux.org.uk \
    --cc=xiubli@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.