All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: David Herrmann <dh.herrmann@gmail.com>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	DRI Development <dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH 10/20] drm/gem: fix up flink name create race
Date: Wed, 17 Jul 2013 20:38:55 +0200	[thread overview]
Message-ID: <20130717183855.GE4550@phenom.ffwll.local> (raw)
In-Reply-To: <CANq1E4RMBa2wU5nTEB9JWNz0EtZvzA+rtSNc=b++BRcccKKcxg@mail.gmail.com>

On Wed, Jul 17, 2013 at 06:38:35PM +0200, David Herrmann wrote:
> Hi
> 
> On Tue, Jul 16, 2013 at 9:12 AM, Daniel Vetter <daniel.vetter@ffwll.ch> wrote:
> > This is the 2nd attempt, I've always been a bit dissatisified with the
> > tricky nature of the first one:
> >
> > http://lists.freedesktop.org/archives/dri-devel/2012-July/025451.html
> >
> > The issue is that the flink ioctl can race with calling gem_close on
> > the last gem handle. In that case we'll end up with a zero handle
> > count, but an flink name (and it's corresponding reference). Which
> > results in a neat space leak.
> >
> > In my first attempt I've solved this by rechecking the handle count.
> > But fundamentally the issue is that ->handle_count isn't your usual
> > refcount - it can be resurrected from 0 among other things.
> >
> > For those special beasts atomic_t often suggest way more ordering that
> > it actually guarantees. To prevent being tricked by those hairy
> > semantics take the easy way out and simply protect the handle with the
> > existing dev->object_name_lock.
> >
> > With that change implemented it's dead easy to fix the flink vs. gem
> > close reace: When we try to create the name we simply have to check
> > whether there's still officially a gem handle around and if not refuse
> > to create the flink name. Since the handle count decrement and flink
> > name destruction is now also protected by that lock the reace is gone
> > and we can't ever leak the flink reference again.
> >
> > Outside of the drm core only the exynos driver looks at the handle
> > count, and tbh I have no idea why (it's just for debug dmesg output
> > luckily).
> >
> > I've considered inlining the drm_gem_object_handle_free, but I plan to
> > add more name-like things (like the exported dma_buf) to this scheme,
> > so it's clearer to leave the handle freeing in its own function.
> >
> > v2: Fix up the error path handling in handle_create and make it more
> > robust by simply calling object_handle_unreference.
> >
> > v3: Fix up the handle_unreference logic bug - atomic_dec_and_test
> > retursn 1 for 0. Oops.
> >
> > Cc: Inki Dae <inki.dae@samsung.com>
> > Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
> > ---
> >  drivers/gpu/drm/drm_gem.c               | 34 ++++++++++++++++++++-------------
> >  drivers/gpu/drm/drm_info.c              |  2 +-
> >  drivers/gpu/drm/exynos/exynos_drm_gem.c |  2 +-
> >  include/drm/drmP.h                      | 12 ++++++++++--
> >  4 files changed, 33 insertions(+), 17 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/drm_gem.c b/drivers/gpu/drm/drm_gem.c
> > index b07519e..14c70b5 100644
> > --- a/drivers/gpu/drm/drm_gem.c
> > +++ b/drivers/gpu/drm/drm_gem.c
> > @@ -140,7 +140,7 @@ int drm_gem_object_init(struct drm_device *dev,
> >                 return PTR_ERR(obj->filp);
> >
> >         kref_init(&obj->refcount);
> > -       atomic_set(&obj->handle_count, 0);
> > +       obj->handle_count = 0;
> >         obj->size = size;
> >
> >         return 0;
> > @@ -161,7 +161,7 @@ int drm_gem_private_object_init(struct drm_device *dev,
> >         obj->filp = NULL;
> >
> >         kref_init(&obj->refcount);
> > -       atomic_set(&obj->handle_count, 0);
> > +       obj->handle_count = 0;
> >         obj->size = size;
> >
> >         return 0;
> > @@ -227,11 +227,9 @@ static void drm_gem_object_handle_free(struct drm_gem_object *obj)
> >         struct drm_device *dev = obj->dev;
> >
> >         /* Remove any name for this object */
> > -       spin_lock(&dev->object_name_lock);
> >         if (obj->name) {
> >                 idr_remove(&dev->object_name_idr, obj->name);
> >                 obj->name = 0;
> > -               spin_unlock(&dev->object_name_lock);
> >                 /*
> >                  * The object name held a reference to this object, drop
> >                  * that now.
> > @@ -239,15 +237,13 @@ static void drm_gem_object_handle_free(struct drm_gem_object *obj)
> >                 * This cannot be the last reference, since the handle holds one too.
> >                  */
> >                 kref_put(&obj->refcount, drm_gem_object_ref_bug);
> > -       } else
> > -               spin_unlock(&dev->object_name_lock);
> > -
> > +       }
> >  }
> >
> >  void
> >  drm_gem_object_handle_unreference_unlocked(struct drm_gem_object *obj)
> >  {
> > -       if (WARN_ON(atomic_read(&obj->handle_count) == 0))
> > +       if (WARN_ON(obj->handle_count == 0))
> >                 return;
> >
> >         /*
> > @@ -256,8 +252,11 @@ drm_gem_object_handle_unreference_unlocked(struct drm_gem_object *obj)
> >         * checked for a name
> >         */
> >
> > -       if (atomic_dec_and_test(&obj->handle_count))
> > +       spin_lock(&obj->dev->object_name_lock);
> > +       if (--obj->handle_count == 0)
> >                 drm_gem_object_handle_free(obj);
> 
> If you inline this here, you can actually drop the huge comment for
> "caller still holds reference" as you call "object_unreference()"
> below, anyway. And with this patch, gem_object_handle_free() is pretty
> small, anyway.
> 
> I don't actually understand what you try to say in the commit message
> about new name-like stuff, but if you reuse it, it's fine.

Later patches will add a 2nd function call here to clean up dma-buf
referenes (that's the name-like stuff), so I've figured inlining actually
reduces code-readability in the end. Hence why I don't do this here.

> 
> > +       spin_unlock(&obj->dev->object_name_lock);
> > +
> >         drm_gem_object_unreference_unlocked(obj);
> >  }
> >
> > @@ -321,18 +320,21 @@ drm_gem_handle_create(struct drm_file *file_priv,
> >          * allocation under our spinlock.
> >          */
> >         idr_preload(GFP_KERNEL);
> > +       spin_lock(&dev->object_name_lock);
> >         spin_lock(&file_priv->table_lock);
> >
> >         ret = idr_alloc(&file_priv->object_idr, obj, 1, 0, GFP_NOWAIT);
> > -
> > +       drm_gem_object_reference(obj);
> > +       obj->handle_count++;
> >         spin_unlock(&file_priv->table_lock);
> > +       spin_unlock(&dev->object_name_lock);
> >         idr_preload_end();
> > -       if (ret < 0)
> > +       if (ret < 0) {
> > +               drm_gem_object_handle_unreference_unlocked(obj);
> >                 return ret;
> > +       }
> 
> The locking order isn't really documented.
> What's wrong with:
> 
> idr_preload(GFP_KERNEL);
> spin_lock(&file_priv->table_lock);
> ret = idr_alloc(&file_priv->object_idr, obj, 1, 0, GFP_NOWAIT);
> spin_unlock(&file_priv->table_lock);
> idr_preload_end();

At this spot a 2nd thread could sneak in with a gem_close (handle names
are easily guessable) which drops the handle reference and removes the
handle before we've fully set things up. End result is that we leak a
reference (since we decrement from 0 to -1 so won't treat it as the last
unref), and the handle_count++ later on here restores it to 0. But the
reference won't ever get cleaned up again.

Hence we need to protect the entire section from concurrent gem_close
calls.

> 
> if (ret < 0)
>         return ret;
> 
> spin_lock(&dev->object_name_lock);
> obj->handle_count++;
> spin_unlock(&dev->object_name_lock);
> drm_gem_object_reference(obj);
> 
> This is safe against flink() as we don't care whether flink() fails if
> user-space isn't even aware of the handle, yet. And if user-space
> already has a handle, then "handle_count" is >0, anyway.
> 
> And gem_object_handle_unreference can only be called if another handle
> exists (thus, handle_count > 0).
> 
> Or am I missing something?

See above, userspace can sneak in before we've actually incremented
handle_count.

> 
> >         *handlep = ret;
> >
> > -       drm_gem_object_reference(obj);
> > -       atomic_inc(&obj->handle_count);
> >
> >         if (dev->driver->gem_open_object) {
> >                 ret = dev->driver->gem_open_object(obj, file_priv);
> > @@ -499,6 +501,12 @@ drm_gem_flink_ioctl(struct drm_device *dev, void *data,
> >
> >         idr_preload(GFP_KERNEL);
> >         spin_lock(&dev->object_name_lock);
> > +       /* prevent races with concurrent gem_close. */
> > +       if (obj->handle_count == 0) {
> > +               ret = -ENOENT;
> > +               goto err;
> 
> spin_unlock(&dev->object_name_lock); ?

Oops, will fix.

> 
> Aside from the spin_unlock(), it's all a matter of taste, so:
>   Reviewed-by: David Herrmann <dh.herrmann@gmail.com>
> 
> Cheers
> David
> 
> > +       }
> > +
> >         if (!obj->name) {
> >                 ret = idr_alloc(&dev->object_name_idr, obj, 1, 0, GFP_NOWAIT);
> >                 if (ret < 0)
> > diff --git a/drivers/gpu/drm/drm_info.c b/drivers/gpu/drm/drm_info.c
> > index d4b20ce..f4b348c 100644
> > --- a/drivers/gpu/drm/drm_info.c
> > +++ b/drivers/gpu/drm/drm_info.c
> > @@ -207,7 +207,7 @@ static int drm_gem_one_name_info(int id, void *ptr, void *data)
> >
> >         seq_printf(m, "%6d %8zd %7d %8d\n",
> >                    obj->name, obj->size,
> > -                  atomic_read(&obj->handle_count),
> > +                  obj->handle_count,
> >                    atomic_read(&obj->refcount.refcount));
> >         return 0;
> >  }
> > diff --git a/drivers/gpu/drm/exynos/exynos_drm_gem.c b/drivers/gpu/drm/exynos/exynos_drm_gem.c
> > index 24c22a8..16963ca 100644
> > --- a/drivers/gpu/drm/exynos/exynos_drm_gem.c
> > +++ b/drivers/gpu/drm/exynos/exynos_drm_gem.c
> > @@ -135,7 +135,7 @@ void exynos_drm_gem_destroy(struct exynos_drm_gem_obj *exynos_gem_obj)
> >         obj = &exynos_gem_obj->base;
> >         buf = exynos_gem_obj->buffer;
> >
> > -       DRM_DEBUG_KMS("handle count = %d\n", atomic_read(&obj->handle_count));
> > +       DRM_DEBUG_KMS("handle count = %d\n", obj->handle_count);
> >
> >         /*
> >          * do not release memory region from exporter.
> > diff --git a/include/drm/drmP.h b/include/drm/drmP.h
> > index 2fb83b4..25da8e0 100644
> > --- a/include/drm/drmP.h
> > +++ b/include/drm/drmP.h
> > @@ -634,8 +634,16 @@ struct drm_gem_object {
> >         /** Reference count of this object */
> >         struct kref refcount;
> >
> > -       /** Handle count of this object. Each handle also holds a reference */
> > -       atomic_t handle_count; /* number of handles on this object */
> > +       /**
> > +        * handle_count - gem file_priv handle count of this object
> > +        *
> > +        * Each handle also holds a reference. Note that when the handle_count
> > +        * drops to 0 any global names (e.g. the id in the flink namespace) will
> > +        * be cleared.
> > +        *
> > +        * Protected by dev->object_name_lock.
> > +        * */
> > +       unsigned handle_count;
> >
> >         /** Related drm device */
> >         struct drm_device *dev;
> > --
> > 1.8.3.2
> >
> > _______________________________________________
> > dri-devel mailing list
> > dri-devel@lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

  reply	other threads:[~2013-07-17 18:38 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-07-16  7:11 [PATCH 00/20] prime/flink fixes and related stuff Daniel Vetter
2013-07-16  7:11 ` [PATCH 01/20] drm: use common drm_gem_dmabuf_release in i915/exynos drivers Daniel Vetter
2013-07-16  7:11 ` [PATCH 02/20] drm/i915: unpin backing storage in dmabuf_unmap Daniel Vetter
2013-07-16  7:11 ` [PATCH 03/20] drm/i915: explicit store base gem object in dma_buf->priv Daniel Vetter
2013-07-16  7:11 ` [PATCH 04/20] drm/prime: add a bit of documentation about gem_obj->import_attach Daniel Vetter
2013-07-22 22:56   ` Rob Clark
2013-07-16  7:11 ` [PATCH 05/20] drm/gem: remove drm_gem_object_handle_unreference Daniel Vetter
2013-07-23  1:17   ` Rob Clark
2013-07-16  7:11 ` [PATCH 06/20] drm/gem: inline drm_gem_object_handle_reference Daniel Vetter
2013-07-23 12:07   ` Rob Clark
2013-07-23 12:31     ` Daniel Vetter
2013-07-23 12:43       ` Rob Clark
2013-07-24  0:00         ` Dave Airlie
2013-07-24  5:23           ` Daniel Vetter
2013-07-16  7:11 ` [PATCH 07/20] drm/gem: move drm_gem_object_handle_unreference_unlocked into drm_gem.c Daniel Vetter
2013-07-16  7:11 ` [PATCH 08/20] drm/gem: remove bogus NULL check from drm_gem_object_handle_unreference_unlocked Daniel Vetter
2013-07-16  7:12 ` [PATCH 09/20] drm/gem: WARN about unbalanced handle refcounts Daniel Vetter
2013-07-16  7:12 ` [PATCH 10/20] drm/gem: fix up flink name create race Daniel Vetter
2013-07-17 16:38   ` David Herrmann
2013-07-17 18:38     ` Daniel Vetter [this message]
2013-07-24  6:04   ` [PATCH] " Daniel Vetter
2013-07-24  9:02     ` Daniel Vetter
2013-07-24 12:13       ` Daniel Vetter
2013-07-16  7:12 ` [PATCH 11/20] drm/prime: fix error path in drm_gem_prime_fd_to_handle Daniel Vetter
2013-07-16  7:12 ` [PATCH 12/20] drm/gem: make drm_gem_object_handle_unreference_unlocked static Daniel Vetter
2013-07-17 16:41   ` David Herrmann
2013-07-17 18:40     ` Daniel Vetter
2013-07-16  7:12 ` [PATCH 13/20] drm/gem: create drm_gem_dumb_destroy Daniel Vetter
2013-07-22 22:52   ` Rob Clark
2013-07-23  6:24   ` Laurent Pinchart
2013-07-23  7:15   ` Inki Dae
2013-08-01 11:41   ` Patrik Jakobsson
2013-07-16  7:12 ` [PATCH 14/20] drm/prime: use proper pointer in drm_gem_prime_handle_to_fd Daniel Vetter
2013-07-16  7:12 ` [PATCH 15/20] drm/prime: shrink critical section protected by prime lock Daniel Vetter
2013-07-16  7:12 ` [PATCH 16/20] drm/prime: clarify logic a bit in drm_gem_prime_fd_to_handle Daniel Vetter
2013-07-16  7:12 ` [PATCH 17/20] drm/gem: switch dev->object_name_lock to a mutex Daniel Vetter
2013-07-16  7:12 ` [PATCH 18/20] drm/gem: completely close gem_open vs. gem_close races Daniel Vetter
2013-07-24 12:21   ` Daniel Vetter
2013-07-16  7:12 ` [PATCH 19/20] drm/prime: proper locking+refcounting for obj->dma_buf link Daniel Vetter
2013-07-16  7:12 ` [PATCH 20/20] drm/prime: Simplify drm_gem_remove_prime_handles Daniel Vetter
2013-07-27  9:22 ` [PATCH 00/20] prime/flink fixes and related stuff Inki Dae
2013-08-04 17:41   ` Daniel Vetter
2013-08-05  2:02     ` Inki Dae
2013-08-05  7:43       ` Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130717183855.GE4550@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dh.herrmann@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.