All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: "Darrick J. Wong" <darrick.wong@oracle.com>
Cc: Christoph Hellwig <hch@lst.de>, linux-xfs@vger.kernel.org
Subject: Re: [PATCH 2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode
Date: Thu, 17 Aug 2017 09:44:22 +0200	[thread overview]
Message-ID: <20170817074422.GA24463@lst.de> (raw)
In-Reply-To: <20170816172130.GA4796@magnolia>

On Wed, Aug 16, 2017 at 10:21:30AM -0700, Darrick J. Wong wrote:
> On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> > Signed-off-by: Christoph Hellwig <hch@lst.de>
> > ---
> >  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
> >  fs/xfs/libxfs/xfs_defer.c | 4 ++--
> >  fs/xfs/libxfs/xfs_defer.h | 2 +-
> >  3 files changed, 4 insertions(+), 4 deletions(-)
> > 
> > diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> > index c09c16b1ad3b..24eba36ef818 100644
> > --- a/fs/xfs/libxfs/xfs_bmap.c
> > +++ b/fs/xfs/libxfs/xfs_bmap.c
> > @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
> >  	bi->bi_whichfork = whichfork;
> >  	bi->bi_bmap = *bmap;
> >  
> > -	error = xfs_defer_join(dfops, bi->bi_owner);
> > +	error = xfs_defer_join_inode(dfops, bi->bi_owner);
> 
> /me wonders if this should be named xfs_defer_ijoin to be more
> consistent with xfs_trans_ijoin, or if we should rename the other one to
> xfs_trans_join_inode instead?

Sure.  I'll resend with the __ prefix removed from __xfs_trans_roll
and this renamed to _ijoin.

Should I also rename xfs_trans_roll_inode to xfs_trans_roll_ijoin?

  reply	other threads:[~2017-08-17  7:44 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-13 14:42 explicitly join inodes to deferred operations Christoph Hellwig
2017-08-13 14:42 ` [PATCH 1/3] xfs: refactor xfs_trans_roll Christoph Hellwig
2017-08-15  1:36   ` Dave Chinner
2017-08-13 14:42 ` [PATCH 2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode Christoph Hellwig
2017-08-15  1:37   ` Dave Chinner
2017-08-16 17:21   ` Darrick J. Wong
2017-08-17  7:44     ` Christoph Hellwig [this message]
2017-08-17 16:22       ` Darrick J. Wong
2017-08-13 14:42 ` [PATCH 3/3] xfs: remove the ip argument to xfs_defer_finish Christoph Hellwig
2017-08-16 17:23   ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170817074422.GA24463@lst.de \
    --to=hch@lst.de \
    --cc=darrick.wong@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.