All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jeff King <peff@peff.net>
To: "Jean-Noël Avila" <jn.avila@free.fr>
Cc: git@vger.kernel.org, Jiang Xin <worldhello.net@gmail.com>
Subject: Re: [PATCH v2] l10n: reformat some localized strings for v2.23.0
Date: Sat, 3 Aug 2019 19:45:22 -0400	[thread overview]
Message-ID: <20190803234522.GA5417@sigill.intra.peff.net> (raw)
In-Reply-To: <20190803195907.3124-1-jn.avila@free.fr>

On Sat, Aug 03, 2019 at 09:59:07PM +0200, Jean-Noël Avila wrote:

> Signed-off-by: Jean-Noël Avila <jn.avila@free.fr>
> ---
>  builtin/checkout.c |  2 +-
>  builtin/fetch.c    | 15 +++++++++++----
>  2 files changed, 12 insertions(+), 5 deletions(-)
> 
> diff --git a/builtin/checkout.c b/builtin/checkout.c
> index 91f8509f85..08e19ed1ed 100644
> --- a/builtin/checkout.c
> +++ b/builtin/checkout.c
> @@ -1769,7 +1769,7 @@ int cmd_restore(int argc, const char **argv, const char *prefix)
>  	struct option *options;
>  	struct option restore_options[] = {
>  		OPT_STRING('s', "source", &opts.from_treeish, "<tree-ish>",
> -			   N_("where the checkout from")),
> +			   N_("where the checkout is from")),

I think your original "where to checkout from" is better.

As a native speaker, "where the checkout is from" implies that checkout
is a noun that is being described. But I think we want checkout to be a
verb (because we are talking about the operation), and the option tells
Git how to do that operation.

(I agree the original "where the checkout from" is nonsense).

> diff --git a/builtin/fetch.c b/builtin/fetch.c
> index 53ce99d2bb..0e8760e5d4 100644
> --- a/builtin/fetch.c
> +++ b/builtin/fetch.c
> @@ -850,6 +850,15 @@ static int iterate_ref_map(void *cb_data, struct object_id *oid)
>  	return 0;
>  }
>  
> +static char warn_show_forced_updates[] =
> +N_("Fetch normally indicates which branches had a forced update, but that\n"
> +   "check has been disabled. To re-enable, use '--show-forced-updates' flag\n"
> +   "or run 'git config fetch.showForcedUpdates true'.");

This one isn't a typo fix, right? It's just putting the two warning()
calls into a single message. I can see how this would be useful for
translators, but note that the output will be different. The original
would be something like:

  warning: Fetch normally indicates...
  warning: To re-enable...

where now we'd get:

  warning: Fetch normally indicates...
  check has been disabled...
  or run 'git config...

which might be a bit harder to read because the wrapped lines lose the
prefix. For advise() we nicely pick out the newlines and prefix each
line individually, but warning(), error(), etc, don't do that. Maybe
they should.

That's too big for this late in the -rc cycle, I think. In the meantime,
I'm not sure which (the original or your patch) is the least-bad
solution. :)

This change (if I am right that there's no actual typo fix) should
perhaps be in a separate patch from the earlier hunk, though.

-Peff

  reply	other threads:[~2019-08-03 23:45 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-30  3:35 [L10N] Kickoff for Git 2.23.0 round #1 Jiang Xin
2019-08-03 10:18 ` [RFC] l10n: fix some typos for v2.23.0 Jean-Noël Avila
2019-08-03 13:50   ` Jiang Xin
2019-08-03 19:59 ` [PATCH v2] l10n: reformat some localized strings " Jean-Noël Avila
2019-08-03 23:45   ` Jeff King [this message]
2019-08-04 11:01     ` Jean-Noël AVILA
2019-08-05  4:21       ` Jeff King
2019-08-05 18:49     ` Junio C Hamano
2019-08-05 21:15       ` Jeff King
2019-08-06 17:19 ` [PATCH v3] " Jean-Noël Avila
2019-08-06 17:54   ` Junio C Hamano
2019-08-06 18:10     ` Jeff King
2019-08-06 19:45     ` Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190803234522.GA5417@sigill.intra.peff.net \
    --to=peff@peff.net \
    --cc=git@vger.kernel.org \
    --cc=jn.avila@free.fr \
    --cc=worldhello.net@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.