All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Subject: [PULL 19/27] qapi: Improve reporting of invalid 'if' errors
Date: Sat, 28 Sep 2019 20:39:26 +0200	[thread overview]
Message-ID: <20190928183934.12459-20-armbru@redhat.com> (raw)
In-Reply-To: <20190928183934.12459-1-armbru@redhat.com>

Move check_if() from check_keys() to check_exprs() and call it later,
so its error messages gain an "in definition" line.

Checking values in a function named check_keys() is unclean anyway.
The original sin was commit 0545f6b887 "qapi: Better error messages
for bad expressions", which checks the value of key 'name'.  More
sinning in commit 2cbf09925a "qapi: More rigorous checking for type
safety bypass", commit c818408e44 "qapi: Implement boxed types for
commands/events", and commit 967c885108 "qapi: add 'if' to top-level
expressions".  This commit does penance for the latter.  The next
commits will do penance for the others.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
Message-Id: <20190927134639.4284-19-armbru@redhat.com>
---
 scripts/qapi/common.py                  | 4 ++--
 tests/qapi-schema/bad-if-empty-list.err | 1 +
 tests/qapi-schema/bad-if-empty.err      | 1 +
 tests/qapi-schema/bad-if-list.err       | 1 +
 tests/qapi-schema/bad-if.err            | 1 +
 5 files changed, 6 insertions(+), 2 deletions(-)

diff --git a/scripts/qapi/common.py b/scripts/qapi/common.py
index 2e1d8158d6..8f96974f85 100644
--- a/scripts/qapi/common.py
+++ b/scripts/qapi/common.py
@@ -925,8 +925,6 @@ def check_keys(expr, info, meta, required, optional=[]):
             raise QAPISemError(info,
                                "'%s' of %s '%s' should only use true value"
                                % (key, meta, name))
-        if key == 'if':
-            check_if(expr, info)
 
 
 def normalize_enum(expr):
@@ -1028,6 +1026,8 @@ def check_exprs(exprs):
         else:
             assert False, 'unexpected meta type'
 
+        check_if(expr, info)
+
         if doc:
             doc.check_expr(expr)
 
diff --git a/tests/qapi-schema/bad-if-empty-list.err b/tests/qapi-schema/bad-if-empty-list.err
index 75fe6497bc..2218c9279b 100644
--- a/tests/qapi-schema/bad-if-empty-list.err
+++ b/tests/qapi-schema/bad-if-empty-list.err
@@ -1 +1,2 @@
+tests/qapi-schema/bad-if-empty-list.json: In struct 'TestIfStruct':
 tests/qapi-schema/bad-if-empty-list.json:2: 'if' condition [] is useless
diff --git a/tests/qapi-schema/bad-if-empty.err b/tests/qapi-schema/bad-if-empty.err
index 358bdc3e51..a3fdb3009d 100644
--- a/tests/qapi-schema/bad-if-empty.err
+++ b/tests/qapi-schema/bad-if-empty.err
@@ -1 +1,2 @@
+tests/qapi-schema/bad-if-empty.json: In struct 'TestIfStruct':
 tests/qapi-schema/bad-if-empty.json:2: 'if' condition '' makes no sense
diff --git a/tests/qapi-schema/bad-if-list.err b/tests/qapi-schema/bad-if-list.err
index 53af099083..e03bf0fc3a 100644
--- a/tests/qapi-schema/bad-if-list.err
+++ b/tests/qapi-schema/bad-if-list.err
@@ -1 +1,2 @@
+tests/qapi-schema/bad-if-list.json: In struct 'TestIfStruct':
 tests/qapi-schema/bad-if-list.json:2: 'if' condition ' ' makes no sense
diff --git a/tests/qapi-schema/bad-if.err b/tests/qapi-schema/bad-if.err
index c2e3f5f44c..190216c109 100644
--- a/tests/qapi-schema/bad-if.err
+++ b/tests/qapi-schema/bad-if.err
@@ -1 +1,2 @@
+tests/qapi-schema/bad-if.json: In struct 'TestIfStruct':
 tests/qapi-schema/bad-if.json:2: 'if' condition must be a string or a list of strings
-- 
2.21.0



  parent reply	other threads:[~2019-09-28 18:51 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-28 18:39 [PULL 00/27] QAPI patches for 2019-09-28 Markus Armbruster
2019-09-28 18:39 ` [PULL 01/27] qmp-dispatch: Use CommandNotFound error for disabled commands Markus Armbruster
2019-09-28 18:39 ` [PULL 02/27] qapi: Tighten QAPISchemaFOO.check() assertions Markus Armbruster
2019-09-28 18:39 ` [PULL 03/27] qapi: Rename .owner to .defined_in Markus Armbruster
2019-09-28 18:39 ` [PULL 04/27] qapi: New QAPISourceInfo, replacing dict Markus Armbruster
2019-09-28 18:39 ` [PULL 05/27] qapi: Prefix frontend errors with an "in definition" line Markus Armbruster
2019-09-28 18:39 ` [PULL 06/27] qapi: Clean up member name case checking Markus Armbruster
2019-09-28 18:39 ` [PULL 07/27] qapi: Change frontend error messages to start with lower case Markus Armbruster
2019-09-28 18:39 ` [PULL 08/27] qapi: Improve reporting of member name clashes Markus Armbruster
2019-09-28 18:39 ` [PULL 09/27] qapi: Reorder check_FOO() parameters for consistency Markus Armbruster
2019-09-28 18:39 ` [PULL 10/27] qapi: Improve reporting of invalid name errors Markus Armbruster
2019-09-28 18:39 ` [PULL 11/27] qapi: Use check_name_str() where it suffices Markus Armbruster
2019-09-28 18:39 ` [PULL 12/27] qapi: Report invalid '*' prefix like any other invalid name Markus Armbruster
2019-09-28 18:39 ` [PULL 13/27] qapi: Move check for reserved names out of add_name() Markus Armbruster
2019-09-28 18:39 ` [PULL 14/27] qapi: Make check_type()'s array case a bit more obvious Markus Armbruster
2019-09-28 18:39 ` [PULL 15/27] qapi: Plumb info to the QAPISchemaMember Markus Armbruster
2019-09-28 18:39 ` [PULL 16/27] qapi: Inline check_name() into check_union() Markus Armbruster
2019-09-28 18:39 ` [PULL 17/27] qapi: Move context-sensitive checking to the proper place Markus Armbruster
2019-09-28 18:39 ` [PULL 18/27] qapi: Move context-free " Markus Armbruster
2019-09-28 18:39 ` Markus Armbruster [this message]
2019-09-28 18:39 ` [PULL 20/27] qapi: Improve reporting of invalid flags Markus Armbruster
2019-09-28 18:39 ` [PULL 21/27] qapi: Improve reporting of missing / unknown definition keys Markus Armbruster
2019-09-28 18:39 ` [PULL 22/27] qapi: Avoid redundant definition references in error messages Markus Armbruster
2019-09-28 18:39 ` [PULL 23/27] qapi: Improve reporting of invalid 'if' further Markus Armbruster
2019-09-28 18:39 ` [PULL 24/27] qapi: Eliminate check_keys(), rename check_known_keys() Markus Armbruster
2019-09-28 18:39 ` [PULL 25/27] qapi: Improve reporting of missing documentation comment Markus Armbruster
2019-09-28 18:39 ` [PULL 26/27] qapi: Improve reporting of redefinition Markus Armbruster
2019-09-28 18:39 ` [PULL 27/27] qapi: Improve source file read error handling Markus Armbruster
2019-09-30 10:48 ` [PULL 00/27] QAPI patches for 2019-09-28 Peter Maydell
2019-10-01 12:13   ` Peter Maydell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190928183934.12459-20-armbru@redhat.com \
    --to=armbru@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.