All of lore.kernel.org
 help / color / mirror / Atom feed
From: Maxim Levitsky <mlevitsk@redhat.com>
To: qemu-devel@nongnu.org
Cc: Kevin Wolf <kwolf@redhat.com>,
	qemu-block@nongnu.org, Markus Armbruster <armbru@redhat.com>,
	"Dr. David Alan Gilbert" <dgilbert@redhat.com>,
	Maxim Levitsky <mlevitsk@redhat.com>,
	Max Reitz <mreitz@redhat.com>
Subject: [PATCH v2 0/9] RFC: [for 5.0]: HMP monitor handlers cleanups
Date: Fri, 22 Nov 2019 18:47:58 +0200	[thread overview]
Message-ID: <20191122164807.27938-1-mlevitsk@redhat.com> (raw)

This patch series is bunch of cleanups
to the hmp monitor code.

This series only touched blockdev related hmp handlers.

No functional changes expected other that
light error message changes by the last patch.

This was inspired by this bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=1719169

Basically some users still parse hmp error messages,
and they would like to have them prefixed with 'Error:'

In commit 66363e9a43f649360a3f74d2805c9f864da027eb we added
the hmp_handle_error which does exactl that but some hmp handlers
don't use it.

In this patch series, I moved all the block related hmp handlers
into blockdev-hmp-cmds.c, and then made them use this function
to report the errors.

I hope I didn't change too much code, I just felt that if
I touch this code, I can also make it easier to find these
handlers, that were scattered over 3 different files.

Changes from V1:
   * move the handlers to block/monitor/block-hmp-cmds.c
   * tiny cleanup for the commit messages

Best regards,
	Maxim Levitsky

Maxim Levitsky (9):
  monitor/hmp: uninline add_init_drive
  monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c
  monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c
  monitor/hmp: move hmp_drive_mirror and hmp_drive_backup to
    block-hmp-cmds.c
  monitor/hmp: move hmp_block_job* to block-hmp-cmds.c
  monitor/hmp: move hmp_snapshot_* to block-hmp-cmds.c
  monitor/hmp: move remaining hmp_block* functions to block-hmp-cmds.c
  monitor/hmp: move hmp_info_block* to block-hmp-cmds.c
  monitor/hmp: Prefer to use hmp_handle_error for error reporting in
    block hmp commands

 MAINTAINERS                    |   1 +
 Makefile.objs                  |   2 +-
 block/Makefile.objs            |   1 +
 block/monitor/Makefile.objs    |   1 +
 block/monitor/block-hmp-cmds.c | 656 +++++++++++++++++++++++++++++++++
 blockdev.c                     |  95 -----
 device-hotplug.c               |  91 -----
 monitor/hmp-cmds.c             | 465 -----------------------
 8 files changed, 660 insertions(+), 652 deletions(-)
 create mode 100644 block/monitor/Makefile.objs
 create mode 100644 block/monitor/block-hmp-cmds.c
 delete mode 100644 device-hotplug.c

-- 
2.17.2



             reply	other threads:[~2019-11-22 17:21 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-22 16:47 Maxim Levitsky [this message]
2019-11-22 16:47 ` [PATCH v2 1/9] monitor/hmp: uninline add_init_drive Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 2/9] monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 3/9] monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 4/9] monitor/hmp: move hmp_drive_mirror and hmp_drive_backup " Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 5/9] monitor/hmp: move hmp_block_job* " Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 6/9] monitor/hmp: move hmp_snapshot_* " Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 7/9] monitor/hmp: move remaining hmp_block* functions " Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 8/9] monitor/hmp: move hmp_info_block* " Maxim Levitsky
2019-11-22 16:48 ` [PATCH v2 9/9] monitor/hmp: Prefer to use hmp_handle_error for error reporting in block hmp commands Maxim Levitsky
2019-11-22 18:51 ` [PATCH v2 0/9] RFC: [for 5.0]: HMP monitor handlers cleanups Dr. David Alan Gilbert

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191122164807.27938-1-mlevitsk@redhat.com \
    --to=mlevitsk@redhat.com \
    --cc=armbru@redhat.com \
    --cc=dgilbert@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.