All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dave Chinner <david@fromorbit.com>
To: "Darrick J. Wong" <darrick.wong@oracle.com>
Cc: linux-xfs@vger.kernel.org, hch@infradead.org,
	Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH 02/11] xfs: make xfs_buf_read return an error code
Date: Mon, 20 Jan 2020 08:57:20 +1100	[thread overview]
Message-ID: <20200119215720.GE9407@dread.disaster.area> (raw)
In-Reply-To: <157924222437.3029431.18011964422343623236.stgit@magnolia>

On Thu, Jan 16, 2020 at 10:23:44PM -0800, Darrick J. Wong wrote:
> From: Darrick J. Wong <darrick.wong@oracle.com>
> 
> Convert xfs_buf_read() to return numeric error codes like most
> everywhere else in xfs.  Hoist the callers' error logging and EFSBADCRC
> remapping code into xfs_buf_read to reduce code duplication.
> 
> Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> Reviewed-by: Christoph Hellwig <hch@lst.de>
> ---
>  fs/xfs/libxfs/xfs_attr_remote.c |   16 +++-------------
>  fs/xfs/xfs_buf.c                |   33 +++++++++++++++++++++++++++++++++
>  fs/xfs/xfs_buf.h                |   14 +++-----------
>  fs/xfs/xfs_log_recover.c        |   26 +++++++-------------------
>  fs/xfs/xfs_symlink.c            |   17 ++++-------------
>  5 files changed, 50 insertions(+), 56 deletions(-)
> 
> 
> diff --git a/fs/xfs/libxfs/xfs_attr_remote.c b/fs/xfs/libxfs/xfs_attr_remote.c
> index a266d05df146..46c516809086 100644
> --- a/fs/xfs/libxfs/xfs_attr_remote.c
> +++ b/fs/xfs/libxfs/xfs_attr_remote.c
> @@ -418,20 +418,10 @@ xfs_attr_rmtval_get(
>  			       (map[i].br_startblock != HOLESTARTBLOCK));
>  			dblkno = XFS_FSB_TO_DADDR(mp, map[i].br_startblock);
>  			dblkcnt = XFS_FSB_TO_BB(mp, map[i].br_blockcount);
> -			bp = xfs_buf_read(mp->m_ddev_targp, dblkno, dblkcnt, 0,
> -					&xfs_attr3_rmt_buf_ops);
> -			if (!bp)
> -				return -ENOMEM;
> -			error = bp->b_error;
> -			if (error) {
> -				xfs_buf_ioerror_alert(bp, __func__);
> -				xfs_buf_relse(bp);
> -
> -				/* bad CRC means corrupted metadata */
> -				if (error == -EFSBADCRC)
> -					error = -EFSCORRUPTED;
> +			error = xfs_buf_read(mp->m_ddev_targp, dblkno, dblkcnt,
> +					0, &bp, &xfs_attr3_rmt_buf_ops);
> +			if (error)
>  				return error;
> -			}
>  
>  			error = xfs_attr_rmtval_copyout(mp, bp, args->dp->i_ino,
>  							&offset, &valuelen,
> diff --git a/fs/xfs/xfs_buf.c b/fs/xfs/xfs_buf.c
> index a00e63d08a3b..8c9cd1ab870b 100644
> --- a/fs/xfs/xfs_buf.c
> +++ b/fs/xfs/xfs_buf.c
> @@ -851,6 +851,39 @@ xfs_buf_read_map(
>  	return bp;
>  }
>  
> +int
> +xfs_buf_read(
> +	struct xfs_buftarg	*target,
> +	xfs_daddr_t		blkno,
> +	size_t			numblks,
> +	xfs_buf_flags_t		flags,
> +	struct xfs_buf		**bpp,
> +	const struct xfs_buf_ops *ops)
> +{
> +	struct xfs_buf		*bp;
> +	int			error;
> +	DEFINE_SINGLE_BUF_MAP(map, blkno, numblks);
> +
> +	*bpp = NULL;
> +	bp = xfs_buf_read_map(target, &map, 1, flags, ops);
> +	if (!bp)
> +		return -ENOMEM;
> +	error = bp->b_error;
> +	if (error) {
> +		xfs_buf_ioerror_alert(bp, __func__);
> +		xfs_buf_stale(bp);
> +		xfs_buf_relse(bp);
> +
> +		/* bad CRC means corrupted metadata */
> +		if (error == -EFSBADCRC)
> +			error = -EFSCORRUPTED;
> +		return error;
> +	}
> +
> +	*bpp = bp;
> +	return 0;
> +}

I'd just put all this in xfs_buf_read_map() and leave
xfs_buf_read() as a simple wrapper around xfs_buf_read_map().

Also:

	if (!bp->b_error) {
		*bpp = bp;
		return 0;
	}
	/* handle error without extra indenting */


> -	const struct xfs_buf_ops *ops)
> -{
> -	DEFINE_SINGLE_BUF_MAP(map, blkno, numblks);
> -	return xfs_buf_read_map(target, &map, 1, flags, ops);
> -}
> +int xfs_buf_read(struct xfs_buftarg *target, xfs_daddr_t blkno, size_t numblks,
> +		xfs_buf_flags_t flags, struct xfs_buf **bpp,
> +		const struct xfs_buf_ops *ops);
>  
>  static inline void
>  xfs_buf_readahead(
> diff --git a/fs/xfs/xfs_log_recover.c b/fs/xfs/xfs_log_recover.c
> index 0d683fb96396..ac79537d3275 100644
> --- a/fs/xfs/xfs_log_recover.c
> +++ b/fs/xfs/xfs_log_recover.c
> @@ -2745,15 +2745,10 @@ xlog_recover_buffer_pass2(
>  	if (buf_f->blf_flags & XFS_BLF_INODE_BUF)
>  		buf_flags |= XBF_UNMAPPED;
>  
> -	bp = xfs_buf_read(mp->m_ddev_targp, buf_f->blf_blkno, buf_f->blf_len,
> -			  buf_flags, NULL);
> -	if (!bp)
> -		return -ENOMEM;
> -	error = bp->b_error;
> -	if (error) {
> -		xfs_buf_ioerror_alert(bp, "xlog_recover_do..(read#1)");
> -		goto out_release;
> -	}
> +	error = xfs_buf_read(mp->m_ddev_targp, buf_f->blf_blkno, buf_f->blf_len,
> +			  buf_flags, &bp, NULL);
> +	if (error)
> +		return error;

I'd argue that if we are touching every remaining xfs_buf_read() call
like this, we should get rid of it and just call xfs_buf_read_map()
instead.

Cheers,

Dave.
-- 
Dave Chinner
david@fromorbit.com

  reply	other threads:[~2020-01-19 21:57 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-17  6:23 [PATCH v2 00/11] xfs: make buffer functions return error codes Darrick J. Wong
2020-01-17  6:23 ` [PATCH 01/11] xfs: make xfs_buf_alloc return an error code Darrick J. Wong
2020-01-19 21:49   ` Dave Chinner
2020-01-20 22:19     ` Darrick J. Wong
2020-01-17  6:23 ` [PATCH 02/11] xfs: make xfs_buf_read " Darrick J. Wong
2020-01-19 21:57   ` Dave Chinner [this message]
2020-01-20 22:22     ` Darrick J. Wong
2020-01-17  6:23 ` [PATCH 03/11] xfs: make xfs_buf_get " Darrick J. Wong
2020-01-19 21:59   ` Dave Chinner
2020-01-17  6:24 ` [PATCH 04/11] xfs: make xfs_buf_get_uncached " Darrick J. Wong
2020-01-17  6:24 ` [PATCH 05/11] xfs: make xfs_buf_read_map " Darrick J. Wong
2020-01-17  6:50   ` Christoph Hellwig
2020-01-17 22:58     ` Darrick J. Wong
2020-01-17  6:24 ` [PATCH 06/11] xfs: make xfs_buf_get_map " Darrick J. Wong
2020-01-17  6:24 ` [PATCH 07/11] xfs: make xfs_trans_get_buf_map " Darrick J. Wong
2020-01-17  6:24 ` [PATCH 08/11] xfs: make xfs_trans_get_buf " Darrick J. Wong
2020-01-17  6:24 ` [PATCH 09/11] xfs: remove the xfs_btree_get_buf[ls] functions Darrick J. Wong
2020-01-17  6:51   ` Christoph Hellwig
2020-01-17  6:24 ` [PATCH 10/11] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers Darrick J. Wong
2020-01-17  6:59   ` Christoph Hellwig
2020-01-17 23:05     ` Darrick J. Wong
2020-01-17  6:24 ` [PATCH 11/11] xfs: remove unnecessary null pointer checks from _read_agf callers Darrick J. Wong
2020-01-17  7:00   ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200119215720.GE9407@dread.disaster.area \
    --to=david@fromorbit.com \
    --cc=darrick.wong@oracle.com \
    --cc=hch@infradead.org \
    --cc=hch@lst.de \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.