All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Sterba <dsterba@suse.cz>
To: Nikolay Borisov <nborisov@suse.com>
Cc: linux-btrfs@vger.kernel.org
Subject: Re: [PATCH 00/10] A bunch of misc cleanups
Date: Fri, 3 Jul 2020 18:21:53 +0200	[thread overview]
Message-ID: <20200703162153.GF27795@twin.jikos.cz> (raw)
In-Reply-To: <20200702134650.16550-1-nborisov@suse.com>

On Thu, Jul 02, 2020 at 04:46:40PM +0300, Nikolay Borisov wrote:
> Here's an assortment of little quality-of-life patches that I created while
> looking into the raid56 code. They should bear no functional changes and have
> tested them with xfstest and nothing fell over so should be rather low risk.
> 
> Patch 1 moves code in __btrfs_map_block, essentially assigning tgtdev_map/raid_map
> closet to where space for them is allocated. This also neccesiated moving the
> call to sort_parity_stripes. The end result is (hopefully) slightly easier to
> follow __btrfs_map_block.
> 
> Next 5 patches cleanup minor things in raid56.c such as removing redundant checks,
> making code interacting with bio_list more in line with what the rest of the
> kernel is doing. Finally it's using some macros/functions instead of open-coding
> them. Really just a bunch of low hanging fruit.
> 
> Final 4 patches gradually remove all labels in btrfs_submit_compressed_read.
> Current failures can be handled "inline" so to speak, without the need for
> extra labels. This likely will change once the BUG_ONs are removed but we are
> not there yet.
> 
> Nikolay Borisov (10):
>   btrfs: Always initialize btrfs_bio::tgtdev_map/raid_map pointers
>   btrfs: raid56: Remove redundant check in rbio_add_io_page
>   btrfs: raid56: Assign bio in while()
>   btrfs: raid56: Remove out label in __raid56_parity_recover
>   btrfs: raid56: Use in_range where applicable
>   btrfs: raid56: Don't opencode swap()
>   btrfs: Remove fail label in check_compressed_csum
>   btrfs: Remove fail1 label in btrfs_submit_compressed_read
>   btrfs: Remove fail2 label from btrfs_submit_compressed_read
>   btrfs: Remove out label in btrfs_submit_compressed_read

Except patches 4, 8, 9, 10, series merged to misc-next. We can have a
look at the label/return cleanups next week, the other cleanups are good
so I don't want to stall this patchset. Thanks.

      parent reply	other threads:[~2020-07-03 16:22 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-02 13:46 [PATCH 00/10] A bunch of misc cleanups Nikolay Borisov
2020-07-02 13:46 ` [PATCH 01/10] btrfs: Always initialize btrfs_bio::tgtdev_map/raid_map pointers Nikolay Borisov
2020-07-02 14:04   ` Johannes Thumshirn
2020-07-03  8:31     ` Nikolay Borisov
2020-07-03 15:57       ` David Sterba
2020-07-06  6:38         ` Johannes Thumshirn
2020-07-02 13:46 ` [PATCH 02/10] btrfs: raid56: Remove redundant check in rbio_add_io_page Nikolay Borisov
2020-07-02 14:12   ` Johannes Thumshirn
2020-07-02 13:46 ` [PATCH 03/10] btrfs: raid56: Assign bio in while() Nikolay Borisov
2020-07-02 14:14   ` Johannes Thumshirn
2020-07-02 13:46 ` [PATCH 04/10] btrfs: raid56: Remove out label in __raid56_parity_recover Nikolay Borisov
2020-07-02 14:02   ` David Sterba
2020-07-02 14:51     ` Nikolay Borisov
2020-07-02 13:46 ` [PATCH 05/10] btrfs: raid56: Use in_range where applicable Nikolay Borisov
2020-07-02 14:19   ` Johannes Thumshirn
2020-07-03 15:45   ` David Sterba
2020-07-02 13:46 ` [PATCH 06/10] btrfs: raid56: Don't opencode swap() Nikolay Borisov
2020-07-02 14:20   ` Johannes Thumshirn
2020-07-02 13:46 ` [PATCH 07/10] btrfs: Remove fail label in check_compressed_csum Nikolay Borisov
2020-07-02 14:10   ` David Sterba
2020-07-02 13:46 ` [PATCH 08/10] btrfs: Remove fail1 label in btrfs_submit_compressed_read Nikolay Borisov
2020-07-02 14:03   ` David Sterba
2020-07-02 13:46 ` [PATCH 09/10] btrfs: Remove fail2 label from btrfs_submit_compressed_read Nikolay Borisov
2020-07-02 14:14   ` David Sterba
2020-07-02 13:46 ` [PATCH 10/10] btrfs: Remove out label in btrfs_submit_compressed_read Nikolay Borisov
2020-07-02 14:23   ` Johannes Thumshirn
2020-07-03 16:21 ` David Sterba [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200703162153.GF27795@twin.jikos.cz \
    --to=dsterba@suse.cz \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=nborisov@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.