All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mike Rapoport <rppt@kernel.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Arnd Bergmann <arnd@arndb.de>, Dinh Nguyen <dinguyen@kernel.org>,
	Guo Ren <guoren@kernel.org>, Helge Deller <deller@gmx.de>,
	Huacai Chen <chenhuacai@kernel.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Matthew Wilcox <willy@infradead.org>,
	Max Filippov <jcmvbkbc@gmail.com>,
	Mike Rapoport <rppt@kernel.org>,
	Mike Rapoport <rppt@linux.ibm.com>,
	"Russell King (Oracle)" <linux@armlinux.org.uk>,
	Thomas Bogendoerfer <tsbogend@alpha.franken.de>,
	WANG Xuerui <kernel@xen0n.name>,
	linux-arch@vger.kernel.org, linux-csky@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-mips@vger.kernel.org,
	linux-mm@kvack.org, linux-parisc@vger.kernel.org,
	linux-xtensa@linux-xtensa.org, loongarch@lists.linux.dev
Subject: [PATCH v2 01/15] csky: drop definition of PTE_ORDER
Date: Tue,  5 Jul 2022 18:46:54 +0300	[thread overview]
Message-ID: <20220705154708.181258-2-rppt@kernel.org> (raw)
In-Reply-To: <20220705154708.181258-1-rppt@kernel.org>

From: Mike Rapoport <rppt@linux.ibm.com>

This is the order of the page table allocation, not the order of a PTE.
Since its always hardwired to 0, simply drop it.

Signed-off-by: Mike Rapoport <rppt@linux.ibm.com>
Acked-by: Guo Ren <guoren@kernel.org>
---
 arch/csky/include/asm/pgtable.h | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/csky/include/asm/pgtable.h b/arch/csky/include/asm/pgtable.h
index bbe245117777..f8bb1e12334b 100644
--- a/arch/csky/include/asm/pgtable.h
+++ b/arch/csky/include/asm/pgtable.h
@@ -19,11 +19,10 @@
  * C-SKY is two-level paging structure:
  */
 #define PGD_ORDER	0
-#define PTE_ORDER	0
 
 #define PTRS_PER_PGD	((PAGE_SIZE << PGD_ORDER) / sizeof(pgd_t))
 #define PTRS_PER_PMD	1
-#define PTRS_PER_PTE	((PAGE_SIZE << PTE_ORDER) / sizeof(pte_t))
+#define PTRS_PER_PTE	(PAGE_SIZE / sizeof(pte_t))
 
 #define pte_ERROR(e) \
 	pr_err("%s:%d: bad pte %08lx.\n", __FILE__, __LINE__, (e).pte_low)
-- 
2.34.1


  reply	other threads:[~2022-07-05 15:47 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-05 15:46 [PATCH v2 00/15] arch: make PxD_ORDER generically available Mike Rapoport
2022-07-05 15:46 ` Mike Rapoport [this message]
2022-07-05 15:46 ` [PATCH v2 02/15] csky: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 03/15] mips: Rename PMD_ORDER to PMD_TABLE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 04/15] mips: Rename PUD_ORDER to PUD_TABLE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 05/15] mips: drop definitions of PTE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 06/15] mips: Rename PGD_ORDER to PGD_TABLE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 07/15] nios2: drop definition of PTE_ORDER Mike Rapoport
2022-07-11 22:55   ` Dinh Nguyen
2022-07-05 15:47 ` [PATCH v2 08/15] nios2: drop definition of PGD_ORDER Mike Rapoport
2022-07-11 22:55   ` Dinh Nguyen
2022-07-05 15:47 ` [PATCH v2 09/15] loongarch: drop definition of PTE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 10/15] loongarch: drop definition of PMD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 11/15] loongarch: drop definition of PUD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 12/15] loongarch: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 13/15] parisc: Rename PGD_ORDER to PGD_TABLE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 14/15] xtensa: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 16:03   ` Max Filippov
2022-07-05 15:47 ` [PATCH v2 15/15] ARM: head.S: rename PMD_ORDER to PMD_ENTRY_ORDER Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220705154708.181258-2-rppt@kernel.org \
    --to=rppt@kernel.org \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=chenhuacai@kernel.org \
    --cc=deller@gmx.de \
    --cc=dinguyen@kernel.org \
    --cc=guoren@kernel.org \
    --cc=jcmvbkbc@gmail.com \
    --cc=kernel@xen0n.name \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-csky@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-xtensa@linux-xtensa.org \
    --cc=linux@armlinux.org.uk \
    --cc=loongarch@lists.linux.dev \
    --cc=rppt@linux.ibm.com \
    --cc=tsbogend@alpha.franken.de \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.