All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dhruva Gole <d-gole@ti.com>
To: "Théo Lebrun" <theo.lebrun@bootlin.com>
Cc: Mark Brown <broonie@kernel.org>, Apurva Nandan <a-nandan@ti.com>,
	<linux-spi@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
	Gregory CLEMENT <gregory.clement@bootlin.com>,
	Vladimir Kondratiev <vladimir.kondratiev@mobileye.com>,
	Thomas Petazzoni <thomas.petazzoni@bootlin.com>,
	Tawfik Bayouk <tawfik.bayouk@mobileye.com>
Subject: Re: [PATCH v2 1/4] spi: cadence-qspi: put runtime in runtime PM hooks names
Date: Wed, 7 Feb 2024 14:03:33 +0530	[thread overview]
Message-ID: <20240207083333.jqghhzihzwz5yeeq@dhruva> (raw)
In-Reply-To: <20240205-cdns-qspi-pm-fix-v2-1-2e7bbad49a46@bootlin.com>

On Feb 05, 2024 at 15:57:29 +0100, Théo Lebrun wrote:
> Follow kernel naming convention with regards to power-management
> callback function names.
> 
> The convention in the kernel is:
>  - prefix_suspend means the system-wide suspend callback;
>  - prefix_runtime_suspend means the runtime PM suspend callback.
> The same applies to resume callbacks.
> 
> Fixes: 0578a6dbfe75 ("spi: spi-cadence-quadspi: add runtime pm support")

Not sure if it's a bug as such since there's no functional change other
than renaming.

> Signed-off-by: Théo Lebrun <theo.lebrun@bootlin.com>
> ---
>  drivers/spi/spi-cadence-quadspi.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/spi/spi-cadence-quadspi.c b/drivers/spi/spi-cadence-quadspi.c
> index 74647dfcb86c..720b28d2980c 100644
> --- a/drivers/spi/spi-cadence-quadspi.c
> +++ b/drivers/spi/spi-cadence-quadspi.c
> @@ -1927,7 +1927,7 @@ static void cqspi_remove(struct platform_device *pdev)
>  	pm_runtime_disable(&pdev->dev);
>  }
>  
> -static int cqspi_suspend(struct device *dev)
> +static int cqspi_runtime_suspend(struct device *dev)
>  {
>  	struct cqspi_st *cqspi = dev_get_drvdata(dev);
>  	struct spi_controller *host = dev_get_drvdata(dev);
> @@ -1941,7 +1941,7 @@ static int cqspi_suspend(struct device *dev)
>  	return ret;
>  }
>  
> -static int cqspi_resume(struct device *dev)
> +static int cqspi_runtime_resume(struct device *dev)
>  {
>  	struct cqspi_st *cqspi = dev_get_drvdata(dev);
>  	struct spi_controller *host = dev_get_drvdata(dev);
> @@ -1956,8 +1956,8 @@ static int cqspi_resume(struct device *dev)
>  	return spi_controller_resume(host);
>  }
>  
> -static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_suspend,
> -				 cqspi_resume, NULL);
> +static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_runtime_suspend,
> +				 cqspi_runtime_resume, NULL);
>  


No objections as such,
Reviewed-by: Dhruva Gole <d-gole@ti.com>

-- 
Best regards,
Dhruva Gole <d-gole@ti.com>

  reply	other threads:[~2024-02-07  8:33 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-05 14:57 [PATCH v2 0/4] spi: cadence-qspi: Fix runtime PM and system-wide suspend Théo Lebrun
2024-02-05 14:57 ` [PATCH v2 1/4] spi: cadence-qspi: put runtime in runtime PM hooks names Théo Lebrun
2024-02-07  8:33   ` Dhruva Gole [this message]
2024-02-07  9:25     ` Théo Lebrun
2024-02-05 14:57 ` [PATCH v2 2/4] spi: cadence-qspi: fix pointer reference in runtime PM hooks Théo Lebrun
2024-02-05 15:12   ` Mark Brown
2024-02-07  8:39     ` Dhruva Gole
2024-02-07  9:50       ` Mark Brown
2024-02-07 10:14         ` Dhruva Gole
2024-02-07  8:42   ` Dhruva Gole
2024-02-07  9:28     ` Théo Lebrun
2024-02-07 10:12       ` Dhruva Gole
2024-02-05 14:57 ` [PATCH v2 3/4] spi: cadence-qspi: remove system-wide suspend helper calls from " Théo Lebrun
2024-02-05 14:57 ` [PATCH v2 4/4] spi: cadence-qspi: add system-wide suspend and resume callbacks Théo Lebrun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240207083333.jqghhzihzwz5yeeq@dhruva \
    --to=d-gole@ti.com \
    --cc=a-nandan@ti.com \
    --cc=broonie@kernel.org \
    --cc=gregory.clement@bootlin.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-spi@vger.kernel.org \
    --cc=tawfik.bayouk@mobileye.com \
    --cc=theo.lebrun@bootlin.com \
    --cc=thomas.petazzoni@bootlin.com \
    --cc=vladimir.kondratiev@mobileye.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.