All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Osipenko <digetx@gmail.com>
To: Peter De Schrijver <pdeschrijver@nvidia.com>,
	Thierry Reding <thierry.reding@gmail.com>,
	Jonathan Hunter <jonathanh@nvidia.com>
Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	linux-pm@vger.kernel.org, linux-tegra@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v6 00/18] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s)
Date: Tue, 29 Oct 2019 03:47:56 +0300	[thread overview]
Message-ID: <40de641f-c38e-51ee-ae27-c5db468c45b5@gmail.com> (raw)
In-Reply-To: <20191028140443.GA27141@pdeschrijver-desktop.Nvidia.com>

28.10.2019 17:04, Peter De Schrijver пишет:
> On Wed, Oct 16, 2019 at 11:14:07PM +0300, Dmitry Osipenko wrote:
>> 16.10.2019 22:47, Dmitry Osipenko пишет:
>>> 16.10.2019 22:21, Peter De Schrijver пишет:
>>>> On Tue, Oct 15, 2019 at 07:59:57PM +0300, Dmitry Osipenko wrote:
>>>>> Hello,
>>>>>
>>>>> This series does the following:
>>>>>
>>>>>   1. Unifies Tegra20/30/114 drivers into a single driver and moves it out
>>>>>      into common drivers/cpuidle/ directory.
>>>>>
>>>>>   2. Enables CPU cluster power-down idling state on Tegra30.
>>>>>
>>>>> In the end there is a quite nice clean up of the Tegra CPUIDLE drivers
>>>>> and of the Tegra's arch code in general. Please review, thanks!
>>>>>
>>>>> Changelog:
>>>>>
>>>>> v6: - Addressed request from Thierry Reding to change the way patches are
>>>>>       organized by making changes in a more incremental manner.
>>>>>
>>>>>     - tegra_sleep_cpu() now checks for the secondary CPUs to be offline
>>>>>       in the "Make outer_disable() open-coded" patch.
>>>>>
>>>>> v5: - Rebased on a recent linux-next, fixed one minor conflict in Kconfig.
>>>>>
>>>>>     - Improved commit's message of the "Support CPU cluster power-down state
>>>>>       on Tegra30" patch.
>>>>>
>>>>>     - The "Support CPU cluster power-down state on Tegra30" patch is also
>>>>>       got split and now there is additional "Make outer_disable() open-coded"
>>>>>       patch.
>>>>>
>>>>>     - Made minor cosmetic changes to the "Introduce unified driver for
>>>>>       NVIDIA Tegra SoCs" patch by improving error message and renaming
>>>>>       one variable.
>>>>>
>>>>> v4: - Fixed compilation with !CONFIG_CACHE_L2X0 (and tested that it still
>>>>>       works).
>>>>>
>>>>>     - Replaced ktime_compare() with ktime_before() in the new driver,
>>>>>       for consistency.
>>>>>
>>>>> v3: - Addressed review comments that were made by Jon Hunter to v2 by
>>>>>       splitting patches into smaller (and simpler) chunks, better
>>>>>       documenting changes in the commit messages and using proper error
>>>>>       codes in the code.
>>>>>
>>>>>       Warnings are replaced with a useful error messages in the code of
>>>>>       "Introduce unified driver for NVIDIA Tegra SoCs" patch.
>>>>>
>>>>>       Secondary CPUs parking timeout increased to 100ms because I found
>>>>>       that it actually may happen to take more than 1ms if CPU is running
>>>>>       on a *very* low frequency.
>>>>>
>>>>>       Added diagnostic messages that are reporting Flow Controller state
>>>>>       when CPU parking fails.
>>>>>
>>>>>       Further polished cpuidle driver's code.
>>>>>
>>>>>       The coupled state entering is now aborted if there is a pending SGI
>>>>>       (Software Generated Interrupt) because it will be lost after GIC's
>>>>>       power-cycling. Like it was done by the old Tegra20 CPUIDLE driver.
>>>>>
>>>>> v2: - Added patches to enable the new cpuidle driver in the defconfigs:
>>>>>
>>>>>         ARM: multi_v7_defconfig: Enable Tegra cpuidle driver
>>>>>         ARM: tegra: Enable Tegra cpuidle driver in tegra_defconfig
>>>>>
>>>>>     - Dropped patches that removed CPUIDLE_FLAG_TIMER_STOP from the idling
>>>>>       states because that flag actually doesn't have any negative effects,
>>>>>       but still is correct for the case of a local CPU timer on older Tegra
>>>>>       SoCs:
>>>>>
>>>>>         cpuidle: tegra: Remove CPUIDLE_FLAG_TIMER_STOP from Tegra114/124 idle-state
>>>>>         cpuidle: tegra: Remove CPUIDLE_FLAG_TIMER_STOP from all states
>>>>>
>>>>>     - The "Add unified driver for NVIDIA Tegra SoCs" patch got more polish.
>>>>>       Tegra30 and Terga114 states are now squashed into a single common C7
>>>>>       state (following Parker TRM terminology, see 17.2.2.2 Power Management
>>>>>       States), more comments added, etc minor changes.
>>>>
>>>> It would be useful to switch the power state terminology to the one used
>>>> for later chips:
>>>>
>>>> LP0 becomes SC7
>>>> LP1 becomes C1
>>>> LP2 becomes CC7
>>>>
>>>> Meaning of these states is as follows
>>>>
>>>> C is a core state:
>>>>
>>>> C1 clock gating
>>>> C2 not defined
>>>> C3 not defined
>>>> C4 not defined
>>>> C5 not defined
>>>> C6 not defined for ARM cores
>>>> C7 power-gating
>>>>
>>>> CC is a CPU cluster C state:
>>>>
>>>> CC1 cluster clock gated
>>>> CC2 not defined
>>>> CC3 fmax@Vmin: not used prior to Tegra186
>>>> CC4: cluster retention: no longer supported
>>>> CC5: not defined
>>>> CC6: cluster power gating
>>>> CC7: cluster rail gating
>>>>
>>>> SC is a System C state:
>>>>
>>>> SC1: not defined
>>>> SC2: not defined
>>>> SC3: not defined
>>>> SC4: not defined
>>>> SC5: not defined
>>>> SC6: not defined
>>>> SC7: VDD_SOC off
>>>
>>> Hello Peter,
>>>
>>> But new "drivers/cpuidle/cpuidle-tegra.c" uses exactly that terminology,
>>> please see "cpuidle: Refactor and move NVIDIA Tegra20 driver into
>>> drivers/cpuidle/" and further patches. Am I missing something? Or do you
>>> want the renaming to be a separate patch?
>>>
>>
>> Or maybe you're suggesting to change the names everywhere and not only
>> in the cpuidle driver? Please clarify :)
> 
> At least some of the variable and function names still say lp2?

The cpuidle driver uses LP2 terminology for everything that comes from
the external arch / firmware includes. But it says CC6 for everything
that is internal to the driver. So yes, there is a bit of new/old
terminology mixing in the code.

The arch code / PMC driver / TF firmware are all saying LP2. The LP2
naming is also a part of the device-tree binding.

It will be a lot of mess to rename the mach-tegra/pm.c code. I guess
eventually it could be moved to drivers/soc/, so maybe it will be better
to postpone the renaming until then?

  reply	other threads:[~2019-10-29  0:47 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-15 16:59 [PATCH v6 00/18] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s) Dmitry Osipenko
2019-10-15 16:59 ` [PATCH v6 01/18] ARM: tegra: Compile sleep-tegra20/30.S unconditionally Dmitry Osipenko
2019-10-15 16:59 ` [PATCH v6 02/18] ARM: tegra: Add tegra_pm_park_secondary_cpu() Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 03/18] ARM: tegra: Remove pen-locking from cpuidle-tegra20 Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 04/18] ARM: tegra: Change tegra_set_cpu_in_lp2() type to void Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 05/18] ARM: tegra: Propagate error from tegra_idle_lp2_last() Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 06/18] ARM: tegra: Expose PM functions required for new cpuidle driver Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 07/18] ARM: tegra: Rename some of the newly exposed PM functions Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 08/18] ARM: tegra: Make outer_disable() open-coded Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 09/18] clk: tegra: Add missing stubs for the case of !CONFIG_PM_SLEEP Dmitry Osipenko
2019-10-29 13:19   ` Thierry Reding
2019-10-15 17:00 ` [PATCH v6 10/18] arm: tegra20: cpuidle: Handle case where secondary CPU hangs on entering LP2 Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 11/18] arm: tegra20: cpuidle: Make abort_flag atomic Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 12/18] arm: tegra20/30: cpuidle: Remove unnecessary memory barrier Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 13/18] cpuidle: Refactor and move NVIDIA Tegra20 driver into drivers/cpuidle/ Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 14/18] cpuidle: tegra: Squash Tegra30 driver into the common driver Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 15/18] cpuidle: tegra: Support CPU cluster power-down state on Tegra30 Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 16/18] cpuidle: tegra: Squash Tegra114 driver into the common driver Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 17/18] ARM: multi_v7_defconfig: Enable Tegra cpuidle driver Dmitry Osipenko
2019-10-15 17:00 ` [PATCH v6 18/18] ARM: tegra: Enable Tegra cpuidle driver in tegra_defconfig Dmitry Osipenko
2019-10-16 19:21 ` [PATCH v6 00/18] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s) Peter De Schrijver
2019-10-16 19:21   ` Peter De Schrijver
2019-10-16 19:47   ` Dmitry Osipenko
2019-10-16 20:14     ` Dmitry Osipenko
2019-10-28 14:04       ` Peter De Schrijver
2019-10-28 14:04         ` Peter De Schrijver
2019-10-29  0:47         ` Dmitry Osipenko [this message]
2019-11-01 12:33           ` Peter De Schrijver
2019-11-01 12:33             ` Peter De Schrijver
2019-11-01 13:22             ` Dmitry Osipenko
2019-11-01 21:30               ` Dmitry Osipenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=40de641f-c38e-51ee-ae27-c5db468c45b5@gmail.com \
    --to=digetx@gmail.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=jonathanh@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=pdeschrijver@nvidia.com \
    --cc=rjw@rjwysocki.net \
    --cc=thierry.reding@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.