All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
To: BALATON Zoltan <balaton@eik.bme.hu>,
	qemu-devel@nongnu.org, qemu-ppc@nongnu.org
Cc: David Gibson <david@gibson.dropbear.id.au>,
	Howard Spoelstra <hsp.cat7@gmail.com>
Subject: Re: [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly
Date: Fri, 26 Jun 2020 13:42:51 +0100	[thread overview]
Message-ID: <70f47a42-9144-c98a-2b7d-bd67cc0e4f75@ilande.co.uk> (raw)
In-Reply-To: <321dd439b98051d7537e9a04fa02785ef132749a.1592315226.git.balaton@eik.bme.hu>

On 16/06/2020 14:47, BALATON Zoltan wrote:

> Half of the occurances already use get_system_memory() directly
> instead of sysmem variable, convert the two other uses to
> get_system_memory() tii which seems to be more common and drop the
> variable.
> 
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
> ---
>  hw/ppc/mac_oldworld.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
> 
> diff --git a/hw/ppc/mac_oldworld.c b/hw/ppc/mac_oldworld.c
> index baf3da6f90..d1c4244b1e 100644
> --- a/hw/ppc/mac_oldworld.c
> +++ b/hw/ppc/mac_oldworld.c
> @@ -87,7 +87,6 @@ static void ppc_heathrow_init(MachineState *machine)
>      const char *kernel_cmdline = machine->kernel_cmdline;
>      const char *initrd_filename = machine->initrd_filename;
>      const char *boot_device = machine->boot_order;
> -    MemoryRegion *sysmem = get_system_memory();
>      PowerPCCPU *cpu = NULL;
>      CPUPPCState *env = NULL;
>      char *filename;
> @@ -128,12 +127,12 @@ static void ppc_heathrow_init(MachineState *machine)
>          exit(1);
>      }
>  
> -    memory_region_add_subregion(sysmem, 0, machine->ram);
> +    memory_region_add_subregion(get_system_memory(), 0, machine->ram);
>  
>      /* allocate and load firmware ROM */
>      memory_region_init_rom(bios, NULL, "ppc_heathrow.bios", PROM_SIZE,
>                             &error_fatal);
> -    memory_region_add_subregion(sysmem, PROM_BASE, bios);
> +    memory_region_add_subregion(get_system_memory(), PROM_BASE, bios);
>  
>      if (!bios_name) {
>          bios_name = PROM_FILENAME;

Reviewed-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>


ATB,

Mark.


  reply	other threads:[~2020-06-26 12:44 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-16 13:47 [PATCH v5 00/11] Mac Old World ROM experiment BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 05/11] grackle: Set revision in PCI config to match hardware BALATON Zoltan
2020-06-26 12:51   ` Mark Cave-Ayland
2020-06-16 13:47 ` [PATCH v5 09/11] macio: Add dummy screamer register area BALATON Zoltan
2020-06-26 13:12   ` Mark Cave-Ayland
2020-06-28 12:26     ` BALATON Zoltan
2020-06-28 14:08       ` BALATON Zoltan
2020-06-28 14:29         ` BALATON Zoltan
2020-06-28 14:53           ` BALATON Zoltan
2020-06-28 15:04             ` BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 08/11] mac_oldworld: Add machine ID register BALATON Zoltan
2020-06-26 13:07   ` Mark Cave-Ayland
2020-06-16 13:47 ` [PATCH v5 10/11] WIP macio/cuda: Attempt to add i2c support BALATON Zoltan
2020-06-28 12:37   ` [RFC PATCH] " BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 06/11] mac_oldworld: Rename ppc_heathrow_reset to ppc_heathrow_cpu_reset BALATON Zoltan
2020-06-26 12:55   ` Mark Cave-Ayland
2020-06-26 22:22     ` BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 07/11] mac_oldworld: Map macio to expected address at reset BALATON Zoltan
2020-06-26 13:03   ` Mark Cave-Ayland
2020-06-26 22:25     ` BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 02/11] mac_newworld: Allow loading binary ROM image BALATON Zoltan
2020-06-26 12:42   ` Mark Cave-Ayland
2020-06-16 13:47 ` [PATCH v5 11/11] mac_oldworld: Add SPD data to cover RAM BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 01/11] mac_oldworld: Allow loading binary ROM image BALATON Zoltan
2020-06-26 12:38   ` Mark Cave-Ayland
2020-06-26 21:57     ` BALATON Zoltan
2020-06-16 13:47 ` [PATCH v5 04/11] mac_oldworld: Drop some variables BALATON Zoltan
2020-06-26 12:46   ` Mark Cave-Ayland
2020-06-16 13:47 ` [PATCH v5 03/11] mac_oldworld: Drop a variable, use get_system_memory() directly BALATON Zoltan
2020-06-26 12:42   ` Mark Cave-Ayland [this message]
2020-06-26 10:21 ` [PATCH v5 00/11] Mac Old World ROM experiment BALATON Zoltan
2020-06-26 12:23   ` Mark Cave-Ayland
2020-06-28 18:34     ` BALATON Zoltan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=70f47a42-9144-c98a-2b7d-bd67cc0e4f75@ilande.co.uk \
    --to=mark.cave-ayland@ilande.co.uk \
    --cc=balaton@eik.bme.hu \
    --cc=david@gibson.dropbear.id.au \
    --cc=hsp.cat7@gmail.com \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-ppc@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.