All of lore.kernel.org
 help / color / mirror / Atom feed
From: Akinobu Mita <akinobu.mita@gmail.com>
To: Sagi Grimberg <sagig@dev.mellanox.co.il>
Cc: target-devel@vger.kernel.org,
	Nicholas Bellinger <nab@linux-iscsi.org>,
	"Martin K. Petersen" <martin.petersen@oracle.com>,
	Christoph Hellwig <hch@lst.de>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	"linux-scsi@vger.kernel.org" <linux-scsi@vger.kernel.org>
Subject: Re: [PATCH v2 1/2] target/rd: reduce code duplication in rd_execute_rw()
Date: Mon, 6 Apr 2015 20:16:41 +0900	[thread overview]
Message-ID: <CAC5umyhG0oinXnsyqXwNc1cqWU3ixHLwB8jbQt=Vt2x=cC3Kyg@mail.gmail.com> (raw)
In-Reply-To: <55223908.6080607@dev.mellanox.co.il>

2015-04-06 16:43 GMT+09:00 Sagi Grimberg <sagig@dev.mellanox.co.il>:
> On 4/5/2015 5:59 PM, Akinobu Mita wrote:
>>
>> Factor out code duplication in rd_execute_rw() into a helper function
>> rd_do_prot_rw().  This change is required to minimize the forthcoming
>> fix in rd_do_prot_rw().
>>
>> Signed-off-by: Akinobu Mita <akinobu.mita@gmail.com>
>> Cc: Nicholas Bellinger <nab@linux-iscsi.org>
>> Cc: Sagi Grimberg <sagig@dev.mellanox.co.il>
>> Cc: "Martin K. Petersen" <martin.petersen@oracle.com>
>> Cc: Christoph Hellwig <hch@lst.de>
>> Cc: "James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>
>> Cc: target-devel@vger.kernel.org
>> Cc: linux-scsi@vger.kernel.org
>> ---
>> * v2
>> - Pass dif_verify() function pointer to helper function instead of
>> is_write,
>>    suggested by Sagi Grimberg.
>>
>>   drivers/target/target_core_rd.c | 66
>> ++++++++++++++++++++---------------------
>>   1 file changed, 32 insertions(+), 34 deletions(-)
>>
>> diff --git a/drivers/target/target_core_rd.c
>> b/drivers/target/target_core_rd.c
>> index 98e83ac..ac5e8d2 100644
>> --- a/drivers/target/target_core_rd.c
>> +++ b/drivers/target/target_core_rd.c
>> @@ -382,6 +382,36 @@ static struct rd_dev_sg_table
>> *rd_get_prot_table(struct rd_dev *rd_dev, u32 page
>>         return NULL;
>>   }
>>
>> +typedef sense_reason_t (*dif_verify)(struct se_cmd *, sector_t, unsigned
>> int,
>> +                                    unsigned int, struct scatterlist *,
>> int);
>> +
>> +static sense_reason_t rd_do_prot_rw(struct se_cmd *cmd, dif_verify
>> dif_verify)
>> +{
>> +       struct se_device *se_dev = cmd->se_dev;
>> +       struct rd_dev *dev = RD_DEV(se_dev);
>> +       struct rd_dev_sg_table *prot_table;
>> +       struct scatterlist *prot_sg;
>> +       u32 sectors = cmd->data_length / se_dev->dev_attrib.block_size;
>> +       u32 prot_offset, prot_page;
>> +       u64 tmp;
>> +       sense_reason_t rc;
>> +
>> +       tmp = cmd->t_task_lba * se_dev->prot_length;
>> +       prot_offset = do_div(tmp, PAGE_SIZE);
>> +       prot_page = tmp;
>> +
>> +       prot_table = rd_get_prot_table(dev, prot_page);
>> +       if (!prot_table)
>> +               return TCM_LOGICAL_UNIT_COMMUNICATION_FAILURE;
>> +
>> +       prot_sg = &prot_table->sg_table[prot_page -
>> +                                       prot_table->page_start_offset];
>> +
>> +       rc = dif_verify(cmd, cmd->t_task_lba, sectors, 0, prot_sg,
>> prot_offset);
>> +
>> +       return rc;
>
>
> Nit, Given there is no action on the returned rc, this can be reduced to:
>         return dif_verify();

You are right,  but the patch 2/2 inserts the lines to release
temporary prot_sg before return statement, so assignment and return
statements will be both required in the end.

  reply	other threads:[~2015-04-06 11:16 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-04-05 14:59 [PATCH v2 1/2] target/rd: reduce code duplication in rd_execute_rw() Akinobu Mita
2015-04-05 14:59 ` [PATCH v2 2/2] target/rd: Don't pass imcomplete scatterlist entries to sbc_dif_verify_* Akinobu Mita
2015-04-06  8:42   ` Sagi Grimberg
2015-04-08  5:13   ` Nicholas A. Bellinger
2015-04-08 14:25     ` Akinobu Mita
2015-04-09  6:41       ` Nicholas A. Bellinger
2015-04-06  7:43 ` [PATCH v2 1/2] target/rd: reduce code duplication in rd_execute_rw() Sagi Grimberg
2015-04-06 11:16   ` Akinobu Mita [this message]
2015-04-08  5:03 ` Nicholas A. Bellinger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAC5umyhG0oinXnsyqXwNc1cqWU3ixHLwB8jbQt=Vt2x=cC3Kyg@mail.gmail.com' \
    --to=akinobu.mita@gmail.com \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=hch@lst.de \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=nab@linux-iscsi.org \
    --cc=sagig@dev.mellanox.co.il \
    --cc=target-devel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.