All of lore.kernel.org
 help / color / mirror / Atom feed
From: Amir Goldstein <amir73il@gmail.com>
To: "Darrick J. Wong" <darrick.wong@oracle.com>
Cc: Dave Chinner <david@fromorbit.com>,
	Eric Sandeen <sandeen@redhat.com>,
	Linux NFS Mailing List <linux-nfs@vger.kernel.org>,
	linux-cifs@vger.kernel.org,
	overlayfs <linux-unionfs@vger.kernel.org>,
	linux-xfs <linux-xfs@vger.kernel.org>,
	Linux MM <linux-mm@kvack.org>,
	Linux Btrfs <linux-btrfs@vger.kernel.org>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	ocfs2-devel@oss.oracle.com
Subject: Re: [PATCH 08/25] vfs: combine the clone and dedupe into a single remap_file_range
Date: Wed, 10 Oct 2018 08:54:44 +0300	[thread overview]
Message-ID: <CAOQ4uxj_wftoGvub9n_6X3Qc64LKxs+8TB-opUiq59sGQ=YoKw@mail.gmail.com> (raw)
In-Reply-To: <153913029885.32295.7399525233513945673.stgit@magnolia>

On Wed, Oct 10, 2018 at 3:12 AM Darrick J. Wong <darrick.wong@oracle.com> wrote:
>
> From: Darrick J. Wong <darrick.wong@oracle.com>
>
> Combine the clone_file_range and dedupe_file_range operations into a
> single remap_file_range file operation dispatch since they're
> fundamentally the same operation.  The differences between the two can
> be made in the prep functions.
>
> Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> ---

I like this. Nits below.

[...]

> diff --git a/fs/btrfs/ioctl.c b/fs/btrfs/ioctl.c
> index d60b6caf09e8..e22b294fa25b 100644
> --- a/fs/btrfs/ioctl.c
> +++ b/fs/btrfs/ioctl.c
> @@ -3627,26 +3627,6 @@ static int btrfs_extent_same(struct inode *src, u64 loff, u64 olen,
>         return ret;
>  }
>
> -int btrfs_dedupe_file_range(struct file *src_file, loff_t src_loff,
> -                           struct file *dst_file, loff_t dst_loff,
> -                           u64 olen)
> -{
> -       struct inode *src = file_inode(src_file);
> -       struct inode *dst = file_inode(dst_file);
> -       u64 bs = BTRFS_I(src)->root->fs_info->sb->s_blocksize;
> -
> -       if (WARN_ON_ONCE(bs < PAGE_SIZE)) {
> -               /*
> -                * Btrfs does not support blocksize < page_size. As a
> -                * result, btrfs_cmp_data() won't correctly handle
> -                * this situation without an update.
> -                */
> -               return -EINVAL;
> -       }
> -
> -       return btrfs_extent_same(src, src_loff, olen, dst, dst_loff);
> -}
> -
>  static int clone_finish_inode_update(struct btrfs_trans_handle *trans,
>                                      struct inode *inode,
>                                      u64 endoff,
> @@ -4348,9 +4328,27 @@ static noinline int btrfs_clone_files(struct file *file, struct file *file_src,
>         return ret;
>  }
>
> -int btrfs_clone_file_range(struct file *src_file, loff_t off,
> -               struct file *dst_file, loff_t destoff, u64 len)
> +int btrfs_remap_file_range(struct file *src_file, loff_t off,
> +               struct file *dst_file, loff_t destoff, u64 len,
> +               unsigned int flags)
>  {
> +       if (flags & RFR_IDENTICAL_DATA) {
> +               struct inode *src = file_inode(src_file);
> +               struct inode *dst = file_inode(dst_file);
> +               u64 bs = BTRFS_I(src)->root->fs_info->sb->s_blocksize;
> +
> +               if (WARN_ON_ONCE(bs < PAGE_SIZE)) {
> +                       /*
> +                        * Btrfs does not support blocksize < page_size. As a
> +                        * result, btrfs_cmp_data() won't correctly handle
> +                        * this situation without an update.
> +                        */
> +                       return -EINVAL;
> +               }
> +
> +               return btrfs_extent_same(src, off, len, dst, destoff);
> +       }
> +

Seems weird that you would do that instead of:

+    if (flags & ~RFR_IDENTICAL_DATA)
+        return -EINVAL;
+    if (flags & RFR_IDENTICAL_DATA)
+        return btrfs_dedupe_file_range(src, off, dst, destoff, len);

>         return btrfs_clone_files(dst_file, src_file, off, len, destoff);
>  }
>
> diff --git a/fs/cifs/cifsfs.c b/fs/cifs/cifsfs.c
> index 7065426b3280..bf971fd7cab2 100644
> --- a/fs/cifs/cifsfs.c
> +++ b/fs/cifs/cifsfs.c
> @@ -975,8 +975,9 @@ const struct inode_operations cifs_symlink_inode_ops = {
>         .listxattr = cifs_listxattr,
>  };
>
> -static int cifs_clone_file_range(struct file *src_file, loff_t off,
> -               struct file *dst_file, loff_t destoff, u64 len)
> +static int cifs_remap_file_range(struct file *src_file, loff_t off,
> +               struct file *dst_file, loff_t destoff, u64 len,
> +               unsigned int flags)
>  {
>         struct inode *src_inode = file_inode(src_file);
>         struct inode *target_inode = file_inode(dst_file);
> @@ -986,6 +987,9 @@ static int cifs_clone_file_range(struct file *src_file, loff_t off,
>         unsigned int xid;
>         int rc;
>
> +       if (flags & RFR_IDENTICAL_DATA)
> +               return -EOPNOTSUPP;
> +

I think everyone would be better off with:
+       if (flags)
+               return -EINVAL;

This way you won't need to change all filesystem implementations
every time that you add a new RFR flag.
Lucky for us, dedup already return -EINVAL if (!f_op->dedupe_file_range)
(and not -EOPNOTSUPP).

[...]
> diff --git a/fs/overlayfs/file.c b/fs/overlayfs/file.c
> index 986313da0c88..693bd0620a81 100644
> --- a/fs/overlayfs/file.c
> +++ b/fs/overlayfs/file.c
> @@ -489,26 +489,28 @@ static ssize_t ovl_copy_file_range(struct file *file_in, loff_t pos_in,
>                             OVL_COPY);
>  }
>
> -static int ovl_clone_file_range(struct file *file_in, loff_t pos_in,
> -                               struct file *file_out, loff_t pos_out, u64 len)
> +static int ovl_remap_file_range(struct file *file_in, loff_t pos_in,
> +                               struct file *file_out, loff_t pos_out,
> +                               u64 len, unsigned int flags)
>  {
> -       return ovl_copyfile(file_in, pos_in, file_out, pos_out, len, 0,
> -                           OVL_CLONE);
> -}
> +       enum ovl_copyop op;
> +
> +       if (flags & RFR_IDENTICAL_DATA)
> +               op = OVL_DEDUPE;
> +       else
> +               op = OVL_CLONE;
>
> -static int ovl_dedupe_file_range(struct file *file_in, loff_t pos_in,
> -                                struct file *file_out, loff_t pos_out, u64 len)
> -{
>         /*
>          * Don't copy up because of a dedupe request, this wouldn't make sense
>          * most of the time (data would be duplicated instead of deduplicated).
>          */
> -       if (!ovl_inode_upper(file_inode(file_in)) ||
> -           !ovl_inode_upper(file_inode(file_out)))
> +       if (op == OVL_DEDUPE &&
> +           (!ovl_inode_upper(file_inode(file_in)) ||
> +            !ovl_inode_upper(file_inode(file_out))))
>                 return -EPERM;
>
>         return ovl_copyfile(file_in, pos_in, file_out, pos_out, len, 0,
> -                           OVL_DEDUPE);
> +                           op);
>  }
>

Apart from the generic check invalid flags comment - ACK on ovl part.

Thanks,
Amir.

  reply	other threads:[~2018-10-10  5:54 UTC|newest]

Thread overview: 84+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-10  0:10 [PATCH v2 00/25] fs: fixes for serious clone/dedupe problems Darrick J. Wong
2018-10-10  0:10 ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:10 ` [PATCH 01/25] xfs: add a per-xfs trace_printk macro Darrick J. Wong
2018-10-10  0:10   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:36   ` Dave Chinner
2018-10-10  0:36     ` [Ocfs2-devel] " Dave Chinner
2018-10-10 15:00   ` [PATCH v2 " Darrick J. Wong
2018-10-10 15:00     ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:10 ` [PATCH 02/25] xfs: refactor clonerange preparation into a separate helper Darrick J. Wong
2018-10-10  0:10   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:10 ` [PATCH 03/25] xfs: zero posteof blocks when cloning above eof Darrick J. Wong
2018-10-10  0:10   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:11 ` [PATCH 04/25] xfs: update ctime and remove suid before cloning files Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:11 ` [PATCH 05/25] vfs: check file ranges " Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 23:06   ` Dave Chinner
2018-10-10 23:06     ` [Ocfs2-devel] " Dave Chinner
2018-10-10 23:13     ` Darrick J. Wong
2018-10-10 23:13       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:11 ` [PATCH 06/25] vfs: strengthen checking of file range inputs to generic_remap_checks Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  5:23   ` Amir Goldstein
2018-10-10 17:01     ` Darrick J. Wong
2018-10-10 17:01       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 17:26       ` Amir Goldstein
2018-10-10  0:11 ` [PATCH 07/25] vfs: skip zero-length dedupe requests Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:11 ` [PATCH 08/25] vfs: combine the clone and dedupe into a single remap_file_range Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  5:54   ` Amir Goldstein [this message]
2018-10-10 15:13     ` Darrick J. Wong
2018-10-10 15:13       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 15:23       ` Amir Goldstein
2018-10-10  0:11 ` [PATCH 09/25] vfs: rename vfs_clone_file_prep to be more descriptive Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:11 ` [PATCH 10/25] vfs: rename clone_verify_area to remap_verify_area Darrick J. Wong
2018-10-10  0:11   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 11/25] vfs: create generic_remap_file_range_touch to update inode metadata Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 12/25] vfs: pass remap flags to generic_remap_file_range_prep Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 13/25] vfs: pass remap flags to generic_remap_checks Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 14/25] vfs: make remap_file_range functions take and return bytes completed Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  6:47   ` Amir Goldstein
2018-10-10 15:50     ` Darrick J. Wong
2018-10-10 15:50       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 18:28       ` Amir Goldstein
2018-10-10 18:32         ` Darrick J. Wong
2018-10-10 18:32           ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 15/25] vfs: plumb RFR_* remap flags through the vfs clone functions Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  6:22   ` Amir Goldstein
2018-10-10  6:39     ` Amir Goldstein
2018-10-10  0:13 ` [PATCH 16/25] vfs: plumb RFR_* remap flags through the vfs dedupe functions Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:13 ` [PATCH 17/25] vfs: make remapping to source file eof more explicit Darrick J. Wong
2018-10-10  0:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 12:29   ` Amir Goldstein
2018-10-10 16:29     ` Darrick J. Wong
2018-10-10 16:29       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10 17:31       ` Amir Goldstein
2018-10-10  0:14 ` [PATCH 18/25] vfs: enable remap callers that can handle short operations Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 19/25] vfs: hide file range comparison function Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 20/25] vfs: implement opportunistic short dedupe Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 21/25] ocfs2: truncate page cache for clone destination file before remapping Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 22/25] ocfs2: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 23/25] ocfs2: support partial clone range and dedupe range Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 24/25] xfs: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  0:14 ` [PATCH 25/25] xfs: support returning partial reflink results Darrick J. Wong
2018-10-10  0:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-10  1:02 ` [PATCH v2 00/25] fs: fixes for serious clone/dedupe problems Dave Chinner
2018-10-10  1:02   ` [Ocfs2-devel] " Dave Chinner
2018-10-10  1:06   ` Darrick J. Wong
2018-10-10  1:06     ` [Ocfs2-devel] " Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAOQ4uxj_wftoGvub9n_6X3Qc64LKxs+8TB-opUiq59sGQ=YoKw@mail.gmail.com' \
    --to=amir73il@gmail.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-unionfs@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=sandeen@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.