All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Xu, Terrence" <terrence.xu@intel.com>
To: Alex Williamson <alex.williamson@redhat.com>,
	Yishai Hadas <yishaih@nvidia.com>
Cc: "bhelgaas@google.com" <bhelgaas@google.com>,
	"corbet@lwn.net" <corbet@lwn.net>,
	"diana.craciun@oss.nxp.com" <diana.craciun@oss.nxp.com>,
	"kwankhede@nvidia.com" <kwankhede@nvidia.com>,
	"eric.auger@redhat.com" <eric.auger@redhat.com>,
	"masahiroy@kernel.org" <masahiroy@kernel.org>,
	"michal.lkml@markovi.net" <michal.lkml@markovi.net>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-s390@vger.kernel.org" <linux-s390@vger.kernel.org>,
	"linux-kbuild@vger.kernel.org" <linux-kbuild@vger.kernel.org>,
	"mgurtovoy@nvidia.com" <mgurtovoy@nvidia.com>,
	"jgg@nvidia.com" <jgg@nvidia.com>,
	"maorg@nvidia.com" <maorg@nvidia.com>,
	"leonro@nvidia.com" <leonro@nvidia.com>,
	"Tian, Kevin" <kevin.tian@intel.com>
Subject: RE: [PATCH V5 00/13] Introduce vfio_pci_core subsystem
Date: Mon, 30 Aug 2021 15:40:53 +0000	[thread overview]
Message-ID: <DM6PR11MB3177A7D59FAB8EE420F14BC5F0CB9@DM6PR11MB3177.namprd11.prod.outlook.com> (raw)
In-Reply-To: <20210826162108.4fc8b844.alex.williamson@redhat.com>

> -----Original Message-----
> From: Alex Williamson <alex.williamson@redhat.com>
> Sent: Friday, August 27, 2021 6:21 AM
> 
> On Thu, 26 Aug 2021 13:38:59 +0300
> Yishai Hadas <yishaih@nvidia.com> wrote:
> >
> > Jason Gunthorpe (2):
> >   vfio: Use select for eventfd
> >   vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
> >
> > Max Gurtovoy (10):
> >   vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
> >   vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
> >   vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
> >   vfio/pci: Rename ops functions to fit core namings
> >   vfio/pci: Include vfio header in vfio_pci_core.h
> >   vfio/pci: Split the pci_driver code out of vfio_pci_core.c
> >   vfio/pci: Move igd initialization to vfio_pci.c
> >   PCI: Add 'override_only' field to struct pci_device_id
> >   PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
> >   vfio/pci: Introduce vfio_pci_core.ko
> >
> > Yishai Hadas (1):
> >   vfio/pci: Move module parameters to vfio_pci.c
> >
> >  Documentation/PCI/pci.rst                     |    1 +
> >  MAINTAINERS                                   |    1 +
> >  drivers/pci/pci-driver.c                      |   28 +-
> >  drivers/vfio/Kconfig                          |   29 +-
> >  drivers/vfio/fsl-mc/Kconfig                   |    3 +-
> >  drivers/vfio/mdev/Kconfig                     |    1 -
> >  drivers/vfio/pci/Kconfig                      |   40 +-
> >  drivers/vfio/pci/Makefile                     |    8 +-
> >  drivers/vfio/pci/vfio_pci.c                   | 2262 +----------------
> >  drivers/vfio/pci/vfio_pci_config.c            |   70 +-
> >  drivers/vfio/pci/vfio_pci_core.c              | 2158 ++++++++++++++++
> >  drivers/vfio/pci/vfio_pci_igd.c               |   19 +-
> >  drivers/vfio/pci/vfio_pci_intrs.c             |   42 +-
> >  drivers/vfio/pci/vfio_pci_rdwr.c              |   18 +-
> >  drivers/vfio/pci/vfio_pci_zdev.c              |    4 +-
> >  drivers/vfio/platform/Kconfig                 |    6 +-
> >  drivers/vfio/platform/reset/Kconfig           |    4 +-
> >  include/linux/mod_devicetable.h               |    6 +
> >  include/linux/pci.h                           |   29 +
> >  .../linux/vfio_pci_core.h                     |   89 +-
> >  scripts/mod/devicetable-offsets.c             |    1 +
> >  scripts/mod/file2alias.c                      |   17 +-
> >  22 files changed, 2525 insertions(+), 2311 deletions(-)  create mode
> > 100644 drivers/vfio/pci/vfio_pci_core.c  rename
> > drivers/vfio/pci/vfio_pci_private.h => include/linux/vfio_pci_core.h
> > (56%)
> Applied to vfio next branch for v5.15.  Thanks,
> 
> Alex
We verified the Intel KVMGT and GVT-d KVM feature, no regression be introduced by these patch series.
Tested-by: Terrence Xu <terrence.xu@intel.com>

Thanks
Terrence

      reply	other threads:[~2021-08-30 15:40 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-26 10:38 [PATCH V5 00/13] Introduce vfio_pci_core subsystem Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 04/13] vfio/pci: Rename ops functions to fit core namings Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 05/13] vfio/pci: Include vfio header in vfio_pci_core.h Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 07/13] vfio/pci: Move igd initialization to vfio_pci.c Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 08/13] vfio/pci: Move module parameters " Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 09/13] PCI: Add 'override_only' field to struct pci_device_id Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 11/13] vfio: Use select for eventfd Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on' Yishai Hadas
2021-08-26 10:39 ` [PATCH V5 13/13] vfio/pci: Introduce vfio_pci_core.ko Yishai Hadas
2021-08-26 22:21 ` [PATCH V5 00/13] Introduce vfio_pci_core subsystem Alex Williamson
2021-08-30 15:40   ` Xu, Terrence [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DM6PR11MB3177A7D59FAB8EE420F14BC5F0CB9@DM6PR11MB3177.namprd11.prod.outlook.com \
    --to=terrence.xu@intel.com \
    --cc=alex.williamson@redhat.com \
    --cc=bhelgaas@google.com \
    --cc=corbet@lwn.net \
    --cc=diana.craciun@oss.nxp.com \
    --cc=eric.auger@redhat.com \
    --cc=jgg@nvidia.com \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=kwankhede@nvidia.com \
    --cc=leonro@nvidia.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=maorg@nvidia.com \
    --cc=masahiroy@kernel.org \
    --cc=mgurtovoy@nvidia.com \
    --cc=michal.lkml@markovi.net \
    --cc=yishaih@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.