All of lore.kernel.org
 help / color / mirror / Atom feed
From: Paul Durrant <xadimgnik@gmail.com>
To: "'Wei Liu'" <wl@xen.org>
Cc: <xen-devel@lists.xenproject.org>,
	"'Paul Durrant'" <pdurrant@amazon.com>,
	"'Christian Lindig'" <christian.lindig@citrix.com>,
	"'Ian Jackson'" <iwj@xenproject.org>,
	"'David Scott'" <dave@recoil.org>,
	"'Anthony PERARD'" <anthony.perard@citrix.com>
Subject: RE: [PATCH v5 19/23] libxl: modify libxl_device_pci_assignable_add/remove/list/list_free()...
Date: Fri, 4 Dec 2020 12:16:12 -0000	[thread overview]
Message-ID: <014f01d6ca37$42317d80$c6947880$@xen.org> (raw)
In-Reply-To: <20201204113535.kogsoqqvfykbg32x@liuwe-devbox-debian-v2>

> -----Original Message-----
> From: Wei Liu <wl@xen.org>
> Sent: 04 December 2020 11:36
> To: Paul Durrant <paul@xen.org>
> Cc: xen-devel@lists.xenproject.org; Paul Durrant <pdurrant@amazon.com>; Christian Lindig
> <christian.lindig@citrix.com>; Ian Jackson <iwj@xenproject.org>; Wei Liu <wl@xen.org>; David Scott
> <dave@recoil.org>; Anthony PERARD <anthony.perard@citrix.com>
> Subject: Re: [PATCH v5 19/23] libxl: modify libxl_device_pci_assignable_add/remove/list/list_free()...
> 
> On Thu, Dec 03, 2020 at 02:25:30PM +0000, Paul Durrant wrote:
> > From: Paul Durrant <pdurrant@amazon.com>
> >
> > ... to use 'libxl_pci_bdf' rather than 'libxl_device_pci'.
> >
> > This patch modifies the API and callers accordingly. It also modifies
> > several internal functions in libxl_pci.c that support the API to also use
> > 'libxl_pci_bdf'.
> >
> > NOTE: The OCaml bindings are adjusted to contain the interface change. It
> >       should therefore not affect compatibility with OCaml-based utilities.
> >
> > Signed-off-by: Paul Durrant <pdurrant@amazon.com>
> > Acked-by: Christian Lindig <christian.lindig@citrix.com>
> 
> > ---
> > Cc: Ian Jackson <iwj@xenproject.org>
> > Cc: Wei Liu <wl@xen.org>
> > Cc: David Scott <dave@recoil.org>
> > Cc: Anthony PERARD <anthony.perard@citrix.com>
> > ---
> >  tools/include/libxl.h                |  15 +-
> >  tools/libs/light/libxl_pci.c         | 213 +++++++++++++++------------
> >  tools/ocaml/libs/xl/xenlight_stubs.c |  15 +-
> >  tools/xl/xl_pci.c                    |  32 ++--
> >  4 files changed, 156 insertions(+), 119 deletions(-)
> >
> > diff --git a/tools/include/libxl.h b/tools/include/libxl.h
> > index 5edacccbd1da..5703fdf367c5 100644
> > --- a/tools/include/libxl.h
> > +++ b/tools/include/libxl.h
> > @@ -469,6 +469,13 @@
> >   */
> >  #define LIBXL_HAVE_PCI_BDF 1
> >
> > +/*
> > + * LIBXL_HAVE_PCI_ASSIGNABLE_BDF indicates that the
> > + * libxl_device_pci_assignable_add/remove/list/list_free() functions all
> > + * use the 'libxl_pci_bdf' type rather than 'libxl_device_pci' type.
> > + */
> > +#define LIBXL_HAVE_PCI_ASSIGNABLE_BDF 1
> > +
> >  /*
> >   * libxl ABI compatibility
> >   *
> > @@ -2378,10 +2385,10 @@ int libxl_device_events_handler(libxl_ctx *ctx,
> >   * added or is not bound, the functions will emit a warning but return
> >   * SUCCESS.
> >   */
> > -int libxl_device_pci_assignable_add(libxl_ctx *ctx, libxl_device_pci *pci, int rebind);
> > -int libxl_device_pci_assignable_remove(libxl_ctx *ctx, libxl_device_pci *pci, int rebind);
> > -libxl_device_pci *libxl_device_pci_assignable_list(libxl_ctx *ctx, int *num);
> > -void libxl_device_pci_assignable_list_free(libxl_device_pci *list, int num);
> > +int libxl_device_pci_assignable_add(libxl_ctx *ctx, libxl_pci_bdf *pcibdf, int rebind);
> > +int libxl_device_pci_assignable_remove(libxl_ctx *ctx, libxl_pci_bdf *pcibdf, int rebind);
> > +libxl_pci_bdf *libxl_device_pci_assignable_list(libxl_ctx *ctx, int *num);
> > +void libxl_device_pci_assignable_list_free(libxl_pci_bdf *list, int num);
> 
> Given these APIs are visible to external callers, you will need to
> provide fallbacks for the old APIs.
> 

Ok, I'll name the new functions something like 'libxl_pci_bdf_assignable_add/remove' etc. and provide compat shims.

  Paul

> Wei.



  reply	other threads:[~2020-12-04 12:16 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-03 14:25 [PATCH v5 00/23] xl / libxl: named PCI pass-through devices Paul Durrant
2020-12-03 14:25 ` [PATCH v5 01/23] xl / libxl: s/pcidev/pci and remove DEFINE_DEVICE_TYPE_STRUCT_X Paul Durrant
2020-12-04 11:13   ` Wei Liu
2020-12-04 11:15     ` Wei Liu
2020-12-04 11:19     ` Paul Durrant
2020-12-04 11:21       ` Wei Liu
2020-12-04 11:23         ` Paul Durrant
2020-12-07 16:18           ` Paul Durrant
2020-12-07 16:23             ` Durrant, Paul
2020-12-03 14:25 ` [PATCH v5 02/23] libxl: make libxl__device_list() work correctly for LIBXL__DEVICE_KIND_PCI Paul Durrant
2020-12-04 11:17   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 03/23] libxl: Make sure devices added by pci-attach are reflected in the config Paul Durrant
2020-12-04 11:18   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 04/23] libxl: add/recover 'rdm_policy' to/from PCI backend in xenstore Paul Durrant
2020-12-04 11:19   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 05/23] libxl: s/detatched/detached in libxl_pci.c Paul Durrant
2020-12-04 11:19   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 06/23] libxl: remove extraneous arguments to do_pci_remove() " Paul Durrant
2020-12-04 11:19   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 07/23] libxl: stop using aodev->device_config in libxl__device_pci_add() Paul Durrant
2020-12-04 11:22   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 08/23] libxl: generalise 'driver_path' xenstore access functions in libxl_pci.c Paul Durrant
2020-12-04 11:22   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 09/23] libxl: remove unnecessary check from libxl__device_pci_add() Paul Durrant
2020-12-04 11:22   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 10/23] libxl: remove get_all_assigned_devices() from libxl_pci.c Paul Durrant
2020-12-04 11:26   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 11/23] libxl: make sure callers of libxl_device_pci_list() free the list after use Paul Durrant
2020-12-04 11:28   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 12/23] libxl: add libxl_device_pci_assignable_list_free() Paul Durrant
2020-12-04 11:29   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 13/23] libxl: use COMPARE_PCI() macro is_pci_in_array() Paul Durrant
2020-12-04 11:29   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 14/23] docs/man: extract documentation of PCI_SPEC_STRING from the xl.cfg manpage Paul Durrant
2020-12-04 11:29   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 15/23] docs/man: improve documentation of PCI_SPEC_STRING Paul Durrant
2020-12-04 11:30   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 16/23] docs/man: fix xl(1) documentation for 'pci' operations Paul Durrant
2020-12-04 11:31   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 17/23] libxl: introduce 'libxl_pci_bdf' in the idl Paul Durrant
2020-12-04 11:31   ` Wei Liu
2020-12-04 13:07   ` Nick Rosbrook
2020-12-03 14:25 ` [PATCH v5 18/23] libxlu: introduce xlu_pci_parse_spec_string() Paul Durrant
2020-12-04 11:34   ` Wei Liu
2020-12-07 19:13     ` Paul Durrant
2020-12-03 14:25 ` [PATCH v5 19/23] libxl: modify libxl_device_pci_assignable_add/remove/list/list_free() Paul Durrant
2020-12-04 11:35   ` Wei Liu
2020-12-04 12:16     ` Paul Durrant [this message]
2020-12-03 14:25 ` [PATCH v5 20/23] docs/man: modify xl(1) in preparation for naming of assignable devices Paul Durrant
2020-12-04 11:35   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 21/23] xl / libxl: support " Paul Durrant
2020-12-04 11:37   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 22/23] docs/man: modify xl-pci-configuration(5) to add 'name' field to PCI_SPEC_STRING Paul Durrant
2020-12-04 11:38   ` Wei Liu
2020-12-03 14:25 ` [PATCH v5 23/23] xl / libxl: support 'xl pci-attach/detach' by name Paul Durrant
2020-12-04 11:38   ` Wei Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='014f01d6ca37$42317d80$c6947880$@xen.org' \
    --to=xadimgnik@gmail.com \
    --cc=anthony.perard@citrix.com \
    --cc=christian.lindig@citrix.com \
    --cc=dave@recoil.org \
    --cc=iwj@xenproject.org \
    --cc=paul@xen.org \
    --cc=pdurrant@amazon.com \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.