All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Hildenbrand <david@redhat.com>
To: Pingfan Liu <kernelfans@gmail.com>
Cc: linux-mm@kvack.org, Dan Williams <dan.j.williams@intel.com>,
	Michal Hocko <mhocko@kernel.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	David Hildenbrand <david@redhat.com>,
	Leonardo Bras <leonardo@linux.ibm.com>,
	Nathan Fontenot <nfont@linux.vnet.ibm.com>,
	Nathan Lynch <nathanl@linux.ibm.com>
Subject: Re: [PATCH] mm/sparse: rename pfn_present() as pfn_to_section_present()
Date: Sat, 15 Feb 2020 13:59:30 +0100	[thread overview]
Message-ID: <0257D252-E03E-4900-89CC-B26C58691F68@redhat.com> (raw)
In-Reply-To: <1581747422-7388-1-git-send-email-kernelfans@gmail.com>



> Am 15.02.2020 um 07:19 schrieb Pingfan Liu <kernelfans@gmail.com>:
> 
> After introducing mem sub section concept, pfn_present() loses its literal
> meaning, and will not be necessary a truth on partial populated mem section.
> 
> Since all of the callers use it to judge an absent section, it is better to
> rename pfn_present() as pfn_to_section_present().

IMHO, the name is not any better.

pfn_in_present_section?

Cheers!

> 
> Signed-off-by: Pingfan Liu <kernelfans@gmail.com>
> Cc: Dan Williams <dan.j.williams@intel.com>
> Cc: Michal Hocko <mhocko@kernel.org>
> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
> Cc: Paul Mackerras <paulus@samba.org>
> Cc: Michael Ellerman <mpe@ellerman.id.au>
> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> Cc: "Rafael J. Wysocki" <rafael@kernel.org>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: David Hildenbrand <david@redhat.com>
> Cc: Leonardo Bras <leonardo@linux.ibm.com>
> Cc: Nathan Fontenot <nfont@linux.vnet.ibm.com>
> Cc: Nathan Lynch <nathanl@linux.ibm.com>
> To: linux-mm@kvack.org
> ---
> arch/powerpc/platforms/pseries/hotplug-memory.c | 2 +-
> drivers/base/node.c                             | 2 +-
> include/linux/mmzone.h                          | 4 ++--
> mm/page_ext.c                                   | 2 +-
> mm/shuffle.c                                    | 2 +-
> 5 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c b/arch/powerpc/platforms/pseries/hotplug-memory.c
> index a4d40a3..5088132 100644
> --- a/arch/powerpc/platforms/pseries/hotplug-memory.c
> +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c
> @@ -360,7 +360,7 @@ static bool lmb_is_removable(struct drmem_lmb *lmb)
> 
>    for (i = 0; i < scns_per_block; i++) {
>        pfn = PFN_DOWN(phys_addr);
> -        if (!pfn_present(pfn)) {
> +        if (!pfn_to_section_present(pfn)) {
>            phys_addr += MIN_MEMORY_BLOCK_SIZE;
>            continue;
>        }
> diff --git a/drivers/base/node.c b/drivers/base/node.c
> index 98a31ba..6f98568 100644
> --- a/drivers/base/node.c
> +++ b/drivers/base/node.c
> @@ -772,7 +772,7 @@ static int register_mem_sect_under_node(struct memory_block *mem_blk,
>         * memory block could have several absent sections from start.
>         * skip pfn range from absent section
>         */
> -        if (!pfn_present(pfn)) {
> +        if (!pfn_to_section_present(pfn)) {
>            pfn = round_down(pfn + PAGES_PER_SECTION,
>                     PAGES_PER_SECTION) - 1;
>            continue;
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index 462f687..eca2db7 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -1372,7 +1372,7 @@ static inline int pfn_valid(unsigned long pfn)
> }
> #endif
> 
> -static inline int pfn_present(unsigned long pfn)
> +static inline int pfn_to_section_present(unsigned long pfn)
> {
>    if (pfn_to_section_nr(pfn) >= NR_MEM_SECTIONS)
>        return 0;
> @@ -1409,7 +1409,7 @@ void sparse_init(void);
> #else
> #define sparse_init()    do {} while (0)
> #define sparse_index_init(_sec, _nid)  do {} while (0)
> -#define pfn_present pfn_valid
> +#define pfn_to_section_present pfn_valid
> #define subsection_map_init(_pfn, _nr_pages) do {} while (0)
> #endif /* CONFIG_SPARSEMEM */
> 
> diff --git a/mm/page_ext.c b/mm/page_ext.c
> index 4ade843..df0e55e 100644
> --- a/mm/page_ext.c
> +++ b/mm/page_ext.c
> @@ -304,7 +304,7 @@ static int __meminit online_page_ext(unsigned long start_pfn,
>    }
> 
>    for (pfn = start; !fail && pfn < end; pfn += PAGES_PER_SECTION) {
> -        if (!pfn_present(pfn))
> +        if (!pfn_to_section_present(pfn))
>            continue;
>        fail = init_section_page_ext(pfn, nid);
>    }
> diff --git a/mm/shuffle.c b/mm/shuffle.c
> index b3fe97f..9242cc8 100644
> --- a/mm/shuffle.c
> +++ b/mm/shuffle.c
> @@ -72,7 +72,7 @@ static struct page * __meminit shuffle_valid_page(unsigned long pfn, int order)
>        return NULL;
> 
>    /* ...is the pfn in a present section or a hole? */
> -    if (!pfn_present(pfn))
> +    if (!pfn_to_section_present(pfn))
>        return NULL;
> 
>    /* ...is the page free and currently on a free_area list? */
> -- 
> 2.7.5
> 



  reply	other threads:[~2020-02-15 12:59 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-15  6:17 [PATCH] mm/sparse: rename pfn_present() as pfn_to_section_present() Pingfan Liu
2020-02-15 12:59 ` David Hildenbrand [this message]
2020-02-17  3:22   ` Pingfan Liu
2020-02-17  5:58     ` [PATCHv2] mm/sparse: rename pfn_present() as pfn_in_present_section() Pingfan Liu
2020-02-17 10:01       ` David Hildenbrand
2020-02-18 11:34       ` Michael Ellerman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0257D252-E03E-4900-89CC-B26C58691F68@redhat.com \
    --to=david@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=benh@kernel.crashing.org \
    --cc=dan.j.williams@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kernelfans@gmail.com \
    --cc=leonardo@linux.ibm.com \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@kernel.org \
    --cc=mpe@ellerman.id.au \
    --cc=nathanl@linux.ibm.com \
    --cc=nfont@linux.vnet.ibm.com \
    --cc=paulus@samba.org \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.