All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Rybchenko <andrew.rybchenko@oktetlabs.ru>
To: Lance Richardson <lance.richardson@broadcom.com>,
	Xiaoyun Li <xiaoyun.li@intel.com>,
	Olivier Matz <olivier.matz@6wind.com>,
	Jerin Jacob <jerinj@marvell.com>,
	Ajit Khaparde <ajit.khaparde@broadcom.com>,
	Somnath Kotur <somnath.kotur@broadcom.com>,
	Beilei Xing <beilei.xing@intel.com>, Jeff Guo <jia.guo@intel.com>,
	David Christensen <drc@linux.vnet.ibm.com>,
	Bruce Richardson <bruce.richardson@intel.com>,
	Konstantin Ananyev <konstantin.ananyev@intel.com>,
	Ruifeng Wang <ruifeng.wang@arm.com>,
	Jingjing Wu <jingjing.wu@intel.com>,
	Qiming Yang <qiming.yang@intel.com>,
	Qi Zhang <qi.z.zhang@intel.com>,
	Haiyue Wang <haiyue.wang@intel.com>,
	Nithin Dabilpuram <ndabilpuram@marvell.com>,
	Kiran Kumar K <kirankumark@marvell.com>,
	Rasesh Mody <rmody@marvell.com>,
	Shahed Shaikh <shshaikh@marvell.com>,
	Jiawen Wu <jiawenwu@trustnetic.com>,
	Jian Wang <jianwang@trustnetic.com>
Cc: dev@dpdk.org, Ferruh Yigit <ferruh.yigit@intel.com>
Subject: Re: [dpdk-dev] [PATCH] mbuf: rename outer ip checksum macro
Date: Thu, 25 Feb 2021 09:52:05 +0300	[thread overview]
Message-ID: <046ae7de-0a21-f2f8-d2ce-b544bbf036d7@oktetlabs.ru> (raw)
In-Reply-To: <20210224162432.337182-1-lance.richardson@broadcom.com>

On 2/24/21 7:24 PM, Lance Richardson wrote:
> Rename PKT_RX_EIP_CKSUM_BAD to PKT_RX_OUTER_IP_CKSUM_BAD and
> deprecate the original name. The new name is better aligned
> with existing PKT_RX_OUTER_* flags, which should help reduce
> confusion about its purpose.
> 
> Suggested-by: Ferruh Yigit <ferruh.yigit@intel.com>
> Signed-off-by: Lance Richardson <lance.richardson@broadcom.com>

Acked-by: Andrew Rybchenko <andrew.rybchenko@oktetlabs.ru>

I think deprecation notice should be added.

> diff --git a/lib/librte_mbuf/rte_mbuf_core.h b/lib/librte_mbuf/rte_mbuf_core.h
> index 9d1609336..796ef8059 100644
> --- a/lib/librte_mbuf/rte_mbuf_core.h
> +++ b/lib/librte_mbuf/rte_mbuf_core.h
> @@ -73,9 +73,18 @@ extern "C" {
>   */
>  #define PKT_RX_IP_CKSUM_BAD  (1ULL << 4)
>  
> - /** External IP header checksum error. */
> +/**
> + * Deprecated.
> + * This flag has been renamed, use PKT_RX_OUTER_IP_CKSUM_BAD instead.
> + */
>  #define PKT_RX_EIP_CKSUM_BAD (1ULL << 5)
>  
> +/**
> + * This flag is set when the outermost IP header checksum is detected as
> + * wrong by the hardware.
> + */
> +#define PKT_RX_OUTER_IP_CKSUM_BAD (1ULL << 5)
> +

I think this one should be keep, but old one should be:

#define PKT_RX_EIP_CKSUM_BAD PKT_RX_OUTER_IP_CKSUM_BAD

with a comment as you have above.

>  /**
>   * A vlan has been stripped by the hardware and its tci is saved in
>   * mbuf->vlan_tci. This can only happen if vlan stripping is enabled
> 


  reply	other threads:[~2021-02-25  6:52 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-24 16:24 [dpdk-dev] [PATCH] mbuf: rename outer ip checksum macro Lance Richardson
2021-02-25  6:52 ` Andrew Rybchenko [this message]
2021-02-25 14:31 ` [dpdk-dev] [PATCH v2] " Lance Richardson
2021-02-26 16:01   ` Ferruh Yigit
2021-02-26 16:27     ` Ajit Khaparde
2021-03-02  9:58       ` Ferruh Yigit

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=046ae7de-0a21-f2f8-d2ce-b544bbf036d7@oktetlabs.ru \
    --to=andrew.rybchenko@oktetlabs.ru \
    --cc=ajit.khaparde@broadcom.com \
    --cc=beilei.xing@intel.com \
    --cc=bruce.richardson@intel.com \
    --cc=dev@dpdk.org \
    --cc=drc@linux.vnet.ibm.com \
    --cc=ferruh.yigit@intel.com \
    --cc=haiyue.wang@intel.com \
    --cc=jerinj@marvell.com \
    --cc=jia.guo@intel.com \
    --cc=jianwang@trustnetic.com \
    --cc=jiawenwu@trustnetic.com \
    --cc=jingjing.wu@intel.com \
    --cc=kirankumark@marvell.com \
    --cc=konstantin.ananyev@intel.com \
    --cc=lance.richardson@broadcom.com \
    --cc=ndabilpuram@marvell.com \
    --cc=olivier.matz@6wind.com \
    --cc=qi.z.zhang@intel.com \
    --cc=qiming.yang@intel.com \
    --cc=rmody@marvell.com \
    --cc=ruifeng.wang@arm.com \
    --cc=shshaikh@marvell.com \
    --cc=somnath.kotur@broadcom.com \
    --cc=xiaoyun.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.