All of lore.kernel.org
 help / color / mirror / Atom feed
From: Hannes Reinecke <hare@suse.de>
To: Christoph Hellwig <hch@lst.de>,
	"Martin K. Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org
Subject: Re: [PATCH 02/10] scsi: remove scsi_init_cmd_errh
Date: Mon, 5 Oct 2020 11:01:37 +0200	[thread overview]
Message-ID: <04d88915-e9c0-5603-d3cd-b4216881d988@suse.de> (raw)
In-Reply-To: <20201005084130.143273-3-hch@lst.de>

On 10/5/20 10:41 AM, Christoph Hellwig wrote:
> There is no good reason to keep this functionality as a separate
> function, just merge it into the only caller.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>   drivers/scsi/scsi_lib.c | 20 ++++----------------
>   1 file changed, 4 insertions(+), 16 deletions(-)
> 
> diff --git a/drivers/scsi/scsi_lib.c b/drivers/scsi/scsi_lib.c
> index b95e00ff346b09..8a7ae46b5943da 100644
> --- a/drivers/scsi/scsi_lib.c
> +++ b/drivers/scsi/scsi_lib.c
> @@ -293,21 +293,6 @@ int __scsi_execute(struct scsi_device *sdev, const unsigned char *cmd,
>   }
>   EXPORT_SYMBOL(__scsi_execute);
>   
> -/**
> - * scsi_init_cmd_errh - Initialize cmd fields related to error handling.
> - * @cmd:  command that is ready to be queued.
> - *
> - * This function has the job of initializing a number of fields related to error
> - * handling. Typically this will be called once for each command, as required.
> - */
> -static void scsi_init_cmd_errh(struct scsi_cmnd *cmd)
> -{
> -	scsi_set_resid(cmd, 0);
> -	memset(cmd->sense_buffer, 0, SCSI_SENSE_BUFFERSIZE);
> -	if (cmd->cmd_len == 0)
> -		cmd->cmd_len = scsi_command_size(cmd->cmnd);
> -}
> -
>   /*
>    * Wake up the error handler if necessary. Avoid as follows that the error
>    * handler is not woken up if host in-flight requests number ==
> @@ -1698,7 +1683,10 @@ static blk_status_t scsi_queue_rq(struct blk_mq_hw_ctx *hctx,
>   	if (bd->last)
>   		cmd->flags |= SCMD_LAST;
>   
> -	scsi_init_cmd_errh(cmd);
> +	scsi_set_resid(cmd, 0);
> +	memset(cmd->sense_buffer, 0, SCSI_SENSE_BUFFERSIZE);
> +	if (cmd->cmd_len == 0)
> +		cmd->cmd_len = scsi_command_size(cmd->cmnd);
>   	cmd->scsi_done = scsi_mq_done;
>   
>   	reason = scsi_dispatch_cmd(cmd);
> 
Reviewed-by: Hannes Reinecke <hare@suse.de>

Cheers,

Hannes
-- 
Dr. Hannes Reinecke                Kernel Storage Architect
hare@suse.de                              +49 911 74053 688
SUSE Software Solutions GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), Geschäftsführer: Felix Imendörffer

  reply	other threads:[~2020-10-05  9:01 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-05  8:41 misc I/O submission cleanups Christoph Hellwig
2020-10-05  8:41 ` [PATCH 01/10] scsi: don't export scsi_device_from_queue Christoph Hellwig
2020-10-05  9:00   ` Hannes Reinecke
2020-10-13 22:42   ` Martin K. Petersen
2020-10-05  8:41 ` [PATCH 02/10] scsi: remove scsi_init_cmd_errh Christoph Hellwig
2020-10-05  9:01   ` Hannes Reinecke [this message]
2020-10-05  8:41 ` [PATCH 03/10] scsi: move command size detection out of the fast path Christoph Hellwig
2020-10-05  9:02   ` Hannes Reinecke
2020-10-05  8:41 ` [PATCH 04/10] scsi: simplify varlen CDB length checking Christoph Hellwig
2020-10-05  9:03   ` Hannes Reinecke
2020-10-05 16:06   ` Bart Van Assche
2020-10-07  2:36     ` Martin K. Petersen
2020-10-05  8:41 ` [PATCH 05/10] scsi: use rq_dma_dir in scsi_setup_cmnd Christoph Hellwig
2020-10-05  9:04   ` Hannes Reinecke
2020-10-05  8:41 ` [PATCH 06/10] scsi: rename scsi_prep_state_check to scsi_device_state_check Christoph Hellwig
2020-10-05  9:04   ` Hannes Reinecke
2020-10-05  8:41 ` [PATCH 07/10] scsi: rename scsi_mq_prep_fn to scsi_prepare_cmd Christoph Hellwig
2020-10-05  9:05   ` Hannes Reinecke
2020-10-05  8:41 ` [PATCH 08/10] scsi: cleanup allocation and freeing of sgtables Christoph Hellwig
2020-10-06  5:49   ` Hannes Reinecke
2020-10-05  8:41 ` [PATCH 09/10] scsi: remove scsi_setup_cmnd and scsi_setup_fs_cmnd Christoph Hellwig
2020-10-05  8:41 ` [PATCH 10/10] scsi: only start the request just before dispatching Christoph Hellwig
2020-10-05 16:11   ` Bart Van Assche
2020-10-07  2:37 ` misc I/O submission cleanups Martin K. Petersen
2020-10-08 16:39 ` Qian Cai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=04d88915-e9c0-5603-d3cd-b4216881d988@suse.de \
    --to=hare@suse.de \
    --cc=hch@lst.de \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.