On 17.03.20 19:16, Alberto Garcia wrote: > This function returns an integer that can be either an error code or a > cluster type (a value from the QCow2ClusterType enum). > > We are going to start using subcluster types instead of cluster types > in some functions so it's better to use the exact data types instead > of integers for clarity and in order to detect errors more easily. > > This patch makes qcow2_get_host_offset() return 0 on success and > puts the returned cluster type in a separate parameter. There are no > semantic changes. > > Signed-off-by: Alberto Garcia > --- > block/qcow2.h | 3 ++- > block/qcow2-cluster.c | 11 +++++++---- > block/qcow2.c | 37 ++++++++++++++++++++++--------------- > 3 files changed, 31 insertions(+), 20 deletions(-) Reviewed-by: Max Reitz