All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func
@ 2019-07-19  2:42 Alex Shi
  2019-07-19  2:42 ` [PATCH v2 2/2] cputime: remove duplicate code in account_process_tick Alex Shi
  2019-07-19  8:11 ` [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Peter Zijlstra
  0 siblings, 2 replies; 4+ messages in thread
From: Alex Shi @ 2019-07-19  2:42 UTC (permalink / raw)
  Cc: Alex Shi, Ingo Molnar, Peter Zijlstra, Frederic Weisbecker,
	Wanpeng Li, Thomas Gleixner, linux-kernel

Using the per cpu rq in function directly is enough, don't need get and
pass it from outside as a parameter. That's make function neat.

Signed-off-by: Alex Shi <alex.shi@linux.alibaba.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Frederic Weisbecker <fweisbec@gmail.com>
Cc: Wanpeng Li <wanpeng.li@hotmail.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: linux-kernel@vger.kernel.org
---
 kernel/sched/cputime.c | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

diff --git a/kernel/sched/cputime.c b/kernel/sched/cputime.c
index 2305ce89a26c..3aaf761ede81 100644
--- a/kernel/sched/cputime.c
+++ b/kernel/sched/cputime.c
@@ -355,7 +355,7 @@ void thread_group_cputime(struct task_struct *tsk, struct task_cputime *times)
  * softirq as those do not count in task exec_runtime any more.
  */
 static void irqtime_account_process_tick(struct task_struct *p, int user_tick,
-					 struct rq *rq, int ticks)
+					 int ticks)
 {
 	u64 other, cputime = TICK_NSEC * ticks;
 
@@ -381,7 +381,7 @@ static void irqtime_account_process_tick(struct task_struct *p, int user_tick,
 		account_system_index_time(p, cputime, CPUTIME_SOFTIRQ);
 	} else if (user_tick) {
 		account_user_time(p, cputime);
-	} else if (p == rq->idle) {
+	} else if (p == this_rq()->idle) {
 		account_idle_time(cputime);
 	} else if (p->flags & PF_VCPU) { /* System time or guest time */
 		account_guest_time(p, cputime);
@@ -392,14 +392,12 @@ static void irqtime_account_process_tick(struct task_struct *p, int user_tick,
 
 static void irqtime_account_idle_ticks(int ticks)
 {
-	struct rq *rq = this_rq();
-
-	irqtime_account_process_tick(current, 0, rq, ticks);
+	irqtime_account_process_tick(current, 0, ticks);
 }
 #else /* CONFIG_IRQ_TIME_ACCOUNTING */
 static inline void irqtime_account_idle_ticks(int ticks) { }
 static inline void irqtime_account_process_tick(struct task_struct *p, int user_tick,
-						struct rq *rq, int nr_ticks) { }
+						int nr_ticks) { }
 #endif /* CONFIG_IRQ_TIME_ACCOUNTING */
 
 /*
@@ -475,13 +473,12 @@ void thread_group_cputime_adjusted(struct task_struct *p, u64 *ut, u64 *st)
 void account_process_tick(struct task_struct *p, int user_tick)
 {
 	u64 cputime, steal;
-	struct rq *rq = this_rq();
 
 	if (vtime_accounting_cpu_enabled())
 		return;
 
 	if (sched_clock_irqtime) {
-		irqtime_account_process_tick(p, user_tick, rq, 1);
+		irqtime_account_process_tick(p, user_tick, 1);
 		return;
 	}
 
@@ -495,7 +492,7 @@ void account_process_tick(struct task_struct *p, int user_tick)
 
 	if (user_tick)
 		account_user_time(p, cputime);
-	else if ((p != rq->idle) || (irq_count() != HARDIRQ_OFFSET))
+	else if ((p != this_rq()->idle) || (irq_count() != HARDIRQ_OFFSET))
 		account_system_time(p, HARDIRQ_OFFSET, cputime);
 	else
 		account_idle_time(cputime);
-- 
2.19.1.856.g8858448bb


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH v2 2/2] cputime: remove duplicate code in account_process_tick
  2019-07-19  2:42 [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Alex Shi
@ 2019-07-19  2:42 ` Alex Shi
  2019-07-19  8:11 ` [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Peter Zijlstra
  1 sibling, 0 replies; 4+ messages in thread
From: Alex Shi @ 2019-07-19  2:42 UTC (permalink / raw)
  Cc: Alex Shi, Ingo Molnar, Peter Zijlstra, Frederic Weisbecker,
	Wanpeng Li, Thomas Gleixner, linux-kernel

The irqtime_account_process_tick path was introduced for precise ns irq
time account from commit abb74cefa9c682fb (sched: Export ns irqtimes through
/proc/stat) while account_process_tick still use jiffes. This divide
isn't neccessary especially now both pathes are ns precison.

Move out the irqtime_account_process_tick func from IRQ_TIME_ACCOUNTING.
So it do generally same things as account_process_tick whenever if
IRQ_TIME_ACCOUNTING set or if sched_clock_irqtime enabled.

Signed-off-by: Alex Shi <alex.shi@linux.alibaba.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Frederic Weisbecker <fweisbec@gmail.com>
Cc: Wanpeng Li <wanpeng.li@hotmail.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: linux-kernel@vger.kernel.org
---
 kernel/sched/cputime.c | 26 ++------------------------
 1 file changed, 2 insertions(+), 24 deletions(-)

diff --git a/kernel/sched/cputime.c b/kernel/sched/cputime.c
index 3aaf761ede81..6116f50e1f37 100644
--- a/kernel/sched/cputime.c
+++ b/kernel/sched/cputime.c
@@ -332,7 +332,6 @@ void thread_group_cputime(struct task_struct *tsk, struct task_cputime *times)
 	rcu_read_unlock();
 }
 
-#ifdef CONFIG_IRQ_TIME_ACCOUNTING
 /*
  * Account a tick to a process and cpustat
  * @p: the process that the CPU time gets accounted to
@@ -390,14 +389,13 @@ static void irqtime_account_process_tick(struct task_struct *p, int user_tick,
 	}
 }
 
+#ifdef CONFIG_IRQ_TIME_ACCOUNTING
 static void irqtime_account_idle_ticks(int ticks)
 {
 	irqtime_account_process_tick(current, 0, ticks);
 }
 #else /* CONFIG_IRQ_TIME_ACCOUNTING */
 static inline void irqtime_account_idle_ticks(int ticks) { }
-static inline void irqtime_account_process_tick(struct task_struct *p, int user_tick,
-						int nr_ticks) { }
 #endif /* CONFIG_IRQ_TIME_ACCOUNTING */
 
 /*
@@ -472,30 +470,10 @@ void thread_group_cputime_adjusted(struct task_struct *p, u64 *ut, u64 *st)
  */
 void account_process_tick(struct task_struct *p, int user_tick)
 {
-	u64 cputime, steal;
-
 	if (vtime_accounting_cpu_enabled())
 		return;
 
-	if (sched_clock_irqtime) {
-		irqtime_account_process_tick(p, user_tick, 1);
-		return;
-	}
-
-	cputime = TICK_NSEC;
-	steal = steal_account_process_time(ULONG_MAX);
-
-	if (steal >= cputime)
-		return;
-
-	cputime -= steal;
-
-	if (user_tick)
-		account_user_time(p, cputime);
-	else if ((p != this_rq()->idle) || (irq_count() != HARDIRQ_OFFSET))
-		account_system_time(p, HARDIRQ_OFFSET, cputime);
-	else
-		account_idle_time(cputime);
+	irqtime_account_process_tick(p, user_tick, 1);
 }
 
 /*
-- 
2.19.1.856.g8858448bb


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func
  2019-07-19  2:42 [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Alex Shi
  2019-07-19  2:42 ` [PATCH v2 2/2] cputime: remove duplicate code in account_process_tick Alex Shi
@ 2019-07-19  8:11 ` Peter Zijlstra
  2019-07-22  7:37   ` Alex Shi
  1 sibling, 1 reply; 4+ messages in thread
From: Peter Zijlstra @ 2019-07-19  8:11 UTC (permalink / raw)
  To: Alex Shi
  Cc: Ingo Molnar, Frederic Weisbecker, Wanpeng Li, Thomas Gleixner,
	linux-kernel

On Fri, Jul 19, 2019 at 10:42:41AM +0800, Alex Shi wrote:
> Using the per cpu rq in function directly is enough, don't need get and
> pass it from outside as a parameter. That's make function neat.

Please look at code-gen; I'm thinking this patch makes things worse.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func
  2019-07-19  8:11 ` [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Peter Zijlstra
@ 2019-07-22  7:37   ` Alex Shi
  0 siblings, 0 replies; 4+ messages in thread
From: Alex Shi @ 2019-07-22  7:37 UTC (permalink / raw)
  To: Peter Zijlstra
  Cc: Ingo Molnar, Frederic Weisbecker, Wanpeng Li, Thomas Gleixner,
	linux-kernel



在 2019/7/19 下午4:11, Peter Zijlstra 写道:
> On Fri, Jul 19, 2019 at 10:42:41AM +0800, Alex Shi wrote:
>> Using the per cpu rq in function directly is enough, don't need get and
>> pass it from outside as a parameter. That's make function neat.
> 
> Please look at code-gen; I'm thinking this patch makes things worse.
> 

Thanks a lot, Peter! 

This patch reference one more time on this_rq(), that do increase cputime.o size. I will move it after access_process_tick() patch in v3. That could resovle the problem and decreases objfile's size on each of patches.

Thanks
Alex 

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2019-07-22  7:38 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-19  2:42 [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Alex Shi
2019-07-19  2:42 ` [PATCH v2 2/2] cputime: remove duplicate code in account_process_tick Alex Shi
2019-07-19  8:11 ` [PATCH v2 1/2] cputime: remove rq parameter for irqtime_account_process_tick func Peter Zijlstra
2019-07-22  7:37   ` Alex Shi

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.