From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Monjalon Subject: Re: [PATCH v10 02/18] lib: create private header file Date: Wed, 15 Mar 2017 18:18:48 +0100 Message-ID: <11064293.gTtyHWn9o3@xps13> References: <1488791433-186137-2-git-send-email-david.hunt@intel.com> <1489558767-56329-1-git-send-email-david.hunt@intel.com> <1489558767-56329-3-git-send-email-david.hunt@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7Bit Cc: dev@dpdk.org, bruce.richardson@intel.com, nelio.laranjeiro@6wind.com To: David Hunt Return-path: Received: from mail-wm0-f49.google.com (mail-wm0-f49.google.com [74.125.82.49]) by dpdk.org (Postfix) with ESMTP id 599A0A10 for ; Wed, 15 Mar 2017 18:18:50 +0100 (CET) Received: by mail-wm0-f49.google.com with SMTP id t189so28545212wmt.1 for ; Wed, 15 Mar 2017 10:18:50 -0700 (PDT) In-Reply-To: <1489558767-56329-3-git-send-email-david.hunt@intel.com> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" 2017-03-15 06:19, David Hunt: > +/** > + * Number of packets to deal with in bursts. Needs to be 8 so as to > + * fit in one cache line. > + */ > +#define RTE_DIST_BURST_SIZE (sizeof(rte_xmm_t) / sizeof(uint16_t)) error: 'rte_xmm_t' undeclared here (arm compilation) Can it be fixed by including rte_vect.h? Ideally I would prefer we stop using XMM types in a generic code. XMM are x86-only registers. It has been translated for other arches but we should use a more generic name. What was the intention here? SSE-optimized code or 128-bit size? Please check lib/librte_eal/common/include/generic/rte_vect.h for a generic type.