From mboxrd@z Thu Jan 1 00:00:00 1970 From: Bharat Bhushan Subject: [PATCH 0/4] *** SUBJECT HERE *** Date: Mon, 28 Oct 2013 15:52:26 +0530 Message-ID: <1382955750-32249-1-git-send-email-Bharat.Bhushan@freescale.com> Mime-Version: 1.0 Content-Type: text/plain Cc: Bharat Bhushan To: , , , , Return-path: Sender: kvm-ppc-owner@vger.kernel.org List-Id: kvm.vger.kernel.org From: Bharat Bhushan v1->v2 - Removed _PAGE_BUSY loop as suggested by PaulS. - Added check for PAGE_SPLITTING kvm: powerpc: use cache attributes from linux pte - 1st Patch fixes a bug in booke (detail in patch) - 2nd patch is renaming the linux_pte_lookup_function() just for clarity. There is not functional change. - 3nd Patch adds a Linux pte lookup function. - 4th Patch uses the above defined function and setup TLB.wimg accordingly Bharat Bhushan (4): kvm: booke: clear host tlb reference flag on guest tlb invalidation kvm: book3s: rename lookup_linux_pte() to lookup_linux_pte_and_update() kvm: powerpc: define a linux pte lookup function kvm: powerpc: use caching attributes as per linux pte arch/powerpc/include/asm/kvm_host.h | 2 +- arch/powerpc/include/asm/pgtable.h | 27 +++++++++++++++++ arch/powerpc/kvm/book3s_hv_rm_mmu.c | 8 +++-- arch/powerpc/kvm/booke.c | 1 + arch/powerpc/kvm/e500.h | 8 +++-- arch/powerpc/kvm/e500_mmu_host.c | 55 +++++++++++++++++++--------------- 6 files changed, 70 insertions(+), 31 deletions(-) From mboxrd@z Thu Jan 1 00:00:00 1970 From: Bharat Bhushan Date: Mon, 28 Oct 2013 10:34:26 +0000 Subject: [PATCH 0/4] *** SUBJECT HERE *** Message-Id: <1382955750-32249-1-git-send-email-Bharat.Bhushan@freescale.com> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: paulus@samba.org, agraf@suse.de, kvm-ppc@vger.kernel.org, kvm@vger.kernel.org, scottwood@freescale.com Cc: Bharat Bhushan From: Bharat Bhushan v1->v2 - Removed _PAGE_BUSY loop as suggested by PaulS. - Added check for PAGE_SPLITTING kvm: powerpc: use cache attributes from linux pte - 1st Patch fixes a bug in booke (detail in patch) - 2nd patch is renaming the linux_pte_lookup_function() just for clarity. There is not functional change. - 3nd Patch adds a Linux pte lookup function. - 4th Patch uses the above defined function and setup TLB.wimg accordingly Bharat Bhushan (4): kvm: booke: clear host tlb reference flag on guest tlb invalidation kvm: book3s: rename lookup_linux_pte() to lookup_linux_pte_and_update() kvm: powerpc: define a linux pte lookup function kvm: powerpc: use caching attributes as per linux pte arch/powerpc/include/asm/kvm_host.h | 2 +- arch/powerpc/include/asm/pgtable.h | 27 +++++++++++++++++ arch/powerpc/kvm/book3s_hv_rm_mmu.c | 8 +++-- arch/powerpc/kvm/booke.c | 1 + arch/powerpc/kvm/e500.h | 8 +++-- arch/powerpc/kvm/e500_mmu_host.c | 55 +++++++++++++++++++--------------- 6 files changed, 70 insertions(+), 31 deletions(-)