All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Bastien ROUCARIÈS" <roucaries.bastien@gmail.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 3/4] kirkwood: Set unused SD pins back to GPIO for DNS-320 & DNS-325
Date: Sun,  8 Jun 2014 18:30:27 +0200	[thread overview]
Message-ID: <1402245028-7525-3-git-send-email-roucaries.bastien@gmail.com> (raw)
In-Reply-To: <1402245028-7525-1-git-send-email-roucaries.bastien@gmail.com>

From: Jamie Lentin <jm@lentin.co.uk>

Neither device makes any use of the SD reader functionalty, so as
suggested by Stefan Herbrechtsmeier, set the pins to GPIO instead
to make this more obvious. Label MPP10 & MPP11's use whilst here.

Signed-off-by: Jamie Lentin <jm@lentin.co.uk>
Cc: prafulla at marvell.com
Cc: albert.u.boot at aribaud.net
Cc: stefan at herbrechtsmeier.net
---
 board/d-link/dnskw/dnskw.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/board/d-link/dnskw/dnskw.c b/board/d-link/dnskw/dnskw.c
index a9fa9a2..90cb92e 100644
--- a/board/d-link/dnskw/dnskw.c
+++ b/board/d-link/dnskw/dnskw.c
@@ -39,14 +39,14 @@ int board_early_init_f(void)
 		MPP7_GPO,
 		MPP8_TW_SDA,
 		MPP9_TW_SCK,
-		MPP10_UART0_TXD,
-		MPP11_UART0_RXD,
-		MPP12_SD_CLK,
+		MPP10_UART0_TXD,	/* 5 pin ...*/
+		MPP11_UART0_RXD,	/* ... console header */
+		MPP12_GPO,
 		MPP13_UART1_TXD,	/* Custom ...*/
 		MPP14_UART1_RXD,	/* ... controller */
-		MPP15_SD_D1,
-		MPP16_SD_D2,
-		MPP17_SD_D3,
+		MPP15_GPIO,
+		MPP16_GPIO,
+		MPP17_GPIO,
 		MPP18_NF_IO0,
 		MPP19_NF_IO1,
 		MPP20_SATA1_ACTn,	/* sata1(left) status led */
-- 
2.0.0.rc2

  parent reply	other threads:[~2014-06-08 16:30 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-08 16:30 [U-Boot] [PATCH 1/4] kirkwood: Rename dns325 to dnskw Bastien ROUCARIÈS
2014-06-08 16:30 ` [U-Boot] [PATCH 2/4] kirkwood: Add support for the D-Link DNS-320 Bastien ROUCARIÈS
2014-06-08 16:30 ` Bastien ROUCARIÈS [this message]
2014-06-08 16:30 ` [U-Boot] [PATCH 4/4] kirkwood: Shorten DNS-325 IDENT_STRING to match DNS-320 Bastien ROUCARIÈS
2014-07-01 20:03 ` [U-Boot] [PATCH 1/4] kirkwood: Rename dns325 to dnskw Albert ARIBAUD
2014-07-01 20:09   ` Bastien ROUCARIES
2014-07-04 17:01 ` [U-Boot] [PATCH v4: DNS320 support 0/4] Add a new kirkwook board Bastien ROUCARIÈS
2014-07-04 17:01   ` [U-Boot] [PATCH 1/4] kirkwood: Rename dns325 to dnskw Bastien ROUCARIÈS
2014-07-04 18:46     ` Albert ARIBAUD
2014-07-04 17:01   ` [U-Boot] [PATCH 2/4] kirkwood: Add support for the D-Link DNS-320 Bastien ROUCARIÈS
2014-07-04 18:48     ` Albert ARIBAUD
2014-07-04 17:01   ` [U-Boot] [PATCH 3/4] kirkwood: Set unused SD pins back to GPIO for DNS-320 & DNS-325 Bastien ROUCARIÈS
2014-07-04 17:01   ` [U-Boot] [PATCH 4/4] kirkwood: Shorten DNS-325 IDENT_STRING to match DNS-320 Bastien ROUCARIÈS
2014-07-04 20:08 ` [U-Boot] [PATCH V5: 0/5] Add a new kirkwook board Bastien ROUCARIÈS
2014-07-04 20:08   ` [U-Boot] [PATCH V5: 1/5] kirkwood: Rename dns325 to dnskw Bastien ROUCARIÈS
2014-07-04 20:08   ` [U-Boot] [PATCH V5: 2/5] kirkwood: Add support for the D-Link DNS-320 Bastien ROUCARIÈS
2014-07-04 20:08   ` [U-Boot] [PATCH V5: 3/5] kirkwood: Set unused SD pins back to GPIO for DNS-320 & DNS-325 Bastien ROUCARIÈS
2014-07-04 20:08   ` [U-Boot] [PATCH V5: 4/5] kirkwood: Shorten DNS-325 IDENT_STRING to match DNS-320 Bastien ROUCARIÈS
2014-07-04 20:08   ` [U-Boot] [PATCH V5: 5/5] Add documentation for dns-32{0,5} Bastien ROUCARIÈS
2014-07-20 15:22     ` Bastien ROUCARIES
  -- strict thread matches above, loose matches on Subject: below --
2014-05-18 16:21 [U-Boot] [V2][PATCH 0/4] Support d-link dns320 (arch kirkwood) Bastien ROUCARIÈS
2014-05-18 16:21 ` [U-Boot] [PATCH 3/4] kirkwood: Set unused SD pins back to GPIO for DNS-320 & DNS-325 Bastien ROUCARIÈS

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1402245028-7525-3-git-send-email-roucaries.bastien@gmail.com \
    --to=roucaries.bastien@gmail.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.