All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vivek Gautam <gautam.vivek@samsung.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 1/2] usb: Rename usb_submit_int_msg() API to usb_int_msg()
Date: Tue, 24 Jun 2014 19:40:21 +0530	[thread overview]
Message-ID: <1403619022-15662-2-git-send-email-gautam.vivek@samsung.com> (raw)
In-Reply-To: <1403619022-15662-1-git-send-email-gautam.vivek@samsung.com>

Until yet usb_**_msg() APIs don't contain the string 'submit'.
Rename it to make things uniform. This is also helping while
adding a host translational layer wherein we are using
usb_submit_**_msg string to name APIs.

Signed-off-by: Vivek Gautam <gautam.vivek@samsung.com>
---
 common/usb.c         |    4 ++--
 common/usb_kbd.c     |    6 +++---
 common/usb_storage.c |    2 +-
 include/usb.h        |    2 +-
 4 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/common/usb.c b/common/usb.c
index 60daa10..5dd09aa 100644
--- a/common/usb.c
+++ b/common/usb.c
@@ -155,10 +155,10 @@ int usb_disable_asynch(int disable)
 /*
  * submits an Interrupt Message
  */
-int usb_submit_int_msg(struct usb_device *dev, unsigned long pipe,
+int usb_int_msg(struct usb_device *dev, unsigned long pipe,
 			void *buffer, int transfer_len, int interval)
 {
-	return submit_int_msg(dev, pipe, buffer, transfer_len, interval);
+	return usb_submit_int_msg(dev, pipe, buffer, transfer_len, interval);
 }
 
 /*
diff --git a/common/usb_kbd.c b/common/usb_kbd.c
index 0b77c16..d9802b0 100644
--- a/common/usb_kbd.c
+++ b/common/usb_kbd.c
@@ -136,7 +136,7 @@ void usb_kbd_generic_poll(void)
 
 	/* Submit a interrupt transfer request */
 	maxp = usb_maxpacket(usb_kbd_dev, pipe);
-	usb_submit_int_msg(usb_kbd_dev, pipe, data->new,
+	usb_int_msg(usb_kbd_dev, pipe, data->new,
 		min(maxp, USB_KBD_BOOT_REPORT_SIZE),
 		ep->bInterval);
 }
@@ -343,7 +343,7 @@ static inline void usb_kbd_poll_for_event(struct usb_device *dev)
 
 	/* Submit a interrupt transfer request */
 	maxp = usb_maxpacket(dev, pipe);
-	usb_submit_int_msg(dev, pipe, &data->new[0],
+	usb_int_msg(dev, pipe, &data->new[0],
 		min(maxp, USB_KBD_BOOT_REPORT_SIZE),
 		ep->bInterval);
 
@@ -472,7 +472,7 @@ static int usb_kbd_probe(struct usb_device *dev, unsigned int ifnum)
 	usb_set_idle(dev, iface->desc.bInterfaceNumber, REPEAT_RATE, 0);
 
 	debug("USB KBD: enable interrupt pipe...\n");
-	if (usb_submit_int_msg(dev, pipe, data->new,
+	if (usb_int_msg(dev, pipe, data->new,
 			       min(maxp, USB_KBD_BOOT_REPORT_SIZE),
 			       ep->bInterval) < 0) {
 		printf("Failed to get keyboard state from device %04x:%04x\n",
diff --git a/common/usb_storage.c b/common/usb_storage.c
index 6ac358d..91a8a86 100644
--- a/common/usb_storage.c
+++ b/common/usb_storage.c
@@ -598,7 +598,7 @@ static int usb_stor_CBI_get_status(ccb *srb, struct us_data *us)
 	int timeout;
 
 	us->ip_wanted = 1;
-	submit_int_msg(us->pusb_dev, us->irqpipe,
+	usb_submit_int_msg(us->pusb_dev, us->irqpipe,
 			(void *) &us->ip_data, us->irqmaxp, us->irqinterval);
 	timeout = 1000;
 	while (timeout--) {
diff --git a/include/usb.h b/include/usb.h
index d9fedee..30fc890 100644
--- a/include/usb.h
+++ b/include/usb.h
@@ -234,7 +234,7 @@ int usb_control_msg(struct usb_device *dev, unsigned int pipe,
 			void *data, unsigned short size, int timeout);
 int usb_bulk_msg(struct usb_device *dev, unsigned int pipe,
 			void *data, int len, int *actual_length, int timeout);
-int usb_submit_int_msg(struct usb_device *dev, unsigned long pipe,
+int usb_int_msg(struct usb_device *dev, unsigned long pipe,
 			void *buffer, int transfer_len, int interval);
 int usb_disable_asynch(int disable);
 int usb_maxpacket(struct usb_device *dev, unsigned long pipe);
-- 
1.7.10.4

  reply	other threads:[~2014-06-24 14:10 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-24 14:10 [U-Boot] [PATCH RFC 0/2] usb: host: Add a wrapper layer for mutiple host support Vivek Gautam
2014-06-24 14:10 ` Vivek Gautam [this message]
2014-06-24 14:10 ` [U-Boot] [PATCH 2/2] RFC: usb: host: Introduce host translational layer Vivek Gautam
2014-06-24 14:26 ` [U-Boot] [PATCH RFC 0/2] usb: host: Add a wrapper layer for mutiple host support Marek Vasut
2014-06-25  5:11   ` Vivek Gautam
2014-06-25  6:08     ` Marek Vasut
2014-06-25  6:27       ` Simon Glass
2014-06-25  8:33         ` Marek Vasut
2014-06-26  2:30           ` Simon Glass
2014-06-26  4:34             ` Vivek Gautam
2014-06-26  4:46               ` Vivek Gautam
2014-06-26  9:21                 ` Marek Vasut
2014-07-07 22:46                   ` Simon Glass

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1403619022-15662-2-git-send-email-gautam.vivek@samsung.com \
    --to=gautam.vivek@samsung.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.