From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932722AbbCQW3d (ORCPT ); Tue, 17 Mar 2015 18:29:33 -0400 Received: from mx1.redhat.com ([209.132.183.28]:48591 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754500AbbCQW3a (ORCPT ); Tue, 17 Mar 2015 18:29:30 -0400 Message-ID: <1426631368.3643.348.camel@redhat.com> Subject: Re: [PATCH v14 19/20] vfio: initialize the virqfd workqueue in VFIO generic code From: Alex Williamson To: Baptiste Reynal Cc: iommu@lists.linux-foundation.org, kvmarm@lists.cs.columbia.edu, tech@virtualopensystems.com, Antonios Motakis , Gavin Shan , Benjamin Herrenschmidt , Alexey Kardashevskiy , Wei Yang , "open list:VFIO DRIVER" , open list Date: Tue, 17 Mar 2015 16:29:28 -0600 In-Reply-To: <1425315600-29761-20-git-send-email-b.reynal@virtualopensystems.com> References: <1425315600-29761-1-git-send-email-b.reynal@virtualopensystems.com> <1425315600-29761-20-git-send-email-b.reynal@virtualopensystems.com> Content-Type: text/plain; charset="UTF-8" Mime-Version: 1.0 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 2015-03-02 at 17:59 +0100, Baptiste Reynal wrote: > From: Antonios Motakis > > Now we have finally completely decoupled virqfd from VFIO_PCI. We can > initialize it from the VFIO generic code, in order to safely use it from > multiple independent VFIO bus drivers. > > Signed-off-by: Antonios Motakis > Signed-off-by: Baptiste Reynal > --- > drivers/vfio/Makefile | 4 +++- > drivers/vfio/pci/Makefile | 3 +-- > drivers/vfio/pci/vfio_pci.c | 8 -------- > drivers/vfio/vfio.c | 8 ++++++++ > 4 files changed, 12 insertions(+), 11 deletions(-) > > diff --git a/drivers/vfio/Makefile b/drivers/vfio/Makefile > index dadf0ca..d798b09 100644 > --- a/drivers/vfio/Makefile > +++ b/drivers/vfio/Makefile > @@ -1,4 +1,6 @@ > -obj-$(CONFIG_VFIO) += vfio.o > +vfio_core-y := vfio.o virqfd.o > + > +obj-$(CONFIG_VFIO) += vfio_core.o > obj-$(CONFIG_VFIO_IOMMU_TYPE1) += vfio_iommu_type1.o > obj-$(CONFIG_VFIO_IOMMU_SPAPR_TCE) += vfio_iommu_spapr_tce.o > obj-$(CONFIG_VFIO_SPAPR_EEH) += vfio_spapr_eeh.o This inadvertently (I assume) renames the main vfio module to vfio_core. That potentially breaks numerous userspace scripts that might try to load the "vfio" module. I don't think that's acceptable. A brute force way to fix this would be to rename vfio.c to vfio_core.c and change the Makefile to: vfio-y := vfio_core.o virqfd.o obj-$(CONFIG_VFIO) += vfio.o Is there any other trickery available to us that could include virqfd.o in vfio.o w/o source file renaming? Thanks, Alex