From mboxrd@z Thu Jan 1 00:00:00 1970 From: Thomas Chou Date: Sat, 5 Sep 2015 10:41:27 +0800 Subject: [U-Boot] [PATCH v3 6/8] nios2: define _end in link script In-Reply-To: <201509041601.17045.marex@denx.de> References: <201509041601.17045.marex@denx.de> Message-ID: <1441420887-6555-1-git-send-email-thomas@wytron.com.tw> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544 "rename _end to __bss_end__" , the _end was removed. But we need it now for separated device tree control, ie, CONFIG_OF_SEPARATE . The _end is used by fdtdec_setup() to find the blob. Signed-off-by: Thomas Chou Acked-by: Marek Vasut Reviewed-by: Simon Glass --- v3 comment coding style fix arch/nios2/cpu/u-boot.lds | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds index 8b0fd1a..9d13ecc 100644 --- a/arch/nios2/cpu/u-boot.lds +++ b/arch/nios2/cpu/u-boot.lds @@ -67,6 +67,12 @@ SECTIONS _edata = .; PROVIDE (edata = .); + /* + * _end - This is end of u-boot.bin image. + * dtb will be appended here to make u-boot-dtb.bin + */ + _end = .; + /* UNINIT DATA - Small uninitialized data is first so it's * adjacent to sdata and can be referenced via gp. The normal * bss follows. We keep it adjacent to simplify init code. -- 2.1.4