From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751943AbcDOB4L (ORCPT ); Thu, 14 Apr 2016 21:56:11 -0400 Received: from mailgw01.mediatek.com ([210.61.82.183]:24905 "EHLO mailgw01.mediatek.com" rhost-flags-OK-FAIL-OK-FAIL) by vger.kernel.org with ESMTP id S1751535AbcDOB4J (ORCPT ); Thu, 14 Apr 2016 21:56:09 -0400 Message-ID: <1460685362.28853.19.camel@mtksdaap41> Subject: Re: [alsa-devel] [RFC PATCH v2 1/5] ASoC: Mediatek: Refine mt8173 driver From: Garlic Tseng To: Yingjoe Chen CC: , , , , , , , , , Date: Fri, 15 Apr 2016 09:56:02 +0800 In-Reply-To: <1460637893.13240.24.camel@mtksdaap41> References: <1460636070-37426-1-git-send-email-garlic.tseng@mediatek.com> <1460636070-37426-2-git-send-email-garlic.tseng@mediatek.com> <1460637893.13240.24.camel@mtksdaap41> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.2.3-0ubuntu6 Content-Transfer-Encoding: 7bit MIME-Version: 1.0 X-MTK: N Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 2016-04-14 at 20:44 +0800, Yingjoe Chen wrote: > On Thu, 2016-04-14 at 20:14 +0800, Garlic Tseng wrote: > > Move mt8173 driver to another folder. > > > > The software control sequence of mt2701 is very different from that of mt8173, > > so this patch moves mt8173 code to another folder. > > > > > > Signed-off-by: Garlic Tseng > > --- > > sound/soc/mediatek/Makefile | 12 +++++------- > > sound/soc/mediatek/mt8173/Makefile | 7 +++++++ > > sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c | 4 ++-- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h | 0 > > sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c | 0 > > 8 files changed, 17 insertions(+), 12 deletions(-) > > create mode 100644 sound/soc/mediatek/mt8173/Makefile > > rename sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h (100%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c (100%) > > > > diff --git a/sound/soc/mediatek/Makefile b/sound/soc/mediatek/Makefile > > index d486860..5048165 100644 > > --- a/sound/soc/mediatek/Makefile > > +++ b/sound/soc/mediatek/Makefile > > @@ -1,7 +1,5 @@ > > -# MTK Platform Support > > -obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > -# Machine support > > -obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173-max98090.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173-rt5650.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173-rt5650-rt5514.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173-rt5650-rt5676.o > > +# 8173 Machine support > > +obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173/ > > Since all CONFIG_SND_SOC_MT8173_* depends on CONFIG_SND_SOC_MEDIATEK, > you could just do: > > obj-$(CONFIG_SND_SOC_MEDIATEK) += mt8173/ > > > This way we don't need to modify 2 makefiles when adding new ASoC > driver. Yes you're right. I'll modify it. > > > > diff --git a/sound/soc/mediatek/mt8173/Makefile b/sound/soc/mediatek/mt8173/Makefile > > new file mode 100644 > > index 0000000..d486860 > > --- /dev/null > > +++ b/sound/soc/mediatek/mt8173/Makefile > > @@ -0,0 +1,7 @@ > > +# MTK Platform Support > > +obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > Maybe we should also rename this to mt8173-afe-pcm.o? Well I agree with you. Maybe I have to check all the files and modify them with prefix "mt8173" and "mt2701". (or "mtk8173" and "mtk2701"? I'm not so sure here) > > Joe.C Thanks for your comments. From mboxrd@z Thu Jan 1 00:00:00 1970 From: Garlic Tseng Subject: Re: [RFC PATCH v2 1/5] ASoC: Mediatek: Refine mt8173 driver Date: Fri, 15 Apr 2016 09:56:02 +0800 Message-ID: <1460685362.28853.19.camel@mtksdaap41> References: <1460636070-37426-1-git-send-email-garlic.tseng@mediatek.com> <1460636070-37426-2-git-send-email-garlic.tseng@mediatek.com> <1460637893.13240.24.camel@mtksdaap41> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mailgw01.mediatek.com (unknown [210.61.82.183]) by alsa0.perex.cz (Postfix) with ESMTP id 418D4261A34 for ; Fri, 15 Apr 2016 03:56:08 +0200 (CEST) In-Reply-To: <1460637893.13240.24.camel@mtksdaap41> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: alsa-devel-bounces@alsa-project.org Sender: alsa-devel-bounces@alsa-project.org To: Yingjoe Chen Cc: alsa-devel@alsa-project.org, ir.lian@mediatek.com, srv_heupstream@mediatek.com, tiwai@suse.de, linux-kernel@vger.kernel.org, koro.chen@mediatek.com, broonie@kernel.org, linux-mediatek@lists.infradead.org, PC.Liao@mediatek.com, linux-arm-kernel@lists.infradead.org List-Id: alsa-devel@alsa-project.org On Thu, 2016-04-14 at 20:44 +0800, Yingjoe Chen wrote: > On Thu, 2016-04-14 at 20:14 +0800, Garlic Tseng wrote: > > Move mt8173 driver to another folder. > > > > The software control sequence of mt2701 is very different from that of mt8173, > > so this patch moves mt8173 code to another folder. > > > > > > Signed-off-by: Garlic Tseng > > --- > > sound/soc/mediatek/Makefile | 12 +++++------- > > sound/soc/mediatek/mt8173/Makefile | 7 +++++++ > > sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c | 4 ++-- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h | 0 > > sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c | 0 > > 8 files changed, 17 insertions(+), 12 deletions(-) > > create mode 100644 sound/soc/mediatek/mt8173/Makefile > > rename sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h (100%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c (100%) > > > > diff --git a/sound/soc/mediatek/Makefile b/sound/soc/mediatek/Makefile > > index d486860..5048165 100644 > > --- a/sound/soc/mediatek/Makefile > > +++ b/sound/soc/mediatek/Makefile > > @@ -1,7 +1,5 @@ > > -# MTK Platform Support > > -obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > -# Machine support > > -obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173-max98090.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173-rt5650.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173-rt5650-rt5514.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173-rt5650-rt5676.o > > +# 8173 Machine support > > +obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173/ > > Since all CONFIG_SND_SOC_MT8173_* depends on CONFIG_SND_SOC_MEDIATEK, > you could just do: > > obj-$(CONFIG_SND_SOC_MEDIATEK) += mt8173/ > > > This way we don't need to modify 2 makefiles when adding new ASoC > driver. Yes you're right. I'll modify it. > > > > diff --git a/sound/soc/mediatek/mt8173/Makefile b/sound/soc/mediatek/mt8173/Makefile > > new file mode 100644 > > index 0000000..d486860 > > --- /dev/null > > +++ b/sound/soc/mediatek/mt8173/Makefile > > @@ -0,0 +1,7 @@ > > +# MTK Platform Support > > +obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > Maybe we should also rename this to mt8173-afe-pcm.o? Well I agree with you. Maybe I have to check all the files and modify them with prefix "mt8173" and "mt2701". (or "mtk8173" and "mtk2701"? I'm not so sure here) > > Joe.C Thanks for your comments. From mboxrd@z Thu Jan 1 00:00:00 1970 From: garlic.tseng@mediatek.com (Garlic Tseng) Date: Fri, 15 Apr 2016 09:56:02 +0800 Subject: [alsa-devel] [RFC PATCH v2 1/5] ASoC: Mediatek: Refine mt8173 driver In-Reply-To: <1460637893.13240.24.camel@mtksdaap41> References: <1460636070-37426-1-git-send-email-garlic.tseng@mediatek.com> <1460636070-37426-2-git-send-email-garlic.tseng@mediatek.com> <1460637893.13240.24.camel@mtksdaap41> Message-ID: <1460685362.28853.19.camel@mtksdaap41> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On Thu, 2016-04-14 at 20:44 +0800, Yingjoe Chen wrote: > On Thu, 2016-04-14 at 20:14 +0800, Garlic Tseng wrote: > > Move mt8173 driver to another folder. > > > > The software control sequence of mt2701 is very different from that of mt8173, > > so this patch moves mt8173 code to another folder. > > > > > > Signed-off-by: Garlic Tseng > > --- > > sound/soc/mediatek/Makefile | 12 +++++------- > > sound/soc/mediatek/mt8173/Makefile | 7 +++++++ > > sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c | 4 ++-- > > sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c | 2 +- > > sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h | 0 > > sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c | 0 > > 8 files changed, 17 insertions(+), 12 deletions(-) > > create mode 100644 sound/soc/mediatek/mt8173/Makefile > > rename sound/soc/mediatek/{ => mt8173}/mt8173-max98090.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5514.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650-rt5676.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mt8173-rt5650.c (99%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-common.h (100%) > > rename sound/soc/mediatek/{ => mt8173}/mtk-afe-pcm.c (100%) > > > > diff --git a/sound/soc/mediatek/Makefile b/sound/soc/mediatek/Makefile > > index d486860..5048165 100644 > > --- a/sound/soc/mediatek/Makefile > > +++ b/sound/soc/mediatek/Makefile > > @@ -1,7 +1,5 @@ > > -# MTK Platform Support > > -obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > -# Machine support > > -obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173-max98090.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173-rt5650.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173-rt5650-rt5514.o > > -obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173-rt5650-rt5676.o > > +# 8173 Machine support > > +obj-$(CONFIG_SND_SOC_MT8173_MAX98090) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5676) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650_RT5514) += mt8173/ > > +obj-$(CONFIG_SND_SOC_MT8173_RT5650) += mt8173/ > > Since all CONFIG_SND_SOC_MT8173_* depends on CONFIG_SND_SOC_MEDIATEK, > you could just do: > > obj-$(CONFIG_SND_SOC_MEDIATEK) += mt8173/ > > > This way we don't need to modify 2 makefiles when adding new ASoC > driver. Yes you're right. I'll modify it. > > > > diff --git a/sound/soc/mediatek/mt8173/Makefile b/sound/soc/mediatek/mt8173/Makefile > > new file mode 100644 > > index 0000000..d486860 > > --- /dev/null > > +++ b/sound/soc/mediatek/mt8173/Makefile > > @@ -0,0 +1,7 @@ > > +# MTK Platform Support > > +obj-$(CONFIG_SND_SOC_MEDIATEK) += mtk-afe-pcm.o > > Maybe we should also rename this to mt8173-afe-pcm.o? Well I agree with you. Maybe I have to check all the files and modify them with prefix "mt8173" and "mt2701". (or "mtk8173" and "mtk2701"? I'm not so sure here) > > Joe.C Thanks for your comments.