All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] qede: rename config option
@ 2016-05-07  4:21 Rasesh Mody
  2016-05-07  4:21 ` [PATCH 2/2] qede: return LAN stats to MFW Rasesh Mody
  2016-05-30 14:38 ` [PATCH 1/2] qede: rename config option Bruce Richardson
  0 siblings, 2 replies; 11+ messages in thread
From: Rasesh Mody @ 2016-05-07  4:21 UTC (permalink / raw)
  To: dev; +Cc: Dept-EngDPDKDev, Rasesh Mody

Rename RTE_LIBRTE_QEDE_DEBUG_DRV to RTE_LIBRTE_QEDE_DEBUG_DRIVER

Fixes: 425cba2a5176 ("qede: enable PMD build")
Fixes: 33e9ff1b72ca ("qede: add core driver")

Signed-off-by: Rasesh Mody <rasesh.mody@qlogic.com>
---
 config/common_base           |    2 +-
 doc/guides/nics/qede.rst     |    2 +-
 drivers/net/qede/qede_logs.h |    2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/config/common_base b/config/common_base
index 3535c6e..a053aa3 100644
--- a/config/common_base
+++ b/config/common_base
@@ -302,7 +302,7 @@ CONFIG_RTE_LIBRTE_BOND_DEBUG_ALB_L1=n
 CONFIG_RTE_LIBRTE_QEDE_PMD=y
 CONFIG_RTE_LIBRTE_QEDE_DEBUG_INIT=n
 CONFIG_RTE_LIBRTE_QEDE_DEBUG_INFO=n
-CONFIG_RTE_LIBRTE_QEDE_DEBUG_DRV=n
+CONFIG_RTE_LIBRTE_QEDE_DEBUG_DRIVER=n
 CONFIG_RTE_LIBRTE_QEDE_DEBUG_TX=n
 CONFIG_RTE_LIBRTE_QEDE_DEBUG_RX=n
 #Provides abs path/name of the firmware file.
diff --git a/doc/guides/nics/qede.rst b/doc/guides/nics/qede.rst
index 6f2d9f2..9ff3d1d 100644
--- a/doc/guides/nics/qede.rst
+++ b/doc/guides/nics/qede.rst
@@ -106,7 +106,7 @@ enabling debugging options may affect system performance.
 
   Toggle display of generic debugging messages.
 
-- ``CONFIG_RTE_LIBRTE_QEDE_DEBUG_DRV`` (default **n**)
+- ``CONFIG_RTE_LIBRTE_QEDE_DEBUG_DRIVER`` (default **n**)
 
   Toggle display of ecore related messages.
 
diff --git a/drivers/net/qede/qede_logs.h b/drivers/net/qede/qede_logs.h
index 9f9bb64..45c4af0 100644
--- a/drivers/net/qede/qede_logs.h
+++ b/drivers/net/qede/qede_logs.h
@@ -36,7 +36,7 @@
 
 #endif
 
-#ifdef RTE_LIBRTE_QEDE_DEBUG_DRV
+#ifdef RTE_LIBRTE_QEDE_DEBUG_DRIVER
 #define DP_VERBOSE(p_dev, module, fmt, ...) \
 do { \
 	if ((p_dev)->dp_module & module) \
-- 
1.7.10.3

^ permalink raw reply related	[flat|nested] 11+ messages in thread

* [PATCH 2/2] qede: return LAN stats to MFW
  2016-05-07  4:21 [PATCH 1/2] qede: rename config option Rasesh Mody
@ 2016-05-07  4:21 ` Rasesh Mody
  2016-05-30 14:34   ` Bruce Richardson
  2016-05-30 14:38 ` [PATCH 1/2] qede: rename config option Bruce Richardson
  1 sibling, 1 reply; 11+ messages in thread
From: Rasesh Mody @ 2016-05-07  4:21 UTC (permalink / raw)
  To: dev; +Cc: Dept-EngDPDKDev, Harish Patil

From: Harish Patil <harish.patil@qlogic.com>

Under certain scenarios, MFW periodically polls the driver
for LAN statistics. This patch implements the osal hook to
fill in the stats.

Fixes: ffa002d318d36 ("qede: add base driver")

Signed-off-by: Harish Patil <harish.patil@qlogic.com>
---
 drivers/net/qede/base/bcm_osal.c |   21 +++++++++++++++++++++
 drivers/net/qede/base/bcm_osal.h |    9 ++++++++-
 2 files changed, 29 insertions(+), 1 deletion(-)

diff --git a/drivers/net/qede/base/bcm_osal.c b/drivers/net/qede/base/bcm_osal.c
index 9540c4b..8a62056 100644
--- a/drivers/net/qede/base/bcm_osal.c
+++ b/drivers/net/qede/base/bcm_osal.c
@@ -15,6 +15,9 @@
 #include "ecore.h"
 #include "ecore_hw.h"
 #include "ecore_iov_api.h"
+#include "ecore_mcp_api.h"
+#include "ecore_l2_api.h"
+
 
 unsigned long qede_log2_align(unsigned long n)
 {
@@ -179,3 +182,21 @@ u32 qede_unzip_data(struct ecore_hwfn *p_hwfn, u32 input_len,
 
 	return p_hwfn->stream->total_out / 4;
 }
+
+void
+qede_get_mcp_proto_stats(struct ecore_dev *edev,
+			 enum ecore_mcp_protocol_type type,
+			 union ecore_mcp_protocol_stats *stats)
+{
+	struct ecore_eth_stats lan_stats;
+
+	if (type == ECORE_MCP_LAN_STATS) {
+		ecore_get_vport_stats(edev, &lan_stats);
+		stats->lan_stats.ucast_rx_pkts = lan_stats.rx_ucast_pkts;
+		stats->lan_stats.ucast_tx_pkts = lan_stats.tx_ucast_pkts;
+		stats->lan_stats.fcs_err = -1;
+	} else {
+		DP_INFO(edev, "Statistics request type %d not supported\n",
+		       type);
+	}
+}
diff --git a/drivers/net/qede/base/bcm_osal.h b/drivers/net/qede/base/bcm_osal.h
index 47d056e..3e2aeb0 100644
--- a/drivers/net/qede/base/bcm_osal.h
+++ b/drivers/net/qede/base/bcm_osal.h
@@ -24,6 +24,9 @@ struct ecore_dev;
 struct ecore_hwfn;
 struct ecore_vf_acquire_sw_info;
 struct vf_pf_resc_request;
+enum ecore_mcp_protocol_type;
+union ecore_mcp_protocol_stats;
+
 void qed_link_update(struct ecore_hwfn *hwfn);
 
 #if RTE_BYTE_ORDER == RTE_LITTLE_ENDIAN
@@ -390,7 +393,11 @@ u32 qede_osal_log2(u32);
 #define OSAL_MAX_T(type, __max1, __max2)	\
 	((type)(__max1) > (type)(__max2) ? (type)(__max1) : (type)(__max2))
 
-#define	OSAL_GET_PROTOCOL_STATS(p_hwfn, type, stats) (0)
+void qede_get_mcp_proto_stats(struct ecore_dev *, enum ecore_mcp_protocol_type,
+			      union ecore_mcp_protocol_stats *);
+#define	OSAL_GET_PROTOCOL_STATS(dev, type, stats) \
+	qede_get_mcp_proto_stats(dev, type, stats)
+
 #define	OSAL_SLOWPATH_IRQ_REQ(p_hwfn) (0)
 
 #endif /* __BCM_OSAL_H */
-- 
1.7.10.3

^ permalink raw reply related	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-05-07  4:21 ` [PATCH 2/2] qede: return LAN stats to MFW Rasesh Mody
@ 2016-05-30 14:34   ` Bruce Richardson
  2016-05-31 19:21     ` Harish Patil
  0 siblings, 1 reply; 11+ messages in thread
From: Bruce Richardson @ 2016-05-30 14:34 UTC (permalink / raw)
  To: Rasesh Mody; +Cc: dev, Dept-EngDPDKDev, Harish Patil

On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
> From: Harish Patil <harish.patil@qlogic.com>
> 
> Under certain scenarios, MFW periodically polls the driver
> for LAN statistics. This patch implements the osal hook to
> fill in the stats.
> 
> Fixes: ffa002d318d36 ("qede: add base driver")
> 
What is MFW?

/Bruce

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 1/2] qede: rename config option
  2016-05-07  4:21 [PATCH 1/2] qede: rename config option Rasesh Mody
  2016-05-07  4:21 ` [PATCH 2/2] qede: return LAN stats to MFW Rasesh Mody
@ 2016-05-30 14:38 ` Bruce Richardson
  2016-06-03 15:01   ` Bruce Richardson
  1 sibling, 1 reply; 11+ messages in thread
From: Bruce Richardson @ 2016-05-30 14:38 UTC (permalink / raw)
  To: Rasesh Mody; +Cc: dev, Dept-EngDPDKDev

On Fri, May 06, 2016 at 09:21:30PM -0700, Rasesh Mody wrote:
> Rename RTE_LIBRTE_QEDE_DEBUG_DRV to RTE_LIBRTE_QEDE_DEBUG_DRIVER
> 
> Fixes: 425cba2a5176 ("qede: enable PMD build")
> Fixes: 33e9ff1b72ca ("qede: add core driver")
> 
These fixes lines don't have the correct commit id's in them. The commit
"qede: enable PMD build" is actually commit 3eae93a9, and "qede: add core
driver" is 2ea6f76a. The commit id of a patch can change from what it is
originally when the patch is applied.

/Bruce

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-05-30 14:34   ` Bruce Richardson
@ 2016-05-31 19:21     ` Harish Patil
  2016-06-01  9:43       ` Thomas Monjalon
  0 siblings, 1 reply; 11+ messages in thread
From: Harish Patil @ 2016-05-31 19:21 UTC (permalink / raw)
  To: Bruce Richardson, Rasesh Mody; +Cc: dev, Dept-Eng DPDK Dev


>On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
>> From: Harish Patil <harish.patil@qlogic.com>
>> 
>> Under certain scenarios, MFW periodically polls the driver
>> for LAN statistics. This patch implements the osal hook to
>> fill in the stats.
>> 
>> Fixes: ffa002d318d36 ("qede: add base driver")
>> 
>What is MFW?
>
>/Bruce
>

MFW - Management FirmWare running on the card.

Thanks
Harish


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-05-31 19:21     ` Harish Patil
@ 2016-06-01  9:43       ` Thomas Monjalon
  2016-06-01 14:16         ` Harish Patil
  0 siblings, 1 reply; 11+ messages in thread
From: Thomas Monjalon @ 2016-06-01  9:43 UTC (permalink / raw)
  To: Harish Patil; +Cc: dev, Bruce Richardson, Rasesh Mody, Dept-Eng DPDK Dev

2016-05-31 19:21, Harish Patil:
> 
> >On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
> >> From: Harish Patil <harish.patil@qlogic.com>
> >> 
> >> Under certain scenarios, MFW periodically polls the driver
> >> for LAN statistics. This patch implements the osal hook to
> >> fill in the stats.
> >> 
> >> Fixes: ffa002d318d36 ("qede: add base driver")
> >> 
> >What is MFW?
> >
> >/Bruce
> >
> 
> MFW - Management FirmWare running on the card.

So MFW can probably be replaced by firmware in the title.

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-06-01  9:43       ` Thomas Monjalon
@ 2016-06-01 14:16         ` Harish Patil
  2016-06-01 14:31           ` Richardson, Bruce
  0 siblings, 1 reply; 11+ messages in thread
From: Harish Patil @ 2016-06-01 14:16 UTC (permalink / raw)
  To: Thomas Monjalon; +Cc: dev, Bruce Richardson, Rasesh Mody, Dept-Eng DPDK Dev

>
>2016-05-31 19:21, Harish Patil:
>> 
>> >On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
>> >> From: Harish Patil <harish.patil@qlogic.com>
>> >> 
>> >> Under certain scenarios, MFW periodically polls the driver
>> >> for LAN statistics. This patch implements the osal hook to
>> >> fill in the stats.
>> >> 
>> >> Fixes: ffa002d318d36 ("qede: add base driver")
>> >> 
>> >What is MFW?
>> >
>> >/Bruce
>> >
>> 
>> MFW - Management FirmWare running on the card.
>
>So MFW can probably be replaced by firmware in the title.
>

Reason I didn’t use “firmware” in the first place is because there are two
different firmware running on the card:
1) MFW (management firmware - which is flashed)
2) Firmware (datapath  firmware - loaded by driver by reading FW file)

So, I can replace it as management firmware explicitly.


Thanks,
Harish
 


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-06-01 14:16         ` Harish Patil
@ 2016-06-01 14:31           ` Richardson, Bruce
  2016-06-01 14:33             ` Harish Patil
  0 siblings, 1 reply; 11+ messages in thread
From: Richardson, Bruce @ 2016-06-01 14:31 UTC (permalink / raw)
  To: Harish Patil, Thomas Monjalon; +Cc: dev, Rasesh Mody, Dept-Eng DPDK Dev



> -----Original Message-----
> From: Harish Patil [mailto:harish.patil@qlogic.com]
> Sent: Wednesday, June 1, 2016 3:16 PM
> To: Thomas Monjalon <thomas.monjalon@6wind.com>
> Cc: dev@dpdk.org; Richardson, Bruce <bruce.richardson@intel.com>; Rasesh
> Mody <rasesh.mody@qlogic.com>; Dept-Eng DPDK Dev <Dept-
> EngDPDKDev@qlogic.com>
> Subject: Re: [dpdk-dev] [PATCH 2/2] qede: return LAN stats to MFW
> 
> >
> >2016-05-31 19:21, Harish Patil:
> >>
> >> >On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
> >> >> From: Harish Patil <harish.patil@qlogic.com>
> >> >>
> >> >> Under certain scenarios, MFW periodically polls the driver for LAN
> >> >> statistics. This patch implements the osal hook to fill in the
> >> >> stats.
> >> >>
> >> >> Fixes: ffa002d318d36 ("qede: add base driver")
> >> >>
> >> >What is MFW?
> >> >
> >> >/Bruce
> >> >
> >>
> >> MFW - Management FirmWare running on the card.
> >
> >So MFW can probably be replaced by firmware in the title.
> >
> 
> Reason I didn’t use “firmware” in the first place is because there are two
> different firmware running on the card:
> 1) MFW (management firmware - which is flashed)
> 2) Firmware (datapath  firmware - loaded by driver by reading FW file)
> 
> So, I can replace it as management firmware explicitly.
> 
> 
> Thanks,
> Harish
> 
How about firmware in the title, and then you can clarify it as management firmware in the message itself?

Regards,
/Bruce

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 2/2] qede: return LAN stats to MFW
  2016-06-01 14:31           ` Richardson, Bruce
@ 2016-06-01 14:33             ` Harish Patil
  0 siblings, 0 replies; 11+ messages in thread
From: Harish Patil @ 2016-06-01 14:33 UTC (permalink / raw)
  To: Richardson, Bruce, Thomas Monjalon; +Cc: dev, Rasesh Mody, Dept-Eng DPDK Dev

>

>
>
>> -----Original Message-----
>> From: Harish Patil [mailto:harish.patil@qlogic.com]
>> Sent: Wednesday, June 1, 2016 3:16 PM
>> To: Thomas Monjalon <thomas.monjalon@6wind.com>
>> Cc: dev@dpdk.org; Richardson, Bruce <bruce.richardson@intel.com>; Rasesh
>> Mody <rasesh.mody@qlogic.com>; Dept-Eng DPDK Dev <Dept-
>> EngDPDKDev@qlogic.com>
>> Subject: Re: [dpdk-dev] [PATCH 2/2] qede: return LAN stats to MFW
>> 
>> >
>> >2016-05-31 19:21, Harish Patil:
>> >>
>> >> >On Fri, May 06, 2016 at 09:21:31PM -0700, Rasesh Mody wrote:
>> >> >> From: Harish Patil <harish.patil@qlogic.com>
>> >> >>
>> >> >> Under certain scenarios, MFW periodically polls the driver for LAN
>> >> >> statistics. This patch implements the osal hook to fill in the
>> >> >> stats.
>> >> >>
>> >> >> Fixes: ffa002d318d36 ("qede: add base driver")
>> >> >>
>> >> >What is MFW?
>> >> >
>> >> >/Bruce
>> >> >
>> >>
>> >> MFW - Management FirmWare running on the card.
>> >
>> >So MFW can probably be replaced by firmware in the title.
>> >
>> 
>> Reason I didn’t use “firmware” in the first place is because there are
>>two
>> different firmware running on the card:
>> 1) MFW (management firmware - which is flashed)
>> 2) Firmware (datapath  firmware - loaded by driver by reading FW file)
>> 
>> So, I can replace it as management firmware explicitly.
>> 
>> 
>> Thanks,
>> Harish
>> 
>How about firmware in the title, and then you can clarify it as
>management firmware in the message itself?
>
>Regards,
>/Bruce
>

Sure, will do.


^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 1/2] qede: rename config option
  2016-05-30 14:38 ` [PATCH 1/2] qede: rename config option Bruce Richardson
@ 2016-06-03 15:01   ` Bruce Richardson
  2016-06-03 15:54     ` Rasesh Mody
  0 siblings, 1 reply; 11+ messages in thread
From: Bruce Richardson @ 2016-06-03 15:01 UTC (permalink / raw)
  To: Rasesh Mody; +Cc: dev, Dept-EngDPDKDev

On Mon, May 30, 2016 at 03:38:41PM +0100, Bruce Richardson wrote:
> On Fri, May 06, 2016 at 09:21:30PM -0700, Rasesh Mody wrote:
> > Rename RTE_LIBRTE_QEDE_DEBUG_DRV to RTE_LIBRTE_QEDE_DEBUG_DRIVER
> > 
> > Fixes: 425cba2a5176 ("qede: enable PMD build")
> > Fixes: 33e9ff1b72ca ("qede: add core driver")
> > 
> These fixes lines don't have the correct commit id's in them. The commit
> "qede: enable PMD build" is actually commit 3eae93a9, and "qede: add core
> driver" is 2ea6f76a. The commit id of a patch can change from what it is
> originally when the patch is applied.
> 
> /Bruce
> 
Patch series applied to dpdk-next-net/rel_16_07 with corrected commit ids in
the fixes line, and some reworking of titles and commit messages as discussed.

Regards,
/Bruce

^ permalink raw reply	[flat|nested] 11+ messages in thread

* Re: [PATCH 1/2] qede: rename config option
  2016-06-03 15:01   ` Bruce Richardson
@ 2016-06-03 15:54     ` Rasesh Mody
  0 siblings, 0 replies; 11+ messages in thread
From: Rasesh Mody @ 2016-06-03 15:54 UTC (permalink / raw)
  To: Bruce Richardson; +Cc: dev, Dept-Eng DPDK Dev

Thanks!

> From: Bruce Richardson [mailto:bruce.richardson@intel.com]
> Sent: Friday, June 03, 2016 8:02 AM
> 
> On Mon, May 30, 2016 at 03:38:41PM +0100, Bruce Richardson wrote:
> > On Fri, May 06, 2016 at 09:21:30PM -0700, Rasesh Mody wrote:
> > > Rename RTE_LIBRTE_QEDE_DEBUG_DRV to
> RTE_LIBRTE_QEDE_DEBUG_DRIVER
> > >
> > > Fixes: 425cba2a5176 ("qede: enable PMD build")
> > > Fixes: 33e9ff1b72ca ("qede: add core driver")
> > >
> > These fixes lines don't have the correct commit id's in them. The
> > commit
> > "qede: enable PMD build" is actually commit 3eae93a9, and "qede: add
> > core driver" is 2ea6f76a. The commit id of a patch can change from
> > what it is originally when the patch is applied.
> >
> > /Bruce
> >
> Patch series applied to dpdk-next-net/rel_16_07 with corrected commit ids
> in the fixes line, and some reworking of titles and commit messages as
> discussed.
> 
> Regards,
> /Bruce

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2016-06-03 15:54 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-07  4:21 [PATCH 1/2] qede: rename config option Rasesh Mody
2016-05-07  4:21 ` [PATCH 2/2] qede: return LAN stats to MFW Rasesh Mody
2016-05-30 14:34   ` Bruce Richardson
2016-05-31 19:21     ` Harish Patil
2016-06-01  9:43       ` Thomas Monjalon
2016-06-01 14:16         ` Harish Patil
2016-06-01 14:31           ` Richardson, Bruce
2016-06-01 14:33             ` Harish Patil
2016-05-30 14:38 ` [PATCH 1/2] qede: rename config option Bruce Richardson
2016-06-03 15:01   ` Bruce Richardson
2016-06-03 15:54     ` Rasesh Mody

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.