All of lore.kernel.org
 help / color / mirror / Atom feed
From: frowand.list@gmail.com
To: Rob Herring <robh+dt@kernel.org>,
	pantelis.antoniou@konsulko.com,
	Pantelis Antoniou <panto@antoniou-consulting.com>
Cc: devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH 12/12] of: Remove unused variable overlay_symbols
Date: Fri, 28 Oct 2016 23:26:32 -0700	[thread overview]
Message-ID: <1477722392-32172-13-git-send-email-frowand.list@gmail.com> (raw)
In-Reply-To: <1477722392-32172-1-git-send-email-frowand.list@gmail.com>

From: Frank Rowand <frank.rowand@am.sony.com>

Remove unused pointer to node "__symbols__".

Signed-off-by: Frank Rowand <frank.rowand@am.sony.com>
---
 drivers/of/resolver.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/of/resolver.c b/drivers/of/resolver.c
index 53353cc8f2bb..783bd09463b5 100644
--- a/drivers/of/resolver.c
+++ b/drivers/of/resolver.c
@@ -287,7 +287,7 @@ static int adjust_local_phandle_references(struct device_node *local_fixups,
 int of_resolve_phandles(struct device_node *overlay)
 {
 	struct device_node *child, *local_fixups, *refnode;
-	struct device_node *tree_symbols, *overlay_symbols, *overlay_fixups;
+	struct device_node *tree_symbols, *overlay_fixups;
 	struct property *prop;
 	const char *refpath;
 	phandle phandle, phandle_delta;
@@ -317,12 +317,9 @@ int of_resolve_phandles(struct device_node *overlay)
 	if (err)
 		goto err_out;
 
-	overlay_symbols = NULL;
 	overlay_fixups = NULL;
 
 	for_each_child_of_node(overlay, child) {
-		if (!of_node_cmp(child->name, "__symbols__"))
-			overlay_symbols = child;
 		if (!of_node_cmp(child->name, "__fixups__"))
 			overlay_fixups = child;
 	}
-- 
1.9.1

  parent reply	other threads:[~2016-10-29  6:28 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-29  6:26 [PATCH 00/12] of: Make drivers/of/resolver.c more readable frowand.list
2016-10-29  6:26 ` frowand.list-Re5JQEeQqe8AvxtiuMwx3w
2016-10-29  6:26 ` [PATCH 01/12] of: Remove comments that state the obvious, to reduce clutter frowand.list
2016-10-29  6:26 ` [PATCH 02/12] of: Remove excessive printks " frowand.list
2016-10-29  6:26 ` [PATCH 03/12] of: Convert comparisons to zero or NULL to logical expressions frowand.list
2016-10-29  6:26 ` [PATCH 04/12] of: Rename functions to more accurately reflect what they do frowand.list
2016-10-29  6:26 ` [PATCH 05/12] of: Remove prefix "__of_" from local function names frowand.list
2016-10-29  6:26 ` [PATCH 06/12] of: Rename variables to better reflect purpose or follow convention frowand.list
2016-10-29  6:26 ` [PATCH 07/12] of: Update structure of code to be clearer, also remove BUG_ON() frowand.list
2016-10-29  6:26 ` [PATCH 08/12] of: Remove redundant size check frowand.list
2016-10-29  6:26 ` [PATCH 09/12] of: Update comments to reflect changes and increase clarity frowand.list
2016-10-29  6:26 ` [PATCH 10/12] of: Add back an error message, restructured frowand.list
2016-10-29  6:26 ` [PATCH 11/12] of: Move setting of pointer to beside test for non-null frowand.list
2016-10-29  6:26 ` frowand.list [this message]
2016-11-10 20:56 ` [PATCH 00/12] of: Make drivers/of/resolver.c more readable Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1477722392-32172-13-git-send-email-frowand.list@gmail.com \
    --to=frowand.list@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pantelis.antoniou@konsulko.com \
    --cc=panto@antoniou-consulting.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.