From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ulf Hansson Subject: [PATCH 3/9] mmc: core: Rename ignore_crc to retry_crc_err to reflect its purpose Date: Wed, 16 Nov 2016 11:51:15 +0100 Message-ID: <1479293481-20186-4-git-send-email-ulf.hansson@linaro.org> References: <1479293481-20186-1-git-send-email-ulf.hansson@linaro.org> Return-path: Received: from mail-qt0-f169.google.com ([209.85.216.169]:35718 "EHLO mail-qt0-f169.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754986AbcKPKvi (ORCPT ); Wed, 16 Nov 2016 05:51:38 -0500 Received: by mail-qt0-f169.google.com with SMTP id c47so95937409qtc.2 for ; Wed, 16 Nov 2016 02:51:37 -0800 (PST) In-Reply-To: <1479293481-20186-1-git-send-email-ulf.hansson@linaro.org> Sender: linux-mmc-owner@vger.kernel.org List-Id: linux-mmc@vger.kernel.org To: linux-mmc@vger.kernel.org, Ulf Hansson Cc: Jaehoon Chung , Adrian Hunter , Linus Walleij , Chaotian Jing , Stephen Boyd , Michael Walle , Yong Mao , Shawn Lin The ignore_crc parameter/variable name is used at a couple of places in the mmc core. Let's rename it to retry_crc_err to reflect its new purpose. Signed-off-by: Ulf Hansson --- drivers/mmc/core/mmc_ops.c | 10 +++++----- drivers/mmc/core/mmc_ops.h | 2 +- 2 files changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/mmc/core/mmc_ops.c b/drivers/mmc/core/mmc_ops.c index 0515748..214e734 100644 --- a/drivers/mmc/core/mmc_ops.c +++ b/drivers/mmc/core/mmc_ops.c @@ -461,7 +461,7 @@ int mmc_switch_status(struct mmc_card *card) } static int mmc_poll_for_busy(struct mmc_card *card, unsigned int timeout_ms, - bool send_status, bool ignore_crc) + bool send_status, bool retry_crc_err) { struct mmc_host *host = card->host; int err; @@ -496,7 +496,7 @@ static int mmc_poll_for_busy(struct mmc_card *card, unsigned int timeout_ms, busy = host->ops->card_busy(host); } else { err = mmc_send_status(card, &status); - if (ignore_crc && err == -EILSEQ) + if (retry_crc_err && err == -EILSEQ) busy = true; else if (err) return err; @@ -528,13 +528,13 @@ static int mmc_poll_for_busy(struct mmc_card *card, unsigned int timeout_ms, * timeout of zero implies maximum possible timeout * @use_busy_signal: use the busy signal as response type * @send_status: send status cmd to poll for busy - * @ignore_crc: ignore CRC errors when sending status cmd to poll for busy + * @retry_crc_err: retry when CRC errors when polling with CMD13 for busy * * Modifies the EXT_CSD register for selected card. */ int __mmc_switch(struct mmc_card *card, u8 set, u8 index, u8 value, unsigned int timeout_ms, bool use_busy_signal, bool send_status, - bool ignore_crc) + bool retry_crc_err) { struct mmc_host *host = card->host; int err; @@ -590,7 +590,7 @@ int __mmc_switch(struct mmc_card *card, u8 set, u8 index, u8 value, } /* Let's try to poll to find out when the command is completed. */ - err = mmc_poll_for_busy(card, timeout_ms, send_status, ignore_crc); + err = mmc_poll_for_busy(card, timeout_ms, send_status, retry_crc_err); out: mmc_retune_release(host); diff --git a/drivers/mmc/core/mmc_ops.h b/drivers/mmc/core/mmc_ops.h index 7f6c0e9..9fccddb 100644 --- a/drivers/mmc/core/mmc_ops.h +++ b/drivers/mmc/core/mmc_ops.h @@ -30,7 +30,7 @@ int mmc_switch_status(struct mmc_card *card); int __mmc_switch(struct mmc_card *card, u8 set, u8 index, u8 value, unsigned int timeout_ms, bool use_busy_signal, bool send_status, - bool ignore_crc); + bool retry_crc_err); #endif -- 1.9.1