All of lore.kernel.org
 help / color / mirror / Atom feed
From: Radu Rendec <rrendec@arista.com>
To: Guenter Roeck <linux@roeck-us.net>
Cc: Wim Van Sebroeck <wim@iguana.be>, linux-watchdog@vger.kernel.org
Subject: Re: [PATCH v3 1/2] watchdog: xen_wdt: use the watchdog subsystem
Date: Wed, 15 Nov 2017 16:46:28 +0000	[thread overview]
Message-ID: <1510764388.27053.22.camel@arista.com> (raw)
In-Reply-To: <20171115162612.GB29282@roeck-us.net>

On Wed, 2017-11-15 at 08:26 -0800, Guenter Roeck wrote:
> On Wed, Nov 15, 2017 at 03:34:40PM +0000, Radu Rendec wrote:
> > On Wed, 2017-11-15 at 06:58 -0800, Guenter Roeck wrote:
> > > On Tue, Nov 14, 2017 at 04:23:49PM +0000, Radu Rendec wrote:
> > > > diff --git a/drivers/watchdog/xen_wdt.c b/drivers/watchdog/xen_wdt.c
> > > > index 5dd5c3494d55..4e00419bd47d 100644
> > > > --- a/drivers/watchdog/xen_wdt.c
> > > > +++ b/drivers/watchdog/xen_wdt.c
> > > > @@ -9,9 +9,8 @@
> > > >   *	2 of the License, or (at your option) any later version.
> > > >   */
> > > >  
> > > > -#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
> > > > -
> > > > -#define DRV_NAME	"wdt"
> > > > +#define DRV_NAME	"xen_wdt"
> > > > +#define DEV_NAME	"watchdog"
> > > 
> > > [ ... ]
> > > 
> > > >  
> > > > +static const struct platform_device_id xen_wdt_id_table[] = {
> > > > +	{ .name	= DEV_NAME },
> > > 
> > > I understand we are way into bikeshedding territory, and I was inclined
> > > to let this just go, but this is way too generic for a platform device
> > > ID, sorry.
> > 
> > Yes, that's the part I don't like about it either. So I think we're on
> > the same page here :)
> > 
> > FWIW, the old (current) version has the same problem, because in the
> > absence of an id_table (or a matching entry), platform_match() matches
> > against the driver name, which is just "wdt".
> > 
> > Anyway, how about using "xwdt0" for DEV_NAME? The driver supports only
> > one device by design, so adding "0" should be fine.
> > 
> 
> A numeric suffix to the device name suggests that there can be more than one,
> which would be misleading.
> 
> And all that because you don't like the output of dev_info(). Hope you don't
> start to mess with all the other drivers having the same "problem" of a less
> than perfect output from dev_ functions.

I was merely trying to make the output look better than just a repeated
string (which doesn't make much sense, IMHO).

At this point I see the following options:

   1. Revert to the previous patch version, but use dev_ instead of pr_ as
      you suggested. Messages would look like "wdt wdt: ...". Note that
      this still has the problem of registering a platform "id" of "wdt"
      which *is* quite generic and may collide with other drivers.
   2. Same as above, but change DRV_NAME to "xen_wdt", which is less
      generic. Messages would look like "xen_wdt xen_wdt: ...".
   3. Keep the id_table and change DEV_NAME to something without a numeric
      suffix, e.g. "xwdt".

At the end of the day, what I really want is to port the xen_wdt driver
to use the watchdog subsystem.

Please let me know which of the above options you prefer and I will
send an updated v4.

Thanks,
Radu


  reply	other threads:[~2017-11-15 16:46 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-14 16:23 [PATCH v3 0/2] xen_wdt: use the watchdog subsystem Radu Rendec
2017-11-14 16:23 ` [PATCH v3 1/2] watchdog: " Radu Rendec
2017-11-15 14:58   ` Guenter Roeck
2017-11-15 15:34     ` Radu Rendec
2017-11-15 16:26       ` Guenter Roeck
2017-11-15 16:46         ` Radu Rendec [this message]
2017-11-15 18:21           ` Guenter Roeck
2017-11-14 16:23 ` [PATCH v3 2/2] watchdog: xen_wdt: remove info message and version number Radu Rendec
2017-11-14 17:31 ` [PATCH v3 0/2] xen_wdt: use the watchdog subsystem Guenter Roeck
2017-11-14 18:08   ` Radu Rendec

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1510764388.27053.22.camel@arista.com \
    --to=rrendec@arista.com \
    --cc=linux-watchdog@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=wim@iguana.be \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.