All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ajay Singh <ajay.kathat@microchip.com>
To: <linux-wireless@vger.kernel.org>
Cc: <devel@driverdev.osuosl.org>, <gregkh@linuxfoundation.org>,
	<ganesh.krishna@microchip.com>, <venkateswara.kaja@microchip.com>,
	<aditya.shankar@microchip.com>, <claudiu.beznea@microchip.com>,
	<adham.abozaeid@Microchip.com>,
	Ajay Singh <ajay.kathat@microchip.com>
Subject: [PATCH 16/22] staging: wilc1000: remove the use of goto label in wilc_spi_read_int()
Date: Wed, 18 Apr 2018 17:09:18 +0530	[thread overview]
Message-ID: <1524051564-15497-17-git-send-email-ajay.kathat@microchip.com> (raw)
In-Reply-To: <1524051564-15497-1-git-send-email-ajay.kathat@microchip.com>

In wilc_spi_read_int() remove the use of goto label '_fail_'. Changes
are done to avoid the use of '_' in label name.

Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
---
 drivers/staging/wilc1000/wilc_spi.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/staging/wilc1000/wilc_spi.c b/drivers/staging/wilc1000/wilc_spi.c
index 57e4f11..1db2814 100644
--- a/drivers/staging/wilc1000/wilc_spi.c
+++ b/drivers/staging/wilc1000/wilc_spi.c
@@ -946,7 +946,7 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
 	if (!ret) {
 		dev_err(&spi->dev,
 			"Failed read WILC_VMM_TO_HOST_SIZE ...\n");
-		goto _fail_;
+		return ret;
 	}
 	tmp = (byte_cnt >> 2) & IRQ_DMA_WD_CNT_MASK;
 
@@ -976,7 +976,6 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
 
 	*int_status = tmp;
 
-_fail_:
 	return ret;
 }
 
-- 
2.7.4

  parent reply	other threads:[~2018-04-18 11:40 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-18 11:39 [PATCH 00/22] staging: wilc1000: cleanup patches to follow linux coding style Ajay Singh
2018-04-18 11:39 ` [PATCH 01/22] staging: wilc1000: rename WILC_WFI_wep_key & WILC_WFI_wep_key_len Ajay Singh
2018-04-18 11:39 ` [PATCH 02/22] staging: wilc1000: rename variable using datatype in their name in add_key() Ajay Singh
2018-04-18 11:39 ` [PATCH 03/22] staging: wilc1000: split add_key() to avoid line over 80 chars Ajay Singh
2018-04-18 11:39 ` [PATCH 04/22] staging: wilc1000: remove inner block {} and resetting of mode variable Ajay Singh
2018-04-18 11:39 ` [PATCH 05/22] staging: wilc1000: refactor add_key() to avoid duplicated code Ajay Singh
2018-04-18 11:39 ` [PATCH 06/22] staging: wilc1000: handle error condition in add_key() and remove auth_type variable Ajay Singh
2018-04-18 11:39 ` [PATCH 07/22] staging: wilc1000: use sizeof(variable) for memory allocated to store key info Ajay Singh
2018-04-18 11:39 ` [PATCH 08/22] staging: wilc1000: fix line over 80 chars in change_station() Ajay Singh
2018-04-18 11:39 ` [PATCH 09/22] staging: wilc1000: rename WID_LOGTerminal_Switch to avoid camelCase Ajay Singh
2018-04-18 11:39 ` [PATCH 10/22] staging: wilc1000: added identifiers name in function definations Ajay Singh
2018-04-18 11:39 ` [PATCH 11/22] staging: wilc1000: remove unused macros in wilc module Ajay Singh
2018-04-18 11:39 ` [PATCH 12/22] staging: wilc1000: remove multiple define used for MAX_SSID_LEN Ajay Singh
2018-04-18 11:39 ` [PATCH 13/22] staging: wilc1000: remove multiple define for mac connect and disconnect Ajay Singh
2018-04-18 11:39 ` [PATCH 14/22] staging: wilc1000: remove the use of goto label in spi_cmd_complete() Ajay Singh
2018-04-18 11:39 ` [PATCH 15/22] staging: wilc1000: remove the use of goto label in wilc_spi_read_size() Ajay Singh
2018-04-18 11:39 ` Ajay Singh [this message]
2018-04-18 11:39 ` [PATCH 17/22] staging: wilc1000: remove goto label '_done_' in handle_listen_state_expired() Ajay Singh
2018-04-18 11:39 ` [PATCH 18/22] staging: wilc1000: remove the use of goto label in wilc_init() Ajay Singh
2018-04-18 11:39 ` [PATCH 19/22] staging: wilc1000: rename goto label '_fail_' linux naming convension Ajay Singh
2018-04-18 11:39 ` [PATCH 20/22] staging: wilc1000: rename goto labels starting with '_' in wilc1000_wlan_init() Ajay Singh
2018-04-18 11:39 ` [PATCH 21/22] staging: wilc1000: remove the use of goto label in wilc_spi_clear_int_ext() Ajay Singh
2018-04-18 11:39 ` [PATCH 22/22] staging: wilc1000: rename pu32InactiveTime to avoid camelCase issue Ajay Singh
2018-04-23 13:45 ` [PATCH 00/22] staging: wilc1000: cleanup patches to follow linux coding style Greg KH
2018-04-23 14:01   ` Ajay Singh
2018-04-23 14:11     ` Greg KH
2018-04-23 14:44     ` Claudiu Beznea

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1524051564-15497-17-git-send-email-ajay.kathat@microchip.com \
    --to=ajay.kathat@microchip.com \
    --cc=adham.abozaeid@Microchip.com \
    --cc=aditya.shankar@microchip.com \
    --cc=claudiu.beznea@microchip.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=ganesh.krishna@microchip.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=venkateswara.kaja@microchip.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.