From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from whitealder.osuosl.org (smtp1.osuosl.org [140.211.166.138]) by ash.osuosl.org (Postfix) with ESMTP id 56BB21C0749 for ; Sun, 20 May 2018 11:03:09 +0000 (UTC) Received: from localhost (localhost [127.0.0.1]) by whitealder.osuosl.org (Postfix) with ESMTP id 540E788CB0 for ; Sun, 20 May 2018 11:03:09 +0000 (UTC) Received: from whitealder.osuosl.org ([127.0.0.1]) by localhost (.osuosl.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id KChKWHvSFUd1 for ; Sun, 20 May 2018 11:03:08 +0000 (UTC) Received: from mail-wr0-f194.google.com (mail-wr0-f194.google.com [209.85.128.194]) by whitealder.osuosl.org (Postfix) with ESMTPS id 6F7C788CA2 for ; Sun, 20 May 2018 11:03:08 +0000 (UTC) Received: by mail-wr0-f194.google.com with SMTP id i14-v6so13245080wre.2 for ; Sun, 20 May 2018 04:03:08 -0700 (PDT) From: Sergio Paracuellos Subject: [PATCH v5 00/10] staging: mt7621-gpio: use mediatek as binding instead of custom mtk Date: Sun, 20 May 2018 13:02:50 +0200 Message-Id: <1526814180-19486-1-git-send-email-sergio.paracuellos@gmail.com> In-Reply-To: <87d0xq1wmz.fsf@notabene.neil.brown.name> References: <87d0xq1wmz.fsf@notabene.neil.brown.name> List-Id: Linux Driver Project Developer List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Errors-To: driverdev-devel-bounces@linuxdriverproject.org Sender: "devel" To: gregkh@linuxfoundation.org Cc: neil@brown.name, driverdev-devel@linuxdriverproject.org The following series updated mt7621-gpio driver to use 'mediatek' which is already defined in kernel bindings documentation instead of add a new custom one 'mtk' for this company. mt7621-gpio device-tree documentation has been added also to the staging driver directory. v5: - PATCH 5 ("staging: mt7621-gpio: avoid use of globals and use platform_data instead") was still missing folowings to be properly working: + The data passed between irq related functions and the ones which have been retrieved were different. Also first data haven't properly set on irq_domain_add_linear call where it was passing NULL instead. Fix those. - Join TODO's modifications patches (PATCH 1 and 11) in one which just makes empty the file. v4: - Only PATCH 5 ("staging: mt7621-gpio: avoid use of globals and use platform_data instead") has changes: + avoid call to gpiochip_add in probe function because function devm_gpiochip_add_data is being used instead. + Call irq_set_chip_data in mediatek_gpio_gpio_map to make data properly passed to interrupts related functions. v3: - Fix condition for check for a valid gpio id in driver probe function included in the PATCH 8 ("staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations and refactor function a bit") of the series. - Rest of patches are not modified at all. v2: - Join some patch ("staging: mt7621-gpio: avoid use of globals and use platform_data instead") with the needed fixes to make it work pointed out by NeilBrown - Add gpio interrupts to documentation and device tree in order to can try them - Other minor code cleanups have been added also. This changes have been reviewed and tested by NeilBrown but I don't know if I have to add those information to the patches by myself if I resend the series or should be added by you Greg when the patches are added to the kernel tree. Hope this helps. Best regards, Sergio Paracuellos Sergio Paracuellos (10): staging: mt7621-gpio: dt-bindings: add documentation for mt7621-gpio staging: mt7621-dts: update gpios related entries to use 'mediatek' staging: mt7621-gpio: replace 'mtk' to use correct one 'mediatek' staging: mt7621-gpio: avoid use of globals and use platform_data instead staging: mt7621-dts: add interrupt device tree nodes for the gpio controller staging: mt7621-gpio: dt-bindings: add interrupt nodes to bindings doc staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations and refactor function a bit staging: mt7621-gpio: use ternary operator in return in mediatek_gpio_get_direction staging: mt7621-gpio: use MTK_BANK_WIDTH instead of magic number staging: mt7621-gpio: update TODO file drivers/staging/mt7621-dts/mt7621.dtsi | 11 +- drivers/staging/mt7621-gpio/TODO | 3 - drivers/staging/mt7621-gpio/gpio-mt7621.c | 116 +++++++++++++-------- .../staging/mt7621-gpio/mediatek,mt7621-gpio.txt | 58 +++++++++++ 4 files changed, 139 insertions(+), 49 deletions(-) create mode 100644 drivers/staging/mt7621-gpio/mediatek,mt7621-gpio.txt -- 2.7.4 _______________________________________________ devel mailing list devel@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel