All of lore.kernel.org
 help / color / mirror / Atom feed
From: Cao Van Dong <cv-dong@jinso.co.jp>
To: broonie@kernel.org, geert+renesas@glider.be, linux-pm@vger.kernel.org
Cc: marc.zyngier@arm.com, kuninori.morimoto.gx@renesas.com,
	yoshihiro.shimoda.uh@renesas.com,
	linux-renesas-soc@vger.kernel.org, h-inayoshi@jinso.co.jp,
	nv-dung@jinso.co.jp, na-hoan@jinso.co.jp, cv-dong@jinso.co.jp
Subject: [PATCH v2] thermal_hwmon: Fix the 'No sensors found' error after replacing the parameter NULL by the actual device
Date: Wed,  3 Oct 2018 16:25:51 +0900	[thread overview]
Message-ID: <1538551551-3431-1-git-send-email-cv-dong@jinso.co.jp> (raw)

Formerly, when registering the hwmon device, we pass NULL as the device. It's not a problem.
Recently, the developer has replaced the parameter NULL as the device by the actual device.
This causes the "No sensors found" error. Therefore, instead of using the device we will use pass
the parent of that device as parameter. This will sync with the processor on the hwmon core.
This patch is to fix this error.

This patch is based on the v4.19-rc3 tag.

---
 drivers/thermal/thermal_hwmon.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/thermal/thermal_hwmon.c b/drivers/thermal/thermal_hwmon.c
index 40c69a5..a918ba9 100644
--- a/drivers/thermal/thermal_hwmon.c
+++ b/drivers/thermal/thermal_hwmon.c
@@ -143,7 +143,7 @@ int thermal_add_hwmon_sysfs(struct thermal_zone_device *tz)
 	INIT_LIST_HEAD(&hwmon->tz_list);
 	strlcpy(hwmon->type, tz->type, THERMAL_NAME_LENGTH);
 	strreplace(hwmon->type, '-', '_');
-	hwmon->device = hwmon_device_register_with_info(&tz->device, hwmon->type,
+	hwmon->device = hwmon_device_register_with_info(tz->device.parent, hwmon->type,
 							hwmon, NULL, NULL);
 	if (IS_ERR(hwmon->device)) {
 		result = PTR_ERR(hwmon->device);
-- 
2.7.4

             reply	other threads:[~2018-10-03 14:14 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-03  7:25 Cao Van Dong [this message]
2018-10-03  7:35 ` Geert Uytterhoeven
2018-10-03  8:07 ` Marc Zyngier
2018-10-04  1:29   ` Cao Van Dong
2018-10-04 16:56     ` Guenter Roeck

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1538551551-3431-1-git-send-email-cv-dong@jinso.co.jp \
    --to=cv-dong@jinso.co.jp \
    --cc=broonie@kernel.org \
    --cc=geert+renesas@glider.be \
    --cc=h-inayoshi@jinso.co.jp \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=na-hoan@jinso.co.jp \
    --cc=nv-dung@jinso.co.jp \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    --subject='Re: [PATCH v2] thermal_hwmon: Fix the '\''No sensors found'\'' error after replacing the parameter NULL by the actual device' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.