All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] drivers/virtio: fix duplicate naming of include guard
@ 2019-03-20 13:57 Andrius Sirvys
  2019-03-21  6:19 ` Rami Rosen
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Andrius Sirvys @ 2019-03-20 13:57 UTC (permalink / raw)
  To: dev, Maxime Coquelin, Tiwei Bie, Zhihong Wang
  Cc: stable, Andrius Sirvys, jianfeng.tan

The LGTM static code analysis tool is reporting

"The macro name '_VHOST_NET_USER_H' of this include guard is used
in 2 different header files."

lib/librte_vhost/vhost_user.h has the same include guard.
Renamed the include guard in vhost.h to differentiate.

Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
Cc: jianfeng.tan@intel.com
Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
---
 drivers/net/virtio/virtio_user/vhost.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
index 83a85cc..f8d26b6 100644
--- a/drivers/net/virtio/virtio_user/vhost.h
+++ b/drivers/net/virtio/virtio_user/vhost.h
@@ -2,8 +2,8 @@
  * Copyright(c) 2010-2016 Intel Corporation
  */
 
-#ifndef _VHOST_NET_USER_H
-#define _VHOST_NET_USER_H
+#ifndef ANOTHER_VHOST_NET_USER_H
+#define ANOTHER_VHOST_NET_USER_H
 
 #include <stdint.h>
 #include <linux/types.h>
-- 
2.7.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] drivers/virtio: fix duplicate naming of include guard
  2019-03-20 13:57 [PATCH] drivers/virtio: fix duplicate naming of include guard Andrius Sirvys
@ 2019-03-21  6:19 ` Rami Rosen
  2019-03-21  7:59 ` Tiwei Bie
  2019-03-21 10:09 ` [PATCH v2] " Andrius Sirvys
  2 siblings, 0 replies; 7+ messages in thread
From: Rami Rosen @ 2019-03-21  6:19 UTC (permalink / raw)
  To: Andrius Sirvys
  Cc: dev, Maxime Coquelin, Tiwei Bie, Zhihong Wang, stable, jianfeng.tan

On Wed, Mar 20, 2019 at 3:58 PM Andrius Sirvys <andrius.sirvys@intel.com>
wrote:

> The LGTM static code analysis tool is reporting
>
> "The macro name '_VHOST_NET_USER_H' of this include guard is used
> in 2 different header files."
>
> lib/librte_vhost/vhost_user.h has the same include guard.
> Renamed the include guard in vhost.h to differentiate.
>
> Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
> Cc: jianfeng.tan@intel.com
> Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
> ---
>
>
Acked-by: Rami Rosen <ramirose@gmail.com>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] drivers/virtio: fix duplicate naming of include guard
  2019-03-20 13:57 [PATCH] drivers/virtio: fix duplicate naming of include guard Andrius Sirvys
  2019-03-21  6:19 ` Rami Rosen
@ 2019-03-21  7:59 ` Tiwei Bie
  2019-03-21  9:26   ` Maxime Coquelin
  2019-03-21 10:09 ` [PATCH v2] " Andrius Sirvys
  2 siblings, 1 reply; 7+ messages in thread
From: Tiwei Bie @ 2019-03-21  7:59 UTC (permalink / raw)
  To: Andrius Sirvys; +Cc: dev, Maxime Coquelin, Zhihong Wang, stable, jianfeng.tan

On Wed, Mar 20, 2019 at 01:57:39PM +0000, Andrius Sirvys wrote:
> The LGTM static code analysis tool is reporting
> 
> "The macro name '_VHOST_NET_USER_H' of this include guard is used
> in 2 different header files."
> 
> lib/librte_vhost/vhost_user.h has the same include guard.
> Renamed the include guard in vhost.h to differentiate.

Above two files are private headers in two individual modules,
there is no chance that they will be included by the same file.
But I agree it's not a good name for any of them.

> 
> Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
> Cc: jianfeng.tan@intel.com
> Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
> ---
>  drivers/net/virtio/virtio_user/vhost.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
> index 83a85cc..f8d26b6 100644
> --- a/drivers/net/virtio/virtio_user/vhost.h
> +++ b/drivers/net/virtio/virtio_user/vhost.h
> @@ -2,8 +2,8 @@
>   * Copyright(c) 2010-2016 Intel Corporation
>   */
>  
> -#ifndef _VHOST_NET_USER_H
> -#define _VHOST_NET_USER_H
> +#ifndef ANOTHER_VHOST_NET_USER_H
> +#define ANOTHER_VHOST_NET_USER_H

If we want to change it, I prefer to change it to _PATH_NAME_,
e.g. _VIRTIO_USER_VHOST_H_ or similar.

Thanks,
Tiwei

>  
>  #include <stdint.h>
>  #include <linux/types.h>
> -- 
> 2.7.4
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] drivers/virtio: fix duplicate naming of include guard
  2019-03-21  7:59 ` Tiwei Bie
@ 2019-03-21  9:26   ` Maxime Coquelin
  0 siblings, 0 replies; 7+ messages in thread
From: Maxime Coquelin @ 2019-03-21  9:26 UTC (permalink / raw)
  To: Tiwei Bie, Andrius Sirvys; +Cc: dev, Zhihong Wang, stable, jianfeng.tan



On 3/21/19 8:59 AM, Tiwei Bie wrote:
> On Wed, Mar 20, 2019 at 01:57:39PM +0000, Andrius Sirvys wrote:
>> The LGTM static code analysis tool is reporting
>>
>> "The macro name '_VHOST_NET_USER_H' of this include guard is used
>> in 2 different header files."
>>
>> lib/librte_vhost/vhost_user.h has the same include guard.
>> Renamed the include guard in vhost.h to differentiate.
> 
> Above two files are private headers in two individual modules,
> there is no chance that they will be included by the same file.
> But I agree it's not a good name for any of them.
> 
>>
>> Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
>> Cc: jianfeng.tan@intel.com
>> Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
>> ---
>>   drivers/net/virtio/virtio_user/vhost.h | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
>> index 83a85cc..f8d26b6 100644
>> --- a/drivers/net/virtio/virtio_user/vhost.h
>> +++ b/drivers/net/virtio/virtio_user/vhost.h
>> @@ -2,8 +2,8 @@
>>    * Copyright(c) 2010-2016 Intel Corporation
>>    */
>>   
>> -#ifndef _VHOST_NET_USER_H
>> -#define _VHOST_NET_USER_H
>> +#ifndef ANOTHER_VHOST_NET_USER_H
>> +#define ANOTHER_VHOST_NET_USER_H
> 
> If we want to change it, I prefer to change it to _PATH_NAME_,
> e.g. _VIRTIO_USER_VHOST_H_ or similar.

+1 for _VIRTIO_USER_VHOST_H_

> 
> Thanks,
> Tiwei
> 
>>   
>>   #include <stdint.h>
>>   #include <linux/types.h>
>> -- 
>> 2.7.4
>>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* [PATCH v2] drivers/virtio: fix duplicate naming of include guard
  2019-03-20 13:57 [PATCH] drivers/virtio: fix duplicate naming of include guard Andrius Sirvys
  2019-03-21  6:19 ` Rami Rosen
  2019-03-21  7:59 ` Tiwei Bie
@ 2019-03-21 10:09 ` Andrius Sirvys
  2019-03-22  6:06   ` Tiwei Bie
  2019-03-27 11:13   ` Maxime Coquelin
  2 siblings, 2 replies; 7+ messages in thread
From: Andrius Sirvys @ 2019-03-21 10:09 UTC (permalink / raw)
  To: dev, Maxime Coquelin, Tiwei Bie, Zhihong Wang
  Cc: stable, Andrius Sirvys, jianfeng.tan

"The macro name '_VHOST_NET_USER_H' of this include guard is used
in 2 different header files."

lib/librte_vhost/vhost_user.h has the same include guard.
Renamed the include guard in vhost.h to differentiate.

Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
Cc: jianfeng.tan@intel.com
Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
Acked-by: Rami Rosen <ramirose@gmail.com>
---
v2: changed the name of the variable
---
 drivers/net/virtio/virtio_user/vhost.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
index 83a85cc..55f4703 100644
--- a/drivers/net/virtio/virtio_user/vhost.h
+++ b/drivers/net/virtio/virtio_user/vhost.h
@@ -2,8 +2,8 @@
  * Copyright(c) 2010-2016 Intel Corporation
  */
 
-#ifndef _VHOST_NET_USER_H
-#define _VHOST_NET_USER_H
+#ifndef _VIRTIO_USER_VHOST_H
+#define _VIRTIO_USER_VHOST_H
 
 #include <stdint.h>
 #include <linux/types.h>
-- 
2.7.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] drivers/virtio: fix duplicate naming of include guard
  2019-03-21 10:09 ` [PATCH v2] " Andrius Sirvys
@ 2019-03-22  6:06   ` Tiwei Bie
  2019-03-27 11:13   ` Maxime Coquelin
  1 sibling, 0 replies; 7+ messages in thread
From: Tiwei Bie @ 2019-03-22  6:06 UTC (permalink / raw)
  To: Andrius Sirvys; +Cc: dev, Maxime Coquelin, Zhihong Wang, stable, jianfeng.tan

On Thu, Mar 21, 2019 at 10:09:53AM +0000, Andrius Sirvys wrote:
> "The macro name '_VHOST_NET_USER_H' of this include guard is used
> in 2 different header files."
> 
> lib/librte_vhost/vhost_user.h has the same include guard.
> Renamed the include guard in vhost.h to differentiate.
> 
> Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
> Cc: jianfeng.tan@intel.com
> Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
> Acked-by: Rami Rosen <ramirose@gmail.com>
> ---
> v2: changed the name of the variable
> ---
>  drivers/net/virtio/virtio_user/vhost.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
> index 83a85cc..55f4703 100644
> --- a/drivers/net/virtio/virtio_user/vhost.h
> +++ b/drivers/net/virtio/virtio_user/vhost.h
> @@ -2,8 +2,8 @@
>   * Copyright(c) 2010-2016 Intel Corporation
>   */
>  
> -#ifndef _VHOST_NET_USER_H
> -#define _VHOST_NET_USER_H
> +#ifndef _VIRTIO_USER_VHOST_H
> +#define _VIRTIO_USER_VHOST_H
>  
>  #include <stdint.h>
>  #include <linux/types.h>
> -- 
> 2.7.4

Reviewed-by: Tiwei Bie <tiwei.bie@intel.com>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] drivers/virtio: fix duplicate naming of include guard
  2019-03-21 10:09 ` [PATCH v2] " Andrius Sirvys
  2019-03-22  6:06   ` Tiwei Bie
@ 2019-03-27 11:13   ` Maxime Coquelin
  1 sibling, 0 replies; 7+ messages in thread
From: Maxime Coquelin @ 2019-03-27 11:13 UTC (permalink / raw)
  To: Andrius Sirvys, dev, Tiwei Bie, Zhihong Wang; +Cc: stable, jianfeng.tan



On 3/21/19 11:09 AM, Andrius Sirvys wrote:
> "The macro name '_VHOST_NET_USER_H' of this include guard is used
> in 2 different header files."
> 
> lib/librte_vhost/vhost_user.h has the same include guard.
> Renamed the include guard in vhost.h to differentiate.
> 
> Fixes: 6a84c37e3975 ("net/virtio-user: add vhost-user adapter layer")
> Cc: jianfeng.tan@intel.com
> Signed-off-by: Andrius Sirvys <andrius.sirvys@intel.com>
> Acked-by: Rami Rosen <ramirose@gmail.com>
> ---
> v2: changed the name of the variable
> ---
>   drivers/net/virtio/virtio_user/vhost.h | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/virtio/virtio_user/vhost.h b/drivers/net/virtio/virtio_user/vhost.h
> index 83a85cc..55f4703 100644
> --- a/drivers/net/virtio/virtio_user/vhost.h
> +++ b/drivers/net/virtio/virtio_user/vhost.h
> @@ -2,8 +2,8 @@
>    * Copyright(c) 2010-2016 Intel Corporation
>    */
>   
> -#ifndef _VHOST_NET_USER_H
> -#define _VHOST_NET_USER_H
> +#ifndef _VIRTIO_USER_VHOST_H
> +#define _VIRTIO_USER_VHOST_H
>   
>   #include <stdint.h>
>   #include <linux/types.h>
> 

Applied to dpdk-next-virtio/master.

Next time please run the check-git-log script before posting,
I fixed the issues while applying.

Thanks,
Maxime

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2019-03-27 11:13 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-03-20 13:57 [PATCH] drivers/virtio: fix duplicate naming of include guard Andrius Sirvys
2019-03-21  6:19 ` Rami Rosen
2019-03-21  7:59 ` Tiwei Bie
2019-03-21  9:26   ` Maxime Coquelin
2019-03-21 10:09 ` [PATCH v2] " Andrius Sirvys
2019-03-22  6:06   ` Tiwei Bie
2019-03-27 11:13   ` Maxime Coquelin

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.