All of lore.kernel.org
 help / color / mirror / Atom feed
* [Bug 1861653] [NEW] CPU of qemu-system-aarch64 always stuck
@ 2020-02-03  6:13 zwq
  2021-05-05 15:23 ` [Bug 1861653] " Thomas Huth
  2021-07-05  4:17 ` Launchpad Bug Tracker
  0 siblings, 2 replies; 3+ messages in thread
From: zwq @ 2020-02-03  6:13 UTC (permalink / raw)
  To: qemu-devel

Public bug reported:

I started qemu with these arguments:
 qemu-system-aarch64 -M virt-2.9 -cpu cortex-a72 -smp cores=8,threads=1,sockets=1 -m 2G -device nec-usb-xhci -device usb-kbd -device usb-tablet -pflash /sdcard/QEMU_EFI.img -pflash /sdcard/QEMU_VARS.img -device virtio-blk-device,drive=Ubuntu -drive if=none,id=Ubuntu,file=Ubuntu.vhd -nographic -net user -net nic,model=rtl8139 -kernel linux -initrd initrd.gz
The setup program of Ubuntu devel aarch64 ran normally.But after several hours,the CPUs emulated by qemu-system-aarch64 went wrong.
Here are the messages displayed on the tty
[15842.164745] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]                                                                         [15930.163589] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]
[16110.163540] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
[16290.162801] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]
[16470.163927] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
[16650.163246] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
[16830.163216] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
[17010.164504] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]

Then I tried CentOS 7.1908 aarch64 with almost the same arguments.
After several hours,it went wrong too.
[17480 . 201 1 58] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=10077
[17480 . 204889] (detected by 3 , t=24007 jiffies , g=218453 , q=5285) [1 7480 . 21 7986] Task dump for CPU 7 :
[17480.222379] swapper/7R running task	0 
0  0x0000002a [17480.229073] Call trace :
[1 7480.241518]	switch t0+0x104/0x1 f8
[17480.249839]	Ox7fffffffffffffff
[17660.232314] rcu : INFO: rcu sched detected stalls on CPUs/ tasks :
[17660.233580] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=17770
[17660.235837] (detected by 3,t=42012 jiffies , g=218453 , q=7039) 
[17660 . 237955] Task dump for CPU 7 :
[17660.238900] swapper/ 7  R running task  0   0
[17660.242967] Call trace :
[17660.246192]	switch t0+0x104/0x1 f8
[17660.253215]	Ox7fffffffffffffff

Obviously qemu-system-aarch64 caused these bugs.

qemu version: 4.x(I have tested version 4.0 & 4.1.0 & 4.2.0)
host architecture: aarch64(Qualcomm Snapdragon series)
host system:Ubuntu devel 20.04& Debian 10(I have tested on many devices)

** Affects: qemu
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1861653

Title:
  CPU of qemu-system-aarch64 always stuck

Status in QEMU:
  New

Bug description:
  I started qemu with these arguments:
   qemu-system-aarch64 -M virt-2.9 -cpu cortex-a72 -smp cores=8,threads=1,sockets=1 -m 2G -device nec-usb-xhci -device usb-kbd -device usb-tablet -pflash /sdcard/QEMU_EFI.img -pflash /sdcard/QEMU_VARS.img -device virtio-blk-device,drive=Ubuntu -drive if=none,id=Ubuntu,file=Ubuntu.vhd -nographic -net user -net nic,model=rtl8139 -kernel linux -initrd initrd.gz
  The setup program of Ubuntu devel aarch64 ran normally.But after several hours,the CPUs emulated by qemu-system-aarch64 went wrong.
  Here are the messages displayed on the tty
  [15842.164745] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]                                                                         [15930.163589] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]
  [16110.163540] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16290.162801] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]
  [16470.163927] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [16650.163246] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16830.163216] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [17010.164504] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]

  Then I tried CentOS 7.1908 aarch64 with almost the same arguments.
  After several hours,it went wrong too.
  [17480 . 201 1 58] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=10077
  [17480 . 204889] (detected by 3 , t=24007 jiffies , g=218453 , q=5285) [1 7480 . 21 7986] Task dump for CPU 7 :
  [17480.222379] swapper/7R running task	0 
  0  0x0000002a [17480.229073] Call trace :
  [1 7480.241518]	switch t0+0x104/0x1 f8
  [17480.249839]	Ox7fffffffffffffff
  [17660.232314] rcu : INFO: rcu sched detected stalls on CPUs/ tasks :
  [17660.233580] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=17770
  [17660.235837] (detected by 3,t=42012 jiffies , g=218453 , q=7039) 
  [17660 . 237955] Task dump for CPU 7 :
  [17660.238900] swapper/ 7  R running task  0   0
  [17660.242967] Call trace :
  [17660.246192]	switch t0+0x104/0x1 f8
  [17660.253215]	Ox7fffffffffffffff

  Obviously qemu-system-aarch64 caused these bugs.

  qemu version: 4.x(I have tested version 4.0 & 4.1.0 & 4.2.0)
  host architecture: aarch64(Qualcomm Snapdragon series)
  host system:Ubuntu devel 20.04& Debian 10(I have tested on many devices)

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1861653/+subscriptions


^ permalink raw reply	[flat|nested] 3+ messages in thread

* [Bug 1861653] Re: CPU of qemu-system-aarch64 always stuck
  2020-02-03  6:13 [Bug 1861653] [NEW] CPU of qemu-system-aarch64 always stuck zwq
@ 2021-05-05 15:23 ` Thomas Huth
  2021-07-05  4:17 ` Launchpad Bug Tracker
  1 sibling, 0 replies; 3+ messages in thread
From: Thomas Huth @ 2021-05-05 15:23 UTC (permalink / raw)
  To: qemu-devel

The QEMU project is currently considering to move its bug tracking to
another system. For this we need to know which bugs are still valid
and which could be closed already. Thus we are setting older bugs to
"Incomplete" now.

If you still think this bug report here is valid, then please switch
the state back to "New" within the next 60 days, otherwise this report
will be marked as "Expired". Or please mark it as "Fix Released" if
the problem has been solved with a newer version of QEMU already.

Thank you and sorry for the inconvenience.


** Changed in: qemu
       Status: New => Incomplete

** Tags added: arm

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1861653

Title:
  CPU of qemu-system-aarch64 always stuck

Status in QEMU:
  Incomplete

Bug description:
  I started qemu with these arguments:
   qemu-system-aarch64 -M virt-2.9 -cpu cortex-a72 -smp cores=8,threads=1,sockets=1 -m 2G -device nec-usb-xhci -device usb-kbd -device usb-tablet -pflash /sdcard/QEMU_EFI.img -pflash /sdcard/QEMU_VARS.img -device virtio-blk-device,drive=Ubuntu -drive if=none,id=Ubuntu,file=Ubuntu.vhd -nographic -net user -net nic,model=rtl8139 -kernel linux -initrd initrd.gz
  The setup program of Ubuntu devel aarch64 ran normally.But after several hours,the CPUs emulated by qemu-system-aarch64 went wrong.
  Here are the messages displayed on the tty
  [15842.164745] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]                                                                         [15930.163589] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]
  [16110.163540] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16290.162801] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]
  [16470.163927] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [16650.163246] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16830.163216] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [17010.164504] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]

  Then I tried CentOS 7.1908 aarch64 with almost the same arguments.
  After several hours,it went wrong too.
  [17480 . 201 1 58] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=10077
  [17480 . 204889] (detected by 3 , t=24007 jiffies , g=218453 , q=5285) [1 7480 . 21 7986] Task dump for CPU 7 :
  [17480.222379] swapper/7R running task	0 
  0  0x0000002a [17480.229073] Call trace :
  [1 7480.241518]	switch t0+0x104/0x1 f8
  [17480.249839]	Ox7fffffffffffffff
  [17660.232314] rcu : INFO: rcu sched detected stalls on CPUs/ tasks :
  [17660.233580] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=17770
  [17660.235837] (detected by 3,t=42012 jiffies , g=218453 , q=7039) 
  [17660 . 237955] Task dump for CPU 7 :
  [17660.238900] swapper/ 7  R running task  0   0
  [17660.242967] Call trace :
  [17660.246192]	switch t0+0x104/0x1 f8
  [17660.253215]	Ox7fffffffffffffff

  Obviously qemu-system-aarch64 caused these bugs.

  qemu version: 4.x(I have tested version 4.0 & 4.1.0 & 4.2.0)
  host architecture: aarch64(Qualcomm Snapdragon series)
  host system:Ubuntu devel 20.04& Debian 10(I have tested on many devices)

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1861653/+subscriptions


^ permalink raw reply	[flat|nested] 3+ messages in thread

* [Bug 1861653] Re: CPU of qemu-system-aarch64 always stuck
  2020-02-03  6:13 [Bug 1861653] [NEW] CPU of qemu-system-aarch64 always stuck zwq
  2021-05-05 15:23 ` [Bug 1861653] " Thomas Huth
@ 2021-07-05  4:17 ` Launchpad Bug Tracker
  1 sibling, 0 replies; 3+ messages in thread
From: Launchpad Bug Tracker @ 2021-07-05  4:17 UTC (permalink / raw)
  To: qemu-devel

[Expired for QEMU because there has been no activity for 60 days.]

** Changed in: qemu
       Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1861653

Title:
  CPU of qemu-system-aarch64 always stuck

Status in QEMU:
  Expired

Bug description:
  I started qemu with these arguments:
   qemu-system-aarch64 -M virt-2.9 -cpu cortex-a72 -smp cores=8,threads=1,sockets=1 -m 2G -device nec-usb-xhci -device usb-kbd -device usb-tablet -pflash /sdcard/QEMU_EFI.img -pflash /sdcard/QEMU_VARS.img -device virtio-blk-device,drive=Ubuntu -drive if=none,id=Ubuntu,file=Ubuntu.vhd -nographic -net user -net nic,model=rtl8139 -kernel linux -initrd initrd.gz
  The setup program of Ubuntu devel aarch64 ran normally.But after several hours,the CPUs emulated by qemu-system-aarch64 went wrong.
  Here are the messages displayed on the tty
  [15842.164745] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]                                                                         [15930.163589] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9]
  [16110.163540] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16290.162801] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]
  [16470.163927] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [16650.163246] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9] 
  [16830.163216] watchdog: BUG: soft lockup - CPU#0 stuck for 23s! [ksoftirqd/0:9] 
  [17010.164504] watchdog: BUG: soft lockup - CPU#0 stuck for 22s! [ksoftirqd/0:9]

  Then I tried CentOS 7.1908 aarch64 with almost the same arguments.
  After several hours,it went wrong too.
  [17480 . 201 1 58] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=10077
  [17480 . 204889] (detected by 3 , t=24007 jiffies , g=218453 , q=5285) [1 7480 . 21 7986] Task dump for CPU 7 :
  [17480.222379] swapper/7R running task	0 
  0  0x0000002a [17480.229073] Call trace :
  [1 7480.241518]	switch t0+0x104/0x1 f8
  [17480.249839]	Ox7fffffffffffffff
  [17660.232314] rcu : INFO: rcu sched detected stalls on CPUs/ tasks :
  [17660.233580] rcu : (3 ticks this GP) idle=362/0/0x3 softirq=61631 /61 631 fqs=17770
  [17660.235837] (detected by 3,t=42012 jiffies , g=218453 , q=7039) 
  [17660 . 237955] Task dump for CPU 7 :
  [17660.238900] swapper/ 7  R running task  0   0
  [17660.242967] Call trace :
  [17660.246192]	switch t0+0x104/0x1 f8
  [17660.253215]	Ox7fffffffffffffff

  Obviously qemu-system-aarch64 caused these bugs.

  qemu version: 4.x(I have tested version 4.0 & 4.1.0 & 4.2.0)
  host architecture: aarch64(Qualcomm Snapdragon series)
  host system:Ubuntu devel 20.04& Debian 10(I have tested on many devices)

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1861653/+subscriptions


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-07-05  4:29 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-03  6:13 [Bug 1861653] [NEW] CPU of qemu-system-aarch64 always stuck zwq
2021-05-05 15:23 ` [Bug 1861653] " Thomas Huth
2021-07-05  4:17 ` Launchpad Bug Tracker

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.