All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API
@ 2021-07-08  4:30 Christophe JAILLET
  2021-07-08 17:32 ` Hemant Kumar
  2021-11-30  6:01 ` Manivannan Sadhasivam
  0 siblings, 2 replies; 5+ messages in thread
From: Christophe JAILLET @ 2021-07-08  4:30 UTC (permalink / raw)
  To: mani, hemantk
  Cc: linux-arm-msm, linux-kernel, kernel-janitors, Christophe JAILLET

The wrappers in include/linux/pci-dma-compat.h should go away.

Replace 'pci_set_dma_mask/pci_set_consistent_dma_mask' by an equivalent
and less verbose 'dma_set_mask_and_coherent()' call.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
If needed, see post from Christoph Hellwig on the kernel-janitors ML:
   https://marc.info/?l=kernel-janitors&m=158745678307186&w=4
---
 drivers/bus/mhi/pci_generic.c | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

diff --git a/drivers/bus/mhi/pci_generic.c b/drivers/bus/mhi/pci_generic.c
index bb0326883470..dd3199de07e2 100644
--- a/drivers/bus/mhi/pci_generic.c
+++ b/drivers/bus/mhi/pci_generic.c
@@ -510,18 +510,12 @@ static int mhi_pci_claim(struct mhi_controller *mhi_cntrl,
 	mhi_cntrl->regs = pcim_iomap_table(pdev)[bar_num];
 	mhi_cntrl->reg_len = pci_resource_len(pdev, bar_num);
 
-	err = pci_set_dma_mask(pdev, dma_mask);
+	err = dma_set_mask_and_coherent(&pdev->dev, dma_mask);
 	if (err) {
 		dev_err(&pdev->dev, "Cannot set proper DMA mask\n");
 		return err;
 	}
 
-	err = pci_set_consistent_dma_mask(pdev, dma_mask);
-	if (err) {
-		dev_err(&pdev->dev, "set consistent dma mask failed\n");
-		return err;
-	}
-
 	pci_set_master(pdev);
 
 	return 0;
-- 
2.30.2


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API
  2021-07-08  4:30 [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API Christophe JAILLET
@ 2021-07-08 17:32 ` Hemant Kumar
  2021-11-29 18:27   ` Christophe JAILLET
  2021-11-30  6:01 ` Manivannan Sadhasivam
  1 sibling, 1 reply; 5+ messages in thread
From: Hemant Kumar @ 2021-07-08 17:32 UTC (permalink / raw)
  To: Christophe JAILLET, mani; +Cc: linux-arm-msm, linux-kernel, kernel-janitors

On Thu, 2021-07-08 at 06:30 +0200, Christophe JAILLET wrote:
> The wrappers in include/linux/pci-dma-compat.h should go away.
> 
> Replace 'pci_set_dma_mask/pci_set_consistent_dma_mask' by an
> equivalent
> and less verbose 'dma_set_mask_and_coherent()' call.
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> If needed, see post from Christoph Hellwig on the kernel-janitors ML:
>    https://marc.info/?l=kernel-janitors&m=158745678307186&w=4
> ---

Reviewed-by: Hemant Kumar <hemantk@codeaurora.org>
-- 
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API
  2021-07-08 17:32 ` Hemant Kumar
@ 2021-11-29 18:27   ` Christophe JAILLET
  2021-11-30  6:06     ` Manivannan Sadhasivam
  0 siblings, 1 reply; 5+ messages in thread
From: Christophe JAILLET @ 2021-11-29 18:27 UTC (permalink / raw)
  To: Hemant Kumar, mani; +Cc: linux-arm-msm, linux-kernel, kernel-janitors

Le 08/07/2021 à 19:32, Hemant Kumar a écrit :
> On Thu, 2021-07-08 at 06:30 +0200, Christophe JAILLET wrote:
>> The wrappers in include/linux/pci-dma-compat.h should go away.
>>
>> Replace 'pci_set_dma_mask/pci_set_consistent_dma_mask' by an
>> equivalent
>> and less verbose 'dma_set_mask_and_coherent()' call.
>>
>> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>> ---
>> If needed, see post from Christoph Hellwig on the kernel-janitors ML:
>>     https://marc.info/?l=kernel-janitors&m=158745678307186&w=4
>> ---
> 
> Reviewed-by: Hemant Kumar <hemantk@codeaurora.org>
> 

Hi,

Polite reminder.
This is still not part of -next.

The patch is old (July/21), I can resend if needed.

CJ

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API
  2021-07-08  4:30 [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API Christophe JAILLET
  2021-07-08 17:32 ` Hemant Kumar
@ 2021-11-30  6:01 ` Manivannan Sadhasivam
  1 sibling, 0 replies; 5+ messages in thread
From: Manivannan Sadhasivam @ 2021-11-30  6:01 UTC (permalink / raw)
  To: Christophe JAILLET; +Cc: hemantk, linux-arm-msm, linux-kernel, kernel-janitors

On Thu, Jul 08, 2021 at 06:30:37AM +0200, Christophe JAILLET wrote:
> The wrappers in include/linux/pci-dma-compat.h should go away.
> 
> Replace 'pci_set_dma_mask/pci_set_consistent_dma_mask' by an equivalent
> and less verbose 'dma_set_mask_and_coherent()' call.
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>

Reveiwed-by: Manivannan Sadhasivam <mani@kernel.org>

Thanks,
Mani

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API
  2021-11-29 18:27   ` Christophe JAILLET
@ 2021-11-30  6:06     ` Manivannan Sadhasivam
  0 siblings, 0 replies; 5+ messages in thread
From: Manivannan Sadhasivam @ 2021-11-30  6:06 UTC (permalink / raw)
  To: Christophe JAILLET
  Cc: Hemant Kumar, linux-arm-msm, linux-kernel, kernel-janitors

On Mon, Nov 29, 2021 at 07:27:20PM +0100, Christophe JAILLET wrote:
> Le 08/07/2021 à 19:32, Hemant Kumar a écrit :
> > On Thu, 2021-07-08 at 06:30 +0200, Christophe JAILLET wrote:
> > > The wrappers in include/linux/pci-dma-compat.h should go away.
> > > 
> > > Replace 'pci_set_dma_mask/pci_set_consistent_dma_mask' by an
> > > equivalent
> > > and less verbose 'dma_set_mask_and_coherent()' call.
> > > 
> > > Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> > > ---
> > > If needed, see post from Christoph Hellwig on the kernel-janitors ML:
> > >     https://marc.info/?l=kernel-janitors&m=158745678307186&w=4
> > > ---
> > 
> > Reviewed-by: Hemant Kumar <hemantk@codeaurora.org>
> > 
> 
> Hi,
> 
> Polite reminder.
> This is still not part of -next.
> 
> The patch is old (July/21), I can resend if needed.

Sorry, this one slipped through the cracks. Applied to mhi-next now!

Thanks,
Mani

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-11-30  6:06 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-08  4:30 [PATCH] bus: mhi: pci_generic: Simplify code and axe the use of a deprecated API Christophe JAILLET
2021-07-08 17:32 ` Hemant Kumar
2021-11-29 18:27   ` Christophe JAILLET
2021-11-30  6:06     ` Manivannan Sadhasivam
2021-11-30  6:01 ` Manivannan Sadhasivam

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.