From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,MENTIONS_GIT_HOSTING,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id BBBDEC352B6 for ; Fri, 10 Apr 2020 16:01:04 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 91FF7212CC for ; Fri, 10 Apr 2020 16:01:04 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726759AbgDJQAv (ORCPT ); Fri, 10 Apr 2020 12:00:51 -0400 Received: from cloudserver094114.home.pl ([79.96.170.134]:57670 "EHLO cloudserver094114.home.pl" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726725AbgDJQAv (ORCPT ); Fri, 10 Apr 2020 12:00:51 -0400 Received: from 185.80.35.16 (185.80.35.16) (HELO kreacher.localnet) by serwer1319399.home.pl (79.96.170.134) with SMTP (IdeaSmtpServer 0.83.415) id 08258914799ae752; Fri, 10 Apr 2020 18:00:49 +0200 From: "Rafael J. Wysocki" To: Linux PM , Alan Stern Cc: Linux ACPI , Linux PCI , LKML , Bjorn Helgaas , Greg Kroah-Hartman , Mika Westerberg , Hans De Goede , Ulf Hansson Subject: [PATCH 0/7] PM: sleep: core: Rearrange the handling of driver power management flags Date: Fri, 10 Apr 2020 17:46:27 +0200 Message-ID: <1888197.j9z7NJ8yPn@kreacher> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" Sender: linux-acpi-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-acpi@vger.kernel.org Hi Alan, Following our recent discussion regarding the DPM_FLAG_* family of flags [1], I have decided to follow some of your recommendations and make changes to the core code handling those flags. The purpose of this is basically to make the code more consistent internally, easier to follow and better documented. First of all, patch [1/7] changes the PM core to skip driver-level "late" and "noirq" suspend callbacks for devices with SMART_SUSPEND set if they are still runtime-suspended during the "late" system-wide suspend phase (without the patch it does that only if subsystem-level late/noirq/early suspend/resume callbacks are not present for the device, which is demonstrably inconsistent) and updates the resume part of the code accordingly (it doesn't need to check whether or not the subsystem-level callbacks are present any more). The next patch, [2/7], is purely cosmetic and its only purpose is to reduce the LOC number and move related pieces of code closer to each other. Patch [3/7] changes the PM core so that it doesn't skip any subsystem-level callbacks during system-wide resume (without the patch they may be skipped in the "early resume" and "resume" phases due to LEAVE_SUSPENDED being set which may be problematic) and to always run the driver's ->resume callback if the corresponding subsystem-level callback is not present (without the patch it may be skipped if LEAVE_SUSPENDED is set) to let it reverse the changes made by the driver's ->suspend callback (which always runs too) if need be. Patches [4-6/7] rename one function in the PM core and two driver PM flags to make their names better reflect their purpose. Finally, patch [7/7] updates the documentation of the driver PM flags to reflect the new code flows. This patch series have been available in the git branch at git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \ pm-sleep-core for easier web and git access. Cheers! [1] https://lore.kernel.org/linux-pm/Pine.LNX.4.44L0.2003251631360.1724-100000@netrider.rowland.org/