All of lore.kernel.org
 help / color / mirror / Atom feed
From: Allison Henderson <allison.henderson@oracle.com>
To: "Darrick J. Wong" <darrick.wong@oracle.com>
Cc: linux-xfs@vger.kernel.org
Subject: Re: [PATCH v14 14/15] xfs: Add delattr mount option
Date: Tue, 5 Jan 2021 14:49:43 -0700	[thread overview]
Message-ID: <18c7472c-598a-624a-7043-0a79ab017919@oracle.com> (raw)
In-Reply-To: <20210105054626.GV6918@magnolia>



On 1/4/21 10:46 PM, Darrick J. Wong wrote:
> On Fri, Dec 18, 2020 at 12:29:16AM -0700, Allison Henderson wrote:
>> This patch adds a mount option to enable delayed attributes. Eventually
>> this can be removed when delayed attrs becomes permanent.
>>
>> Signed-off-by: Allison Henderson <allison.henderson@oracle.com>
>> ---
>>   fs/xfs/libxfs/xfs_attr.h | 2 +-
>>   fs/xfs/xfs_mount.h       | 1 +
>>   fs/xfs/xfs_super.c       | 6 +++++-
>>   fs/xfs/xfs_xattr.c       | 2 ++
>>   4 files changed, 9 insertions(+), 2 deletions(-)
>>
>> diff --git a/fs/xfs/libxfs/xfs_attr.h b/fs/xfs/libxfs/xfs_attr.h
>> index 4838094..edd008d 100644
>> --- a/fs/xfs/libxfs/xfs_attr.h
>> +++ b/fs/xfs/libxfs/xfs_attr.h
>> @@ -30,7 +30,7 @@ struct xfs_attr_list_context;
>>   
>>   static inline bool xfs_hasdelattr(struct xfs_mount *mp)
> 
> /me had a brain fart just now that ... since struct xfs_delattr_context
> is ultimately going to be absorbed into struct xfs_attr_item, we really
> should have called the control knob part of this 'logattr' instead of
> 'delattr', because that's (IMIO) a better explanation of what the mount
> option actually does for users.
That's fine, honestly I figured I'd just throw some name out there just 
to get it working initially, and if someone wants a different name, 
they'd say so.  It is a temporary option after all.  :-)

> 
> An even better name would have been "logged attributes replayable"
> because then you could use the prefix XFS_LARP for things. :P
Yeah, I think the name scheme was something we mulled about a while ago, 
though didn't really have a solid opinion on yet.  But we did feel that 
DAS and DAC are sort of close to DA and DAX.

I am ok with LARP.  I'll probably end up mistakenly referring to it as a 
"Log Action Re-Play", but I'm fine with that.  :-)  Just as long as 
everyone else is. Names seem to be something that everyone is really 
opinionated on, and it peppers little changes all over the set, so it 
would be nice to have a semi solid consensus  :-)

Thanks for the reviews!

Allison

> 
> Comments? :)
> 
> --D
> 
> 
>>   {
>> -	return false;
>> +	return mp->m_flags & XFS_MOUNT_DELATTR;
>>   }
>>   
>>   /*
>> diff --git a/fs/xfs/xfs_mount.h b/fs/xfs/xfs_mount.h
>> index dfa429b..4794f27 100644
>> --- a/fs/xfs/xfs_mount.h
>> +++ b/fs/xfs/xfs_mount.h
>> @@ -254,6 +254,7 @@ typedef struct xfs_mount {
>>   #define XFS_MOUNT_NOATTR2	(1ULL << 25)	/* disable use of attr2 format */
>>   #define XFS_MOUNT_DAX_ALWAYS	(1ULL << 26)
>>   #define XFS_MOUNT_DAX_NEVER	(1ULL << 27)
>> +#define XFS_MOUNT_DELATTR	(1ULL << 28)	/* enable delayed attributes */
>>   
>>   /*
>>    * Max and min values for mount-option defined I/O
>> diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
>> index 813be87..72169ee 100644
>> --- a/fs/xfs/xfs_super.c
>> +++ b/fs/xfs/xfs_super.c
>> @@ -92,7 +92,7 @@ enum {
>>   	Opt_filestreams, Opt_quota, Opt_noquota, Opt_usrquota, Opt_grpquota,
>>   	Opt_prjquota, Opt_uquota, Opt_gquota, Opt_pquota,
>>   	Opt_uqnoenforce, Opt_gqnoenforce, Opt_pqnoenforce, Opt_qnoenforce,
>> -	Opt_discard, Opt_nodiscard, Opt_dax, Opt_dax_enum,
>> +	Opt_discard, Opt_nodiscard, Opt_dax, Opt_dax_enum, Opt_delattr
>>   };
>>   
>>   static const struct fs_parameter_spec xfs_fs_parameters[] = {
>> @@ -137,6 +137,7 @@ static const struct fs_parameter_spec xfs_fs_parameters[] = {
>>   	fsparam_flag("nodiscard",	Opt_nodiscard),
>>   	fsparam_flag("dax",		Opt_dax),
>>   	fsparam_enum("dax",		Opt_dax_enum, dax_param_enums),
>> +	fsparam_flag("delattr",		Opt_delattr),
>>   	{}
>>   };
>>   
>> @@ -1292,6 +1293,9 @@ xfs_fs_parse_param(
>>   		xfs_mount_set_dax_mode(mp, result.uint_32);
>>   		return 0;
>>   #endif
>> +	case Opt_delattr:
>> +		mp->m_flags |= XFS_MOUNT_DELATTR;
>> +		return 0;
>>   	/* Following mount options will be removed in September 2025 */
>>   	case Opt_ikeep:
>>   		xfs_warn(mp, "%s mount option is deprecated.", param->key);
>> diff --git a/fs/xfs/xfs_xattr.c b/fs/xfs/xfs_xattr.c
>> index 9b0c790..8ec61df 100644
>> --- a/fs/xfs/xfs_xattr.c
>> +++ b/fs/xfs/xfs_xattr.c
>> @@ -8,6 +8,8 @@
>>   #include "xfs_shared.h"
>>   #include "xfs_format.h"
>>   #include "xfs_log_format.h"
>> +#include "xfs_trans_resv.h"
>> +#include "xfs_mount.h"
>>   #include "xfs_da_format.h"
>>   #include "xfs_inode.h"
>>   #include "xfs_da_btree.h"
>> -- 
>> 2.7.4
>>

  reply	other threads:[~2021-01-05 21:50 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-18  7:29 [PATCH v14 00/15] xfs: Delayed Attributes Allison Henderson
2020-12-18  7:29 ` [PATCH v14 01/15] xfs: Add helper xfs_attr_node_remove_step Allison Henderson
2020-12-21  6:45   ` Chandan Babu R
2020-12-21 23:48     ` Allison Henderson
2020-12-22 16:50   ` Brian Foster
2020-12-18  7:29 ` [PATCH v14 02/15] xfs: Add xfs_attr_node_remove_cleanup Allison Henderson
2020-12-21  6:45   ` Chandan Babu R
2020-12-21 23:47     ` Allison Henderson
2020-12-22 16:50   ` Brian Foster
2020-12-18  7:29 ` [PATCH v14 03/15] xfs: Hoist transaction handling in xfs_attr_node_remove_step Allison Henderson
2020-12-21  6:45   ` Chandan Babu R
2020-12-21 21:51     ` Allison Henderson
2020-12-18  7:29 ` [PATCH v14 04/15] xfs: Add delay ready attr remove routines Allison Henderson
2020-12-22  7:22   ` Chandan Babu R
2020-12-22 15:41     ` Allison Henderson
2020-12-23  4:05       ` Chandan Babu R
2020-12-22 17:11   ` Brian Foster
2020-12-22 17:20     ` Brian Foster
2020-12-22 18:44       ` Brian Foster
2020-12-23  5:20         ` Allison Henderson
2020-12-23 14:16           ` Brian Foster
2020-12-24  8:23             ` Allison Henderson
2021-01-04 17:52               ` Brian Foster
2021-01-05 18:10                 ` Allison Henderson
2021-01-06 14:25                   ` Brian Foster
2020-12-18  7:29 ` [PATCH v14 05/15] xfs: Add delay ready attr set routines Allison Henderson
2020-12-23  8:00   ` Chandan Babu R
2020-12-23 16:31     ` Allison Henderson
2020-12-18  7:29 ` [PATCH v14 06/15] xfs: Add state machine tracepoints Allison Henderson
2021-01-05  4:50   ` Chandan Babu R
2021-01-05 21:06     ` Allison Henderson
2021-01-05  5:28   ` Darrick J. Wong
2021-01-05 21:07     ` Allison Henderson
2020-12-18  7:29 ` [PATCH v14 07/15] xfs: Rename __xfs_attr_rmtval_remove Allison Henderson
2020-12-18  7:29 ` [PATCH v14 08/15] xfs: Handle krealloc errors in xlog_recover_add_to_cont_trans Allison Henderson
2021-01-05  5:38   ` Darrick J. Wong
2021-01-05 20:15     ` Allison Henderson
2020-12-18  7:29 ` [PATCH v14 09/15] xfs: Set up infastructure for deferred attribute operations Allison Henderson
2020-12-18  7:29 ` [PATCH v14 10/15] xfs: Skip flip flags for delayed attrs Allison Henderson
2020-12-18  7:29 ` [PATCH v14 11/15] xfs: Add xfs_attr_set_deferred and xfs_attr_remove_deferred Allison Henderson
2020-12-18  7:29 ` [PATCH v14 12/15] xfs: Remove unused xfs_attr_*_args Allison Henderson
2020-12-18  7:29 ` [PATCH v14 13/15] xfs: Add delayed attributes error tag Allison Henderson
2020-12-18  7:29 ` [PATCH v14 14/15] xfs: Add delattr mount option Allison Henderson
2021-01-05  5:46   ` Darrick J. Wong
2021-01-05 21:49     ` Allison Henderson [this message]
2020-12-18  7:29 ` [PATCH v14 15/15] xfs: Merge xfs_delattr_context into xfs_attr_item Allison Henderson
2021-01-05  5:47   ` Darrick J. Wong
2021-01-05 21:07     ` Allison Henderson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=18c7472c-598a-624a-7043-0a79ab017919@oracle.com \
    --to=allison.henderson@oracle.com \
    --cc=darrick.wong@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.