All of lore.kernel.org
 help / color / mirror / Atom feed
From: David B Harris <david@eelf.ddts.net>
To: alsa-devel@lists.sourceforge.net
Subject: Re: SIS7012 works but get's frozen
Date: Sat, 19 Jul 2003 06:25:42 -0400	[thread overview]
Message-ID: <20030719062542.5cade906.david@eelf.ddts.net> (raw)
In-Reply-To: <1058568436.3642.15.camel@julius>

[-- Attachment #1: Type: text/plain, Size: 2829 bytes --]

On 18 Jul 2003 18:47:17 -0400
"P.I.Julius" <julius@solutions-i.org> wrote:
> Hi all ALSA developers
> 
> I have a sis7012 sound card with my new laptop SonyVaio PCG-GRT100 but
> the sound is not working. I tried out with the kernel i810_audio modul,
> with the OpenSounSystem, and with the alsa too, but with every driver my
> sound card is not working. The modules are loaded, and i can change the
> volume with aumix, but if i try to play a sound file, just the first
> second gets played, and then my box gets frozen.
> 
> Please help, i really want to hear more then 1 second from a mp3 file :)
> Thanks a lot
> Julius

I'd like to "me too" this particular report; I use the on-board audio of
the ECS K7S5A motherboard, and 0.9.5 doesn't seem to be particularily
happy with it. Here are some error messages:

[ david@willow: ~/music/ ]$ xmms
ALSA lib pcm_params.c:2096:(snd_pcm_hw_refine_slave) Slave PCM not usable
[ david@willow: ~/music/ ]$ mpg321 -o alsa Don\ MacLean\ -\ American\ Pie.mp3 
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.59q (2002/03/23). Written and copyrights by Joe Drew.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!

Playing MPEG stream from Don MacLean - American Pie.mp3 ...
MPEG 1.0 layer III, 192 kbit/s, 44100 Hz stereo
ALSA lib pcm_params.c:2096:(snd_pcm_hw_refine_slave) Slave PCM not usable
ALSA snd_pcm_hw_params_any error: Invalid argument
libao - OSS cannot set channels to 2
Can't find a suitable libao driver. (Is device in use?)
[ david@willow: ~/music/ ]$ 
[ david@willow: ~/music/ ]$ esd -tcp -public -nobeeps -as 2
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 48Khz, stereo,16bit failed
Trying 22.05Khz, 8bit stereo.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 22.05Khz, stereo, 8bit failed
Trying 44.1Khz, 16bit mono.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 44.1Khz, mono, 8bit failed
Trying 22.05Khz, 8bit mono.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 22.05Khz, mono, 8bit failed
Trying 11.025Khz, 8bit stereo.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 11.025Khz, stereo, 8bit failed
Trying 11.025Khz, 8bit mono.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 11.025Khz, mono, 8bit failed
Trying 8.192Khz, 8bit mono.
SNDCTL_DSP_SETFMT: Invalid argument
Audio device open for 8.192Khz, mono, 8bit failed
Trying 8Khz, 8bit mono.
SNDCTL_DSP_SETFMT: Invalid argument
Sound device inadequate for Esound. Fatal.
[ david@willow: ~/music/ ]$ 

Thanks :)

[-- Attachment #2: Type: application/pgp-signature, Size: 189 bytes --]

  reply	other threads:[~2003-07-19 10:25 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-18 22:47 SIS7012 works but get's frozen P.I.Julius
2003-07-19 10:25 ` David B Harris [this message]
2003-07-21 14:35   ` Takashi Iwai
2003-07-21 16:19     ` David B Harris
2003-07-21 14:34 ` Takashi Iwai
2003-07-18 23:37 P.I.Julius
     [not found] <BAY2-F34S5C74a24LnK000028d9@hotmail.com>
2003-07-22 16:47 ` Takashi Iwai
2003-07-23  1:55 Lisandro Pin
2003-07-23  8:25 ` Takashi Iwai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20030719062542.5cade906.david@eelf.ddts.net \
    --to=david@eelf.ddts.net \
    --cc=alsa-devel@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.