All of lore.kernel.org
 help / color / mirror / Atom feed
From: Randy Dunlap <randy.dunlap@oracle.com>
To: Muli Ben-Yehuda <muli@il.ibm.com>
Cc: Joe Perches <joe@perches.com>, linux-kernel@vger.kernel.org
Subject: Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)" to "array_for_each(index, array)"
Date: Tue, 13 Feb 2007 08:28:45 -0800	[thread overview]
Message-ID: <20070213082845.84212ca0.randy.dunlap@oracle.com> (raw)
In-Reply-To: <20070213073738.GB23804@rhun.ibm.com>

On Tue, 13 Feb 2007 09:37:38 +0200 Muli Ben-Yehuda wrote:

> On Mon, Feb 12, 2007 at 03:47:50PM -0800, Joe Perches wrote:
> 
> > Now that most of the sizeof(array)/sizeof(array[0]) conversions have
> > been done (there are about 800 done and about another 130 left),
> > perhaps it could be useful to change the code to use a define
> > similar to the list_for_each
> > 
> > #define list_for_each(pos, head) \
> > 	for (pos = (head)->next; prefetch(pos->next), pos != (head); \
> >         	pos = pos->next)
> > 
> > perhaps
> > 
> > #define array_for_each(index, array) \
> > 	for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)
> 
> Could we please stop "improving" the C language? it has served us fine
> so far.

I'm with Muli.  The open-coded for loop is fine (using ARRAY_SIZE).

---
~Randy
*** Remember to use Documentation/SubmitChecklist when testing your code ***

  reply	other threads:[~2007-02-13 16:33 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-02-12 23:47 Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)" to "array_for_each(index, array)" Joe Perches
2007-02-13  0:20 ` Ben Nizette
2007-02-13  0:47   ` Joe Perches
2007-02-13  4:19     ` Nick Piggin
2007-02-13  7:34       ` Joe Perches
2007-02-13  7:42         ` Nick Piggin
2007-02-13 10:36           ` Bernd Petrovitsch
2007-02-13 10:54             ` Nick Piggin
2007-02-13 11:07               ` Bernd Petrovitsch
2007-02-13  7:37 ` Muli Ben-Yehuda
2007-02-13 16:28   ` Randy Dunlap [this message]
2007-02-13  7:48 ` YOSHIFUJI Hideaki / 吉藤英明

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070213082845.84212ca0.randy.dunlap@oracle.com \
    --to=randy.dunlap@oracle.com \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=muli@il.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.