All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chen Cao <kcao@redhat.com>
To: Avi Kivity <avi@redhat.com>
Cc: Isaku Yamahata <yamahata@valinux.co.jp>,
	Ken CC <ken.ccao@gmail.com>,
	kvm@vger.kernel.org, qemu-devel@nongnu.org,
	"Michael S. Tsirkin" <mst@redhat.com>
Subject: Re: [Qemu-devel] [PATCH 3/3] Check pci slot number in parse_pci_devfn
Date: Tue, 24 Aug 2010 20:16:32 +0800	[thread overview]
Message-ID: <20100824121632.GG1971@kt> (raw)
In-Reply-To: <4C73B55C.3050800@redhat.com>

On Tue, Aug 24, 2010 at 03:04:44PM +0300, Avi Kivity wrote:
>  On 08/24/2010 03:07 PM, Isaku Yamahata wrote:
> >On Tue, Aug 24, 2010 at 02:42:18PM +0300, Avi Kivity wrote:
> >>  On 08/24/2010 02:35 PM, Isaku Yamahata wrote:
> >>>Add Cc: mst@redhat.com.
> >>>
> >>>MAX_PCI_SLOTS should be in pci.h instead of qdev.h?
> >>>And the name should be start with PCI_ prefix for consistency?
> >>>
> >>>Except that, the patches look okay.
> >>>
> >>These aren't slots, are they?  They are functions.
> >The function checks if given $slot.$fn (or $slot) is valid.
> >So it's slots. max 32.
> 
> +    assert(devfn<  PCIBUS_MAX_DEVICES);
> 
> 
> Looks like we're comparing a function number to PCIBUS_MAX_DEVICES.
> 

PCIBUS_MAX_DEVICES is the size of PCIBus.devices[], I have added it in
the first patch at the defination of struct PCIBus, line 50 hw/pci.c.
so i think the better name of the macro should be PCIBUS_MAX_FN,
right?


Ken

> -- 
> error compiling committee.c: too many arguments to function
> 
> --
> To unsubscribe from this list: send the line "unsubscribe kvm" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 

WARNING: multiple messages have this Message-ID
From: Chen Cao <kcao@redhat.com>
To: Avi Kivity <avi@redhat.com>
Cc: Isaku Yamahata <yamahata@valinux.co.jp>,
	Ken CC <ken.ccao@gmail.com>,
	qemu-devel@nongnu.org, kvm@vger.kernel.org,
	"Michael S. Tsirkin" <mst@redhat.com>
Subject: Re: [Qemu-devel] [PATCH 3/3] Check pci slot number in parse_pci_devfn
Date: Tue, 24 Aug 2010 20:16:32 +0800	[thread overview]
Message-ID: <20100824121632.GG1971@kt> (raw)
In-Reply-To: <4C73B55C.3050800@redhat.com>

On Tue, Aug 24, 2010 at 03:04:44PM +0300, Avi Kivity wrote:
>  On 08/24/2010 03:07 PM, Isaku Yamahata wrote:
> >On Tue, Aug 24, 2010 at 02:42:18PM +0300, Avi Kivity wrote:
> >>  On 08/24/2010 02:35 PM, Isaku Yamahata wrote:
> >>>Add Cc: mst@redhat.com.
> >>>
> >>>MAX_PCI_SLOTS should be in pci.h instead of qdev.h?
> >>>And the name should be start with PCI_ prefix for consistency?
> >>>
> >>>Except that, the patches look okay.
> >>>
> >>These aren't slots, are they?  They are functions.
> >The function checks if given $slot.$fn (or $slot) is valid.
> >So it's slots. max 32.
> 
> +    assert(devfn<  PCIBUS_MAX_DEVICES);
> 
> 
> Looks like we're comparing a function number to PCIBUS_MAX_DEVICES.
> 

PCIBUS_MAX_DEVICES is the size of PCIBus.devices[], I have added it in
the first patch at the defination of struct PCIBus, line 50 hw/pci.c.
so i think the better name of the macro should be PCIBUS_MAX_FN,
right?


Ken

> -- 
> error compiling committee.c: too many arguments to function
> 
> --
> To unsubscribe from this list: send the line "unsubscribe kvm" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 

  reply	other threads:[~2010-08-24 12:16 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-24  6:33 [PATCH 1/3] PCI: define max devices number on PCIBus as PCIBUS_MAX_DEVICES in pci.h Ken CC
2010-08-24  6:33 ` [Qemu-devel] " Ken CC
2010-08-24  6:48 ` [PATCH 2/3] pci init: fail qemu if devfn exceeding the max devices number supported on bus Ken CC
2010-08-24  6:48   ` [Qemu-devel] " Ken CC
2010-08-24  6:49 ` [PATCH 3/3] Check pci slot number in parse_pci_devfn Ken CC
2010-08-24  6:49   ` [Qemu-devel] " Ken CC
2010-08-24 11:35   ` Isaku Yamahata
2010-08-24 11:35     ` Isaku Yamahata
2010-08-24 11:42     ` Avi Kivity
2010-08-24 11:42       ` Avi Kivity
2010-08-24 12:07       ` Isaku Yamahata
2010-08-24 12:07         ` Isaku Yamahata
2010-08-24 12:04         ` Avi Kivity
2010-08-24 12:04           ` Avi Kivity
2010-08-24 12:16           ` Chen Cao [this message]
2010-08-24 12:16             ` Chen Cao
2010-08-24 12:19             ` Avi Kivity
2010-08-24 12:19               ` Avi Kivity
2010-08-24 12:24           ` Isaku Yamahata
2010-08-24 12:24             ` Isaku Yamahata
2010-08-24 12:16             ` Avi Kivity
2010-08-24 12:16               ` Avi Kivity
     [not found] <20100824062517.12408.45246.stgit@k1>
2010-08-24  6:34 ` Ken CC

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100824121632.GG1971@kt \
    --to=kcao@redhat.com \
    --cc=avi@redhat.com \
    --cc=ken.ccao@gmail.com \
    --cc=kvm@vger.kernel.org \
    --cc=mst@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=yamahata@valinux.co.jp \
    --subject='Re: [Qemu-devel] [PATCH 3/3] Check pci slot number in parse_pci_devfn' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.