From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from [140.186.70.92] (port=42201 helo=eggs.gnu.org) by lists.gnu.org with esmtp (Exim 4.43) id 1Pi5ZU-000760-Qo for qemu-devel@nongnu.org; Wed, 26 Jan 2011 08:38:05 -0500 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1Pi5ZS-00087t-QJ for qemu-devel@nongnu.org; Wed, 26 Jan 2011 08:38:04 -0500 Received: from mx1.redhat.com ([209.132.183.28]:51819) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1Pi5ZS-00087h-Ff for qemu-devel@nongnu.org; Wed, 26 Jan 2011 08:38:02 -0500 Date: Wed, 26 Jan 2011 15:37:44 +0200 From: "Michael S. Tsirkin" Message-ID: <20110126133744.GB12805@redhat.com> References: <76163938f7a687e924637b7118b4000d940d6465.1296034717.git.yamahata@valinux.co.jp> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <76163938f7a687e924637b7118b4000d940d6465.1296034717.git.yamahata@valinux.co.jp> Subject: [Qemu-devel] Re: [PATCH 1/3] pci: replace the magic, 256, for the maximum of devfn List-Id: qemu-devel.nongnu.org List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Isaku Yamahata Cc: qemu-devel@nongnu.org On Wed, Jan 26, 2011 at 06:45:18PM +0900, Isaku Yamahata wrote: > Introduce symbol PCI_DEVFN_MAX for the maximum of devfn > and replace the magic, 256. > > Signed-off-by: Isaku Yamahata > --- > hw/pci.h | 2 ++ > hw/pci_internals.h | 2 +- > 2 files changed, 3 insertions(+), 1 deletions(-) > > diff --git a/hw/pci.h b/hw/pci.h > index 0d2753f..ffb04e8 100644 > --- a/hw/pci.h > +++ b/hw/pci.h > @@ -16,7 +16,9 @@ > #define PCI_DEVFN(slot, func) ((((slot) & 0x1f) << 3) | ((func) & 0x07)) > #define PCI_SLOT(devfn) (((devfn) >> 3) & 0x1f) > #define PCI_FUNC(devfn) ((devfn) & 0x07) > +#define PCI_SLOT_MAX 32 > #define PCI_FUNC_MAX 8 > +#define PCI_DEVFN_MAX (PCI_SLOT_MAX * PCI_FUNC_MAX) SLOT_MAX makes sense. I'd prefer open-coding PCI_DEVFN_MAX if there's only one user. > > /* Class, Vendor and Device IDs from Linux's pci_ids.h */ > #include "pci_ids.h" > diff --git a/hw/pci_internals.h b/hw/pci_internals.h > index e3c93a3..f17e681 100644 > --- a/hw/pci_internals.h > +++ b/hw/pci_internals.h > @@ -22,7 +22,7 @@ struct PCIBus { > pci_hotplug_fn hotplug; > DeviceState *hotplug_qdev; > void *irq_opaque; > - PCIDevice *devices[256]; > + PCIDevice *devices[PCI_DEVFN_MAX]; > PCIDevice *parent_dev; > target_phys_addr_t mem_base; > > -- > 1.7.1.1