From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752217Ab1DSF5I (ORCPT ); Tue, 19 Apr 2011 01:57:08 -0400 Received: from e1.ny.us.ibm.com ([32.97.182.141]:41699 "EHLO e1.ny.us.ibm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751011Ab1DSF5G (ORCPT ); Tue, 19 Apr 2011 01:57:06 -0400 Date: Tue, 19 Apr 2011 11:13:25 +0530 From: Srikar Dronamraju To: Peter Zijlstra Cc: Ingo Molnar , Steven Rostedt , Linux-mm , Arnaldo Carvalho de Melo , Linus Torvalds , Masami Hiramatsu , Ananth N Mavinakayanahalli , Christoph Hellwig , Andi Kleen , Thomas Gleixner , Jonathan Corbet , Oleg Nesterov , Andrew Morton , Jim Keniston , Roland McGrath , SystemTap , LKML Subject: Re: [PATCH v3 2.6.39-rc1-tip 14/26] 14: x86: x86 specific probe handling Message-ID: <20110419054325.GA10698@linux.vnet.ibm.com> Reply-To: Srikar Dronamraju References: <20110401143223.15455.19844.sendpatchset@localhost6.localdomain6> <20110401143517.15455.88373.sendpatchset@localhost6.localdomain6> <1303145700.32491.891.camel@twins> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline In-Reply-To: <1303145700.32491.891.camel@twins> User-Agent: Mutt/1.5.20 (2009-06-14) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Peter Zijlstra [2011-04-18 18:55:00]: > On Fri, 2011-04-01 at 20:05 +0530, Srikar Dronamraju wrote: > > +/* > > + * @reg: reflects the saved state of the task > > + * @vaddr: the virtual address to jump to. > > + * Return 0 on success or a -ve number on error. > > + */ > > +void set_ip(struct pt_regs *regs, unsigned long vaddr) > > +{ > > + regs->ip = vaddr; > > +} > > Since we have the cross-architecture function: > instruction_pointer(struct pt_regs*) to read the thing, this ought to be > called set_instruction_pointer(struct pt_regs*, unsigned long) or > somesuch. Okay, will rename set_ip to set_instruction_pointer. From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail138.messagelabs.com (mail138.messagelabs.com [216.82.249.35]) by kanga.kvack.org (Postfix) with ESMTP id B7820900086 for ; Tue, 19 Apr 2011 01:57:07 -0400 (EDT) Received: from d01relay06.pok.ibm.com (d01relay06.pok.ibm.com [9.56.227.116]) by e4.ny.us.ibm.com (8.14.4/8.13.1) with ESMTP id p3J5apRG023689 for ; Tue, 19 Apr 2011 01:36:51 -0400 Received: from d01av02.pok.ibm.com (d01av02.pok.ibm.com [9.56.224.216]) by d01relay06.pok.ibm.com (8.13.8/8.13.8/NCO v10.0) with ESMTP id p3J5v1AB2695272 for ; Tue, 19 Apr 2011 01:57:01 -0400 Received: from d01av02.pok.ibm.com (loopback [127.0.0.1]) by d01av02.pok.ibm.com (8.14.4/8.13.1/NCO v10.0 AVout) with ESMTP id p3J5v0xM005037 for ; Tue, 19 Apr 2011 02:57:01 -0300 Date: Tue, 19 Apr 2011 11:13:25 +0530 From: Srikar Dronamraju Subject: Re: [PATCH v3 2.6.39-rc1-tip 14/26] 14: x86: x86 specific probe handling Message-ID: <20110419054325.GA10698@linux.vnet.ibm.com> Reply-To: Srikar Dronamraju References: <20110401143223.15455.19844.sendpatchset@localhost6.localdomain6> <20110401143517.15455.88373.sendpatchset@localhost6.localdomain6> <1303145700.32491.891.camel@twins> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline In-Reply-To: <1303145700.32491.891.camel@twins> Sender: owner-linux-mm@kvack.org List-ID: To: Peter Zijlstra Cc: Ingo Molnar , Steven Rostedt , Linux-mm , Arnaldo Carvalho de Melo , Linus Torvalds , Masami Hiramatsu , Ananth N Mavinakayanahalli , Christoph Hellwig , Andi Kleen , Thomas Gleixner , Jonathan Corbet , Oleg Nesterov , Andrew Morton , Jim Keniston , Roland McGrath , SystemTap , LKML * Peter Zijlstra [2011-04-18 18:55:00]: > On Fri, 2011-04-01 at 20:05 +0530, Srikar Dronamraju wrote: > > +/* > > + * @reg: reflects the saved state of the task > > + * @vaddr: the virtual address to jump to. > > + * Return 0 on success or a -ve number on error. > > + */ > > +void set_ip(struct pt_regs *regs, unsigned long vaddr) > > +{ > > + regs->ip = vaddr; > > +} > > Since we have the cross-architecture function: > instruction_pointer(struct pt_regs*) to read the thing, this ought to be > called set_instruction_pointer(struct pt_regs*, unsigned long) or > somesuch. Okay, will rename set_ip to set_instruction_pointer. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: email@kvack.org