All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Ben Widawsky <ben@bwidawsk.net>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 1/3] drm/i915: make FDI training a display function
Date: Wed, 20 Apr 2011 08:16:44 -0700	[thread overview]
Message-ID: <20110420081644.3b928320@jbarnes-desktop> (raw)
In-Reply-To: <20110420144508.GA12517@lundgren.kumite>

On Wed, 20 Apr 2011 07:45:08 -0700
Ben Widawsky <ben@bwidawsk.net> wrote:
> > @@ -7270,6 +7267,7 @@ static void intel_init_display(struct drm_device *dev)
> >  					      "Disable CxSR\n");
> >  				dev_priv->display.update_wm = NULL;
> >  			}
> > +			dev_priv->display.train_fdi = ironlake_fdi_link_train;
> >  		} else if (IS_GEN6(dev)) {
> >  			if (SNB_READ_WM0_LATENCY()) {
> >  				dev_priv->display.update_wm = sandybridge_update_wm;
> > @@ -7278,6 +7276,7 @@ static void intel_init_display(struct drm_device *dev)
> >  					      "Disable CxSR\n");
> >  				dev_priv->display.update_wm = NULL;
> >  			}
> > +			dev_priv->display.train_fdi = gen6_fdi_link_train;
> >  		} else
> >  			dev_priv->display.update_wm = NULL;
> >  	} else if (IS_PINEVIEW(dev)) {
> 
> I prefer when the function pointer is named similarly to the function.
> Makes it easier to read/find code.
> 
> (*fdi_link_train)(struct drm_crtc *crtc);
> OR
> (*link_train)(struct drm_crtc *crtc);

Yeah, fdi_link_train is probably a better name.  Thanks for checking it
out.

-- 
Jesse Barnes, Intel Open Source Technology Center

  reply	other threads:[~2011-04-20 15:16 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-04-07 21:32 (no subject) Jesse Barnes
2011-04-07 21:32 ` [PATCH 1/3] drm/i915: make FDI training a display function Jesse Barnes
2011-04-20 14:45   ` Ben Widawsky
2011-04-20 15:16     ` Jesse Barnes [this message]
2011-04-07 21:32 ` [PATCH 2/3] drm/i915: split irq handling into per-chipset functions Jesse Barnes
2011-04-07 21:50   ` Chris Wilson
2011-04-07 22:04     ` Jesse Barnes
2011-04-07 22:13       ` Chris Wilson
2011-04-07 21:33 ` [PATCH 3/3] drm/i915: split enable/disable vblank code into chipset specific functions Jesse Barnes

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110420081644.3b928320@jbarnes-desktop \
    --to=jbarnes@virtuousgeek.org \
    --cc=ben@bwidawsk.net \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.