All of lore.kernel.org
 help / color / mirror / Atom feed
From: "John W. Linville" <linville@tuxdriver.com>
To: Javier Lopez <jlopex@gmail.com>
Cc: linux-wireless@vger.kernel.org, j@w1.fi, javier@cozybit.com
Subject: Re: [PATCH v2] mac80211_hwsim driver support userspace frame tx/rx
Date: Thu, 28 Apr 2011 14:34:36 -0400	[thread overview]
Message-ID: <20110428183435.GB2511@tuxdriver.com> (raw)
In-Reply-To: <1303500703-24157-1-git-send-email-jlopex@gmail.com>

On Fri, Apr 22, 2011 at 09:31:43PM +0200, Javier Lopez wrote:
> This is an updated patch that solve the issues found in the previous 
> patch, it adds frame exchange capabilities with userspace to 
> mac80211_hwsim driver. Allowing user space applications to decide if a 
> frame should be dropped or not.
> 
> Frame exchange between kernel and userspace is done through a generic 
> netlink communication protocol, a new family called HWSIM is proposed 
> in order to communicate with userspace applications. This family 

> +static struct genl_family hwsim_genl_family = {
> +	.id = GENL_ID_GENERATE,
> +	.hdrsize = 0,
> +	.name = "HWSIM",
> +	.version = VERSION_NR,
> +	.maxattr = HWSIM_ATTR_MAX,
> +};

I don't have any big objections to this patch.  But I think that
"HWSIM" is not a very good name.  Most/all of the other genl_family
definitions seem to use a name specific to their function.  While
"HWSIM" is somewhat descriptive, it seems prone to confusion.  I would
prefer to see a name like "mac80211_hwsim".

John

P.S.  Sorry to "bikeshed" this...
-- 
John W. Linville		Someday the world will need a hero, and you
linville@tuxdriver.com			might be all we have.  Be ready.

  reply	other threads:[~2011-04-28 18:45 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-04-18 20:45 [PATCH] mac80211_hwsim driver support userspace frame tx/rx Javier Lopez
2011-04-19  2:19 ` Javier Cardona
2011-04-22 19:31   ` [PATCH v2] " Javier Lopez
2011-04-28 18:34     ` John W. Linville [this message]
2011-05-01 19:29   ` [PATCH v3] " Javier Lopez
2011-05-01 21:35     ` Johannes Berg
2011-05-11 21:32   ` [PATCH v4] " Javier Lopez
2011-05-18  0:09     ` Javier Cardona
2011-05-18 20:58       ` Johannes Berg
2011-05-19 16:00     ` Johannes Berg
2011-05-25 10:41   ` [PATCH v5] " Javier Lopez
2011-05-25 19:03   ` [PATCH v6] " Javier Lopez
2011-05-26  3:54     ` Johannes Berg
2011-05-31 21:29   ` [PATCH v7] " Javier Lopez
2011-05-31 22:06   ` Javier Lopez
2011-06-01  4:16     ` Johannes Berg
     [not found]       ` <BANLkTinE0axwc_X9Gt=qdrjufopvPNADng@mail.gmail.com>
2011-06-01  8:48         ` Johannes Berg
2011-06-01  9:26   ` [PATCH v8] " Javier Lopez

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110428183435.GB2511@tuxdriver.com \
    --to=linville@tuxdriver.com \
    --cc=j@w1.fi \
    --cc=javier@cozybit.com \
    --cc=jlopex@gmail.com \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.