From mboxrd@z Thu Jan 1 00:00:00 1970 From: Mike Frysinger Date: Thu, 1 Sep 2011 09:52:08 -0400 Subject: [U-Boot] [PATCH 01/15] Make bootm optionally use pre-existing atags for Linux kernel boot. In-Reply-To: <1314876881-9669-1-git-send-email-pali.rohar@gmail.com> References: <201109011304.46581.marek.vasut@gmail.com> <1314876881-9669-1-git-send-email-pali.rohar@gmail.com> Message-ID: <201109010952.09122.vapier@gentoo.org> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de > +#ifdef CONFIG_CHAINLOADER > + uint params; > + #define PARAMS params > +#else > + #define PARAMS (bd->bi_boot_params) > +#endif do not indent the "#" with preprocessors also, this can be rewritten a bit. always declare uint params regardless of the define, and then when in the chainloader logic, set it to the env value, otherwise set it to bd->bi_boot_params. then you can delete this dedicated and ugly "PARAMS" define. > +#ifdef CONFIG_CHAINLOADER this is kind of a crappy define. how about "CONFIG_ATAGSADDR". also, you'll need to update toplevel README to document the new option. > + s = getenv ("atags"); "atagsaddr" is probably a better name as a plain "atags" can be interpreted multiple ways > + params = simple_strtoul (s, NULL, 16); no spaces before the open paren in func calls. wrong: foo (a); right: foo(a); > + printf ("Using existing atags at 0x%x\n", params); 0x%x -> %#x -mike -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 836 bytes Desc: This is a digitally signed message part. Url : http://lists.denx.de/pipermail/u-boot/attachments/20110901/521a388d/attachment.pgp