All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE.
@ 2012-04-20 12:13 Dave Airlie
  2012-04-20 12:13 ` [PATCH 2/2] drm/nouveau: fix open-coded ARRAY_SIZE in volt code Dave Airlie
  2012-04-20 12:24 ` [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Chris Wilson
  0 siblings, 2 replies; 4+ messages in thread
From: Dave Airlie @ 2012-04-20 12:13 UTC (permalink / raw)
  To: dri-devel

From: Dave Airlie <airlied@redhat.com>

Signed-off-by: Dave Airlie <airlied@redhat.com>
---
 drivers/gpu/drm/i915/intel_tv.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/gpu/drm/i915/intel_tv.c b/drivers/gpu/drm/i915/intel_tv.c
index ca12c70..67f444d 100644
--- a/drivers/gpu/drm/i915/intel_tv.c
+++ b/drivers/gpu/drm/i915/intel_tv.c
@@ -811,7 +811,7 @@ intel_tv_mode_lookup(const char *tv_format)
 {
 	int i;
 
-	for (i = 0; i < sizeof(tv_modes) / sizeof(tv_modes[0]); i++) {
+	for (i = 0; i < ARRAY_SIZE(tv_modes); i++) {
 		const struct tv_mode *tv_mode = &tv_modes[i];
 
 		if (!strcmp(tv_format, tv_mode->name))
-- 
1.7.7.6

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/2] drm/nouveau: fix open-coded ARRAY_SIZE in volt code
  2012-04-20 12:13 [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Dave Airlie
@ 2012-04-20 12:13 ` Dave Airlie
  2012-04-20 12:24 ` [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Chris Wilson
  1 sibling, 0 replies; 4+ messages in thread
From: Dave Airlie @ 2012-04-20 12:13 UTC (permalink / raw)
  To: dri-devel

From: Dave Airlie <airlied@redhat.com>

Signed-off-by: Dave Airlie <airlied@redhat.com>
---
 drivers/gpu/drm/nouveau/nouveau_volt.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/gpu/drm/nouveau/nouveau_volt.c b/drivers/gpu/drm/nouveau/nouveau_volt.c
index b010cb9..fdc8f77 100644
--- a/drivers/gpu/drm/nouveau/nouveau_volt.c
+++ b/drivers/gpu/drm/nouveau/nouveau_volt.c
@@ -29,7 +29,7 @@
 #include "nouveau_gpio.h"
 
 static const enum dcb_gpio_tag vidtag[] = { 0x04, 0x05, 0x06, 0x1a, 0x73 };
-static int nr_vidtag = sizeof(vidtag) / sizeof(vidtag[0]);
+static int nr_vidtag = ARRAY_SIZE(vidtag);
 
 int
 nouveau_voltage_gpio_get(struct drm_device *dev)
-- 
1.7.7.6

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE.
  2012-04-20 12:13 [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Dave Airlie
  2012-04-20 12:13 ` [PATCH 2/2] drm/nouveau: fix open-coded ARRAY_SIZE in volt code Dave Airlie
@ 2012-04-20 12:24 ` Chris Wilson
  2012-04-20 13:56   ` Daniel Vetter
  1 sibling, 1 reply; 4+ messages in thread
From: Chris Wilson @ 2012-04-20 12:24 UTC (permalink / raw)
  To: Dave Airlie, dri-devel

On Fri, 20 Apr 2012 13:13:54 +0100, Dave Airlie <airlied@gmail.com> wrote:
> From: Dave Airlie <airlied@redhat.com>
> 
> Signed-off-by: Dave Airlie <airlied@redhat.com>
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE.
  2012-04-20 12:24 ` [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Chris Wilson
@ 2012-04-20 13:56   ` Daniel Vetter
  0 siblings, 0 replies; 4+ messages in thread
From: Daniel Vetter @ 2012-04-20 13:56 UTC (permalink / raw)
  To: Chris Wilson; +Cc: dri-devel

On Fri, Apr 20, 2012 at 01:24:59PM +0100, Chris Wilson wrote:
> On Fri, 20 Apr 2012 13:13:54 +0100, Dave Airlie <airlied@gmail.com> wrote:
> > From: Dave Airlie <airlied@redhat.com>
> > 
> > Signed-off-by: Dave Airlie <airlied@redhat.com>
> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Queued for -next, thanks for the patch.
-Daniel
-- 
Daniel Vetter
Mail: daniel@ffwll.ch
Mobile: +41 (0)79 365 57 48

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2012-04-20 13:55 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-20 12:13 [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Dave Airlie
2012-04-20 12:13 ` [PATCH 2/2] drm/nouveau: fix open-coded ARRAY_SIZE in volt code Dave Airlie
2012-04-20 12:24 ` [PATCH 1/2] drm/i915/tv: fix open-coded ARRAY_SIZE Chris Wilson
2012-04-20 13:56   ` Daniel Vetter

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.